Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 31.0 - slowness and script problems for using websites

  • 12 replies
  • 45 have this problem
  • 13 views
  • Last reply by FredMcD

more options

Since Firefox 31.0 is released, some technical problems of slowness and script problems to use websites have been noticed from mine. Sometimes it needs up to some minutes to load a website and sometimes there are error messages for an unanswered script.

pemigabo123

All Replies (12)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

  • Remove Cookies

Warning ! ! This will log you out of all sites you're logged in to. Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

Hello FredMcD,

thank you for your message. But your answer to my question at support.mozilla.org is not helpful, although it is a professional technical answer from a Top 10 Contributor from mozilla.

It seems that there is a permanent unfixed problem always if a new version of mozilla is released. After all fixed problems of the earlier version of firefox, there is no problem at all. But if I am already working with the non-problem earlier version of firefox, then suddenly the problems of error messages, slowness and script errors are appearing, and if I have looked for the actual version of firefox, there was signed a new version and now I have known, aha a new vesion of firefox was released and it needs up some time for every new version until the error problems were fixed. Maybe it is combined with the plugins like flashplayer or shockwave. But a professional version of firefox should not sign up error messages, because of plugins, while working with these plugins. Another answer from another support.mozilla.member was for an overload problem, because of opening some windows of firefox. But to open many windows of firefox was already no problem with the earlier version firefox 30.0 or earlier, until the error messages are fixed.

The same unfixed problems are since firefox 25.0 up to 30.0, but I was wondering for how long version 30.0 was actual in practical working. And since version of firefox 31.0 was released the same problems of error messages, slowness and script errors were appearing.

At the moment it seems firefox 31.0 works alright. But only the following time shows if it works without error messages, slowness and sript problems or not.

In hope to give a helpful answer to yours kind regards pemigabo123

more options

Hello FredMcD,

thank you for your message. I want to send you a second answer from mine for your technical help. But I have got this kind of answer several times from some other members of support.mozilla.org, and I have started firefox with deactivated addons or in safe mode. But the only thing of "technical problem" I have got then, was to get lost in all bookmarks. If I would have not saved bookmarks before, I would have lost them for all, so you have to know that you will get lost in all bookmarks while starting firefox in safe mode.

But error messages, slowness and script error messages are still there, and it was not fixed through starting firefox with deactivated addons or in safe mode.

kind regards pemigabo123

more options

What is the name of the scripts giving you errors? Is it the same site? Some sites, all sites?

more options

I include an image of the warning I get because you can't copy and paste from the messages. The general very serious slowdown loading nearly all sites and the frequency of these messages, not always from the same source, all began with 31.0 so there is an unacknowledged problem with that release and it _must_ be fixed. This kind of broken release has happened way, way too often in the history of FF releases.

Making it possible to copy the text from these messages would be friendly. It's hard to search Google on a long string you can only read with your eyes.

more options

Don,

I answered the question that you asked. https://support.mozilla.org/en-US/questions/1014882#answer-614020

more options

FredMcD,

thank you for your message. At the moment firefox 31.0 works alright and I do not have got another error message from scripts. But it was not only a slowness combined with script error messages. it is also something else in different kinds. And I suppose it is combined with udates for other plugins.

But on the other hand I do not prefer to make experimental starts with firefox at all. If I want to use a webbrowser it needs to be well working and not to have been got in experience which error messages could be appearing in the next firefox version.

I will take part in the firefox community to report and post a comment, if something works not well with firefox or with thunderbird to help to find it for you as mozilla support team. And I hope this support from mine could help you to make firefox better.

kind regards pemigabo123

more options

@the-edmeister: Indeed you did and it solved the problem perfectly. Thanks again.

Modified by DonGateley

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

@FredMcD: If you are replying to me, I would if I was the thread owner. Since I'm not all I can do is vote yes for helpful. I think.

more options

Hello FredMcD,

I want to send you a message again to my post "Firefox 31.0 - slowness and script problems for using websites", because I have noticed some of the described technical issues to firefox 31.0 again. Since some of the plugins for firefox have been updated too, firefox works alright, and it seems that all problems of slowness and scripts are fixed. But it would be necessary that updates are released similar to each other, but not to different points of time. And if I do not know if the plugins of adobe or java will be updated or not, it seemed for first that the technical issues have been only depending to firefox. To start firefox in safe mode would not have solved the problem of slowness.

I think an update checker or update manager should help for a browser like firefox. Maybe if a new version of firefox would be released it could help to make updating combined with plugins more helpful to a similar point of time. But it needs to check up before, if a new update for adobe flashplayer, adobe shockwave or jave would be released too.

pemigabo123

more options

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.