X
Tap here to go to the mobile version of the site.

Support Forum

My PDF file icons are changed as firefox icons.. how can i get pdf icons for pdf files

Posted

I m using windows xp... in my computer all pdf file icons changed as a firefox icons. it is so difficult to find the files. so try to tell me how to change pdf icons for pdf files.

I m using windows xp... in my computer all pdf file icons changed as a firefox icons. it is so difficult to find the files. so try to tell me how to change pdf icons for pdf files.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • PDF Architect 2
  • VLC media player Web Plugin 2.1.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

GINAHERE 2 solutions 64 answers

thank you soooooooooooo much. i agree, it is hijavking my pdf files and i am so mad i could spit.

i don't need the browser. 
who needs to be treatd like this?
chrome is good. and i also don't mind ie in fact -- when i tried to log into my paypal account, i had to swtich from fire fox because it just hjung and wojld not go there. what they are doing here is bad.

nad

thank you soooooooooooo much. i agree, it is hijavking my pdf files and i am so mad i could spit. i don't need the browser. who needs to be treatd like this? chrome is good. and i also don't mind ie in fact -- when i tried to log into my paypal account, i had to swtich from fire fox because it just hjung and wojld not go there. what they are doing here is bad. nad
DeathBunny2000 0 solutions 2 answers

I did that and the icons changed back to .PDF, but today they were Firefox html icons again. So, apparently there is some kind of problem.

I did that and the icons changed back to .PDF, but today they were Firefox html icons again. So, apparently there is some kind of problem.
jscher2000
  • Top 10 Contributor
8637 solutions 70651 answers

Hi GINAHERE, you probably have found a workaround by now. But just in case:

(1) To have PDFs open in your preferred PDF viewer, such as Adobe Reader, right-click a PDF on disk and use the Open With function to choose that program. If Open With does not appear on a regular right-click, try Shioft+right-click.

(2) To have the description of PDFs change from Firefox HTML file to Adobe PDF document (or whatever it was before) is more work, as you can read in this thread.

Hi GINAHERE, you probably have found a workaround by now. But just in case: (1) To have PDFs open in your preferred PDF viewer, such as Adobe Reader, right-click a PDF on disk and use the Open With function to choose that program. If Open With does not appear on a regular right-click, try Shioft+right-click. (2) To have the description of PDFs change from Firefox HTML file to Adobe PDF document (or whatever it was before) is more work, as you can read in this thread.
GINAHERE 2 solutions 64 answers

Hello

I just uninstalled the browser I have used for years. First, I really don't like this hijacking of my pdf files. If Mozilla had asked, or showed an option, it would be different. But it really confused me at first. Like, hey where did my pdf files go?
 When I uninstalled, my files returned to pdf.
I have read from another on this forum that you can re-install foxfire, but do NOT make it your default browser and the files will stay pdf.
 I haven't re-installed. I just don't care for Mozilla doing that. I did install chrome because it's good to have a second browser. I don't know if the safari would do that, either, but what Mozilla did was very bad policy.
 It's weird because I've used foxfire forever, but I'm liking IE. 
 I also ran into some issues very recently, such as logging into my PayPal account with foxfire: that little circle would continue and continue and it would never go to the page. I'd have to use IE for that. So, whatever it is, I could not figure it out, and feel maybe the Mozilla browser has outlived its usefulness. I don't like aggressive actions that usurp my choice, and clearly I'm not the only one.
Hello I just uninstalled the browser I have used for years. First, I really don't like this hijacking of my pdf files. If Mozilla had asked, or showed an option, it would be different. But it really confused me at first. Like, hey where did my pdf files go? When I uninstalled, my files returned to pdf. I have read from another on this forum that you can re-install foxfire, but do NOT make it your default browser and the files will stay pdf. I haven't re-installed. I just don't care for Mozilla doing that. I did install chrome because it's good to have a second browser. I don't know if the safari would do that, either, but what Mozilla did was very bad policy. It's weird because I've used foxfire forever, but I'm liking IE. I also ran into some issues very recently, such as logging into my PayPal account with foxfire: that little circle would continue and continue and it would never go to the page. I'd have to use IE for that. So, whatever it is, I could not figure it out, and feel maybe the Mozilla browser has outlived its usefulness. I don't like aggressive actions that usurp my choice, and clearly I'm not the only one.
GINAHERE 2 solutions 64 answers

If you want to keep your files in pdf you have to re-install but do NOT make foxfire your default browser.

 Personally, the fact that any browser would hijack my pdf files and change them to something I didn't want, don't recognize and not offer me the option, is not what I want to use any way.
 I installed chrome and IE is what I use. I am liking it, but it's taking a while getting use to it. 
 Truth be told, there were so many things done with foxfire when it started out as a really good option to IE, but too much this and that done to it -- I think ruins a good thing.
Hope this helps -- reinstall, but don't make it default.
If you want to keep your files in pdf you have to re-install but do NOT make foxfire your default browser. Personally, the fact that any browser would hijack my pdf files and change them to something I didn't want, don't recognize and not offer me the option, is not what I want to use any way. I installed chrome and IE is what I use. I am liking it, but it's taking a while getting use to it. Truth be told, there were so many things done with foxfire when it started out as a really good option to IE, but too much this and that done to it -- I think ruins a good thing. Hope this helps -- reinstall, but don't make it default.
GINAHERE 2 solutions 64 answers

Hi jsher

I just wanted to add this: My first action was to open a file and then under the save as, I saved it as a pdf. However, it changed right back. Nothing else changed to a pdf. So doing that didn't help. The only way is to uninstall foxfire. If you want to use it, re-install but don't make it the default. I hope a lot of people protest, so Mozilla will realize it needs to re-think this, ask people first let users decide and have a way to change this without uninstall, reinstall etc.
Hi jsher I just wanted to add this: My first action was to open a file and then under the save as, I saved it as a pdf. However, it changed right back. Nothing else changed to a pdf. So doing that didn't help. The only way is to uninstall foxfire. If you want to use it, re-install but don't make it the default. I hope a lot of people protest, so Mozilla will realize it needs to re-think this, ask people first let users decide and have a way to change this without uninstall, reinstall etc.
jscher2000
  • Top 10 Contributor
8637 solutions 70651 answers

Hi GINAHERE, what you are experiencing is a glitch occurring on some systems. The Firefox installer is not supposed to displace an existing PDF viewer, only add Firefox as the PDF viewer in case you do not have an existing PDF viewer.

Hi GINAHERE, what you are experiencing is a glitch occurring on some systems. The Firefox installer is not supposed to displace an existing PDF viewer, only add Firefox as the PDF viewer in case you do not have an existing PDF viewer.
GINAHERE 2 solutions 64 answers

I have a pdf viewer, but Mozilla hijacked them. I think they are doing that in a number of cases. If I did nt have a pdf viewer, I would not be able to view these files, or create them.

 I saved in pdf, but it reverted back and I just thought that entire thing was bad policy, not to ask, not to send out update and create it as such people have a choice.
I have a pdf viewer, but Mozilla hijacked them. I think they are doing that in a number of cases. If I did nt have a pdf viewer, I would not be able to view these files, or create them. I saved in pdf, but it reverted back and I just thought that entire thing was bad policy, not to ask, not to send out update and create it as such people have a choice.
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157354 answers

The Firefox installer checks some registry keys to see if there is currently an application registered to handle PDF files. If not all registry keys exist or are configured properly then Firefox will think that it needs to register itself to handle such files.

  • bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

The Firefox installer checks some registry keys to see if there is currently an application registered to handle PDF files. If not all registry keys exist or are configured properly then Firefox will think that it needs to register itself to handle such files. *[https://bugzilla.mozilla.org/show_bug.cgi?id=452254 bug 452254] - Register for audio/video .ogg and .pdf file handlers if nothing else has <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>
DVEE 0 solutions 6 answers

I had the same problem. The ONLY way to resolve it with Firefox 31 is to uninstall Firefox, then reinstall it but DO NOT SET IT AS YOUR DEFAULT browser! Unistalling it restores your PDF files. When you reinstall it, the PDF files will survive just fine unless you set Firefox as your default. You can still use Firefox all the time, it just can't be your default browser. If you do set it as your default, your PDFs turn into something else and will not be PDFs again even if you then unset it as your default. You actually have to uninstall and reinstall without EVER setting it as your default. Hopefully the designers of Firefox will get this horrific gliche corrected in Firefox 32!

I had the same problem. The ONLY way to resolve it with Firefox 31 is to uninstall Firefox, then reinstall it but DO NOT SET IT AS YOUR DEFAULT browser! Unistalling it restores your PDF files. When you reinstall it, the PDF files will survive just fine unless you set Firefox as your default. You can still use Firefox all the time, it just can't be your default browser. If you do set it as your default, your PDFs turn into something else and will not be PDFs again even if you then unset it as your default. You actually have to uninstall and reinstall without EVER setting it as your default. Hopefully the designers of Firefox will get this horrific gliche corrected in Firefox 32!
GINAHERE 2 solutions 64 answers

Thanks. I haven't re-downloaded and I'm not sure I will. But thanks for the fix. I hope, too, that firefox fixes this. No matter what excuses, it's a bad thing to do to users.

  I was thinking, too bad you can't roll back to previous versions of firefox. I liked previous versions. Every time they update, there is different. Just changing things isn't always good.
Thanks. I haven't re-downloaded and I'm not sure I will. But thanks for the fix. I hope, too, that firefox fixes this. No matter what excuses, it's a bad thing to do to users. I was thinking, too bad you can't roll back to previous versions of firefox. I liked previous versions. Every time they update, there is different. Just changing things isn't always good.

Modified by GINAHERE

Bob_in_Calgary 0 solutions 5 answers

I also had this major screw up courtesy of Mozilla. I tried all of the various solution from various threads except f'king with the registry. I use Win XP pro 32 and pro 64. Here is the solution that worked on both of my computers. -Let Firefox complete the v31 update and set it as the default browser. -Completely un-install your PDF reader software (I use Foxit). -RE-install the PDF software with the options you normally choose. This restored all my PDF icons and file type descriptions back to what they should be. I hope this works for you as well. The Mozilla Firefox coders deserve a good slap on the head for causing this problem and others. I had to use the "Classic theme restorer" to fix the last one.

I also had this major screw up courtesy of Mozilla. I tried all of the various solution from various threads except f'king with the registry. I use Win XP pro 32 and pro 64. Here is the solution that worked on both of my computers. -Let Firefox complete the v31 update and set it as the default browser. -Completely un-install your PDF reader software (I use Foxit). -RE-install the PDF software with the options you normally choose. This restored all my PDF icons and file type descriptions back to what they should be. I hope this works for you as well. The Mozilla Firefox coders deserve a good slap on the head for causing this problem and others. I had to use the "Classic theme restorer" to fix the last one.
GINAHERE 2 solutions 64 answers

Thank you much. I don't have a lot of time but when I get a chance, I'll try that. Or maybe just not make firefox the default browser. I agree, most of all, never should this have happened. It's way overreaching. Meanwhile, it's given me a chance to finally get to know chrome and get reacquainted with ie.

Thank you much. I don't have a lot of time but when I get a chance, I'll try that. Or maybe just not make firefox the default browser. I agree, most of all, never should this have happened. It's way overreaching. Meanwhile, it's given me a chance to finally get to know chrome and get reacquainted with ie.
MuhammadIslam 0 solutions 1 answers

I had the same problem with Firefox 31 on Windows XP and this is how I fixed it. Now everything is in order.

Step1: Open Firefox > Tools > Options > Applications > Content type [Adobe forms] > Action: Select Adobe reader

Step 2: Uninstall and reinstall Firefox.

Step 3: Go to the PDF file which you want to be opened > Right click on the file >Select open with >Choose your Adobe reader as the application > check the mention “always open with same application which i selected”

You may need to restart your computer for the changes to be effective.

I had the same problem with Firefox 31 on Windows XP and this is how I fixed it. Now everything is in order. Step1: Open Firefox > Tools > Options > Applications > Content type [Adobe forms] > Action: Select Adobe reader Step 2: Uninstall and reinstall Firefox. Step 3: Go to the PDF file which you want to be opened > Right click on the file >Select open with >Choose your Adobe reader as the application > check the mention “always open with same application which i selected” You may need to restart your computer for the changes to be effective.
cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157354 answers
See also: *[[/questions/1014919#answer-618531]]
AliceWyman
  • Moderator
240 solutions 2593 answers

rameezmrr, are you still looking for a solution? You haven't posted a reply in this thread since July 10th.

The answer mentioned by cor-el worked for me (I opened Adobe Reader XI, went to Edit -> Preferences -> General and clicked the button, "Select Default PDF Handler"). For details, see

'''rameezmrr''', are you still looking for a solution? You haven't posted a reply in this thread since July 10th. The answer mentioned by cor-el worked for me (I opened Adobe Reader XI, went to Edit -> Preferences -> General and clicked the button, "Select Default PDF Handler"). For details, see *[/questions/1014919#answer-618531] pdf files now have a firefox icon
js.bigata 0 solutions 5 answers

The following completely solved same problem for me :

Control Panel > Folder Options > File Types > New > PDF > Advanced > >Associated File Type, and choose "Adobe PDF reader"

The following completely solved same problem for me : Control Panel > Folder Options > File Types > New > PDF > Advanced > >Associated File Type, and choose "Adobe PDF reader"
GINAHERE 2 solutions 64 answers

Wow it took me all day to log in. I think this website has issues.

  I did not need to do anything with adobe, thankfully. The latest version of Firefox has the options in the tools, you can choose which program you want to open not just pdf files, but music files, etc. THAT was a great idea.
I would have responded this morning but between forgetting I had to use a user name, and then re-setting my password over and over, and it was the user name. 
I think the fix that firefox did is excellent. No messing around with adobe etc.
Wow it took me all day to log in. I think this website has issues. I did not need to do anything with adobe, thankfully. The latest version of Firefox has the options in the tools, you can choose which program you want to open not just pdf files, but music files, etc. THAT was a great idea. I would have responded this morning but between forgetting I had to use a user name, and then re-setting my password over and over, and it was the user name. I think the fix that firefox did is excellent. No messing around with adobe etc.
cortina_ed 0 solutions 2 answers

Google chrome highjacked my PC and when I uninstalled it. I was left with this problem. Chrome is at fault, It has Highjacked Adobe as well wont let me ask for help. Chrome is CRAP.

Google chrome highjacked my PC and when I uninstalled it. I was left with this problem. Chrome is at fault, It has Highjacked Adobe as well wont let me ask for help. Chrome is CRAP.
Mark H. 0 solutions 1 answers

This link /questions/1014919#answer-618531 mentioned above worked beautifully! Thank you very much!

This link /questions/1014919#answer-618531 mentioned above worked beautifully! Thank you very much!