ძიება მხარდაჭერაში

ნუ გაებმებით თაღლითების მახეში მხარდაჭერის საიტზე. აქ არასდროს მოგთხოვენ სატელეფონო ნომერზე დარეკვას, შეტყობინების გამოგზავნას ან პირადი მონაცემების გაზიარებას. გთხოვთ, გვაცნობოთ რამე საეჭვოს შემჩნევისას „დარღვევაზე მოხსენების“ მეშვეობით.

Learn More

slow opening of external links

  • 15 პასუხი
  • 0 მომხმარებელი წააწყდა მსგავს სიძნელეს
  • 6 ნახვა
  • ბოლოს გამოეხმაურა jonzn4SUSE

Using firefox version 102.3.0esr (64-bit) on openSUSE Leap. Since a couple of weeks the opening of external links by clicking a link from any application or when running firefox <url> is taking about 5 seconds when the browser is already open. This was always instantly and still is on same setup on laptop machine, both are updated to the most recent OS packages.

I've tried safe-mode, new profile, copied profile from the laptop, searched online for references but so far I can't pinpoint what the issue seems to be.

Any kind of information as to resolving this issue would be greatly appreciated.

Using firefox version 102.3.0esr (64-bit) on openSUSE Leap. Since a couple of weeks the opening of external links by clicking a link from any application or when running firefox <url> is taking about 5 seconds when the browser is already open. This was always instantly and still is on same setup on laptop machine, both are updated to the most recent OS packages. I've tried safe-mode, new profile, copied profile from the laptop, searched online for references but so far I can't pinpoint what the issue seems to be. Any kind of information as to resolving this issue would be greatly appreciated.

ყველა პასუხი (15)

Opening links from within the browser does not give me this delay at all.

გამოსადეგია?

What version of openSUSE are you on? You may have to run strace to see what Firefox is doing when you click on a link from another app. I've been Tumbling for so long, I thought I'd give Leap a try. Just installed 15.5 Alpha and will see if I have the same issue.

Try downloading Firefox from Mozilla, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Also, you should run multiple versions of Firefox as a backup for your data if you sync. see old screenshot

ჩასწორების თარიღი: , ავტორი: jonzn4SUSE

გამოსადეგია?

No issue on 15.5 for me. see screenshot


Operating System: openSUSE Leap 15.5 KDE Plasma Version: 5.24.4 KDE Frameworks Version: 5.90.0 Qt Version: 5.15.2 Kernel Version: 5.14.21-150500.30-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD RENOIR

ჩასწორების თარიღი: , ავტორი: jonzn4SUSE

გამოსადეგია?

Same for me on my old laptop running 15.4. I clicked the What's New link and a tab opened without delay. see screenshot


Operating System: openSUSE Leap 15.4 KDE Plasma Version: 5.24.4 KDE Frameworks Version: 5.90.0 Qt Version: 5.15.2 Kernel Version: 5.14.21-150400.24.18-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-3520M CPU @ 2.90GHz Memory: 15.6 GiB of RAM Graphics Processor: llvmpipe

გამოსადეგია?

openSUSE 15.4. I'm following the normal release path.

On my laptop it works as expected and that one should more or less be the same as the problematic system. But with the empty profile and the copied working profile not giving a different result my current thinking it is something outside of firefox on that box that is causing this delay but I might be proved wrong here.

გამოსადეგია?

What happens under a different user account?

გამოსადეგია?

Same thing happens. I'm getting the feeling the problem might be outside of FF with a dependency but so far no clue what. And not sure how to properly investigate it.

გამოსადეგია?

This is definitely not a Firefox issue. I would recommend just running the Distro version of Firefox as a secondary and run Firefox from Mozilla as your primary browser. You can run strace to what happens when you click a link from another app.

Start Firefox, get the process id (ps -fe | grep firefox), then run the cmd from my screenshot with the process id for Firefox. Then click a link from another app, make note of the time clicked it, and then go look at the logs to see what happened.

გამოსადეგია?

Post a screenshot of your partition table. see screenshot My laptop has 3 drives (1 m.2 and 2 2.5 ssd) and I dual boot Win 11.

გამოსადეგია?

I did the strace as suggested on both openSUSE en mozilla provided firefox. They both have the same delay of around 5 seconds. firefox.log is the one from openSUSE version. I can see 5 seconds after I clicked the link 14:35:05 access("/tmp/www.ad.nl", F_OK) = -1 ENOENT (No such file or directory). That is the only reference to the link I have found. Clearly here it is trying to access it as local directory. Not sure what happens before that as I'm not familiar with strace and output of it. The firefox-local.log is from the mozilla version and as mentioned I see the same behavior. 14:42:20 access("/usr/local/bin/firefox/www.ad.nl", F_OK) = -1 ENOENT (No such file or directory)

I wanted and intended to upload the 2 logs but I have no clue whether I can do that within this forum. Is there some default way of uploading attachments or are you using external tools. The reduced files are 1.6 and 2.2Mb in size.

My partitions for root and /home are each in it's own partition on an ssd raid 1 partition. The data profile of the original openSUSE is on a 4 disk raid5 partition. But this setup I have used for 5-10years or something without having this issue. All partitions are ext4.

გამოსადეგია?

I did another strace on a laptop where there is no delay and I do not see that line where it tries to access the link as a directory. Is that any clue?

გამოსადეგია?

Not sure why it's trying to access that site. I would just run Firefox from Mozilla and you can sync your data to it. You should also bookmark this site to upload logs. https://paste.opensuse.org/

ჩასწორების თარიღი: , ავტორი: jonzn4SUSE

გამოსადეგია?

I uploaded the logs

https://paste.opensuse.org/69989000 the strace from the non delayed laptop https://paste.opensuse.org/26492234 the strace from my main machine that is having the delay issue. This log is way bigger and has a ton of gettime and recv_message calls, way way more than the other listing

14:35:01 clock_gettime(CLOCK_MONOTONIC, {tv_sec=330563, tv_nsec=802688176}) = 0 14:35:01 recvmsg(4, {msg_namelen=0}, 0) = -1 EAGAIN (Resource temporarily unavailable)

I have no clue what is causing them though

გამოსადეგია?

Sorry was posted again as site was slow in response

ჩასწორების თარიღი: , ავტორი: dutchguy69

გამოსადეგია?

I would ask on this forum. --> forums.opensuse.org Maybe some closer to dev can take a look at the output on the forum.

გამოსადეგია?

დასვით კითხვა

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.