ძიება მხარდაჭერაში

ნუ გაებმებით თაღლითების მახეში მხარდაჭერის საიტზე. აქ არასდროს მოგთხოვენ სატელეფონო ნომერზე დარეკვას, შეტყობინების გამოგზავნას ან პირადი მონაცემების გაზიარებას. გთხოვთ, გვაცნობოთ რამე საეჭვოს შემჩნევისას „დარღვევაზე მოხსენების“ მეშვეობით.

Learn More

Problem accessing New York Times articles

  • 17 პასუხი
  • 0 მომხმარებელი წააწყდა მსგავს სიძნელეს
  • 14 ნახვა
  • ბოლოს გამოეხმაურა mstorin

I have a problem accessing articles in the New York Times web page. I have a Basic subscription and I am signed in. When I try to read an article, the New York Times site thinks I do not have a subscription and that I have used up all my free articles. If I use the Chrome browser, it works fine, but I do not want to use Chrome. I use FireFox for all my browsing. I have deleted cache and cookies. Tried the "Private Windows" too. I have logged out and back in. I have rebooted the machine (an Alienware 17 R5) and closed and opened Firefox. The "agents" I chatted with say this is a browser problem as everything is working fine on their side and it works in Chrome. Can anyone help me out?

Mark

I have a problem accessing articles in the New York Times web page. I have a Basic subscription and I am signed in. When I try to read an article, the New York Times site thinks I do not have a subscription and that I have used up all my free articles. If I use the Chrome browser, it works fine, but I do not want to use Chrome. I use FireFox for all my browsing. I have deleted cache and cookies. Tried the "Private Windows" too. I have logged out and back in. I have rebooted the machine (an Alienware 17 R5) and closed and opened Firefox. The "agents" I chatted with say this is a browser problem as everything is working fine on their side and it works in Chrome. Can anyone help me out? Mark

ყველა პასუხი (17)

Hi Mark, the site uses multiple servers including www.nytimes.com, myaccount.nytimes.com and nyt.com.

Firefox recently rolled out "Total Cookie Protection" to more users. This limits how sites can use "third party" cookies, meaning cookies from different servers than the one you see in the address bar. If you need different NYT servers to have "cross-site" cookie access in order to access materials on all servers, then you will need to make exceptions. Here's how:

On each different server you notice in the address bar, turn off Enhanced Tracking Protection. To do that, click the shield icon to the left of the lock icon in the address bar. Then click the slider switch to turn off protection.

Any improvement?

More info in the following articles:

გამოსადეგია?

jscher2000, I was able to turn off the Enhanced Tracking Protection for the first two servers you mentioned, but try to get to nyt.com simply took my to nytimes.com. Turning off the protection on those two servers had no effect on my problem. All articles are still being blocked.

გამოსადეგია?

Screenshots and links of what you can access in Chrome compared to what happens with Firefox would be nice.

გამოსადეგია?

Here are screen shots of the Firefox vs Chrome screens, same article being accessed. First Chrome: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-09-25-09-03-32-289ac2.png

Next Firefox: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-09-25-09-03-47-a772f5.png

You can see that the article is blocked in Firefox. NYT thinks that I do not have a subscription and have used up my free articles for the month (or whatever time period they use to determine that).

გამოსადეგია?

Hmm, that's definitely very strange. The top part of the page shows the Account menu but another part of the page seems to think you are not an account holder.

Since your toolbar appears to have a Ghostery button, you also could try using that button to turn off their blocking on the site and see whether that makes any difference. Similar for other blockers, but I don't know the buttons.

After each change, try reloading the page bypassing the cache. To do that, either:

  • Shift+click the Reload button on the toolbar
  • Ctrl+Shift+R
  • Ctrl+F5

This should force Firefox to retrieve all of the files fresh from the server.

გამოსადეგია?

jscher2000, thanks for all your help. Both Ghostery and uBlock Origin (the only two blockers I have installed) are disabled on the NYT's sites, but it had no effect. I tried bypassing the cache too. This is very frustrating.

გამოსადეგია?

Screenshot are good here but since you aren't providing URL without users login in - no one can test in FireFox or Chrome for the issues?

ჩასწორების თარიღი: , ავტორი: Dropa

გამოსადეგია?

Hi Dropa, I have an account and it's not normal for the top part of the page to show that you're logged in and the bottom part to refer to free articles like you don't have an account.

It seems that some of the scripts aren't "on the same page" as the others. My only theory for that was cross-site cookie problems, but it seems there is some other issue.

mstorin said

Both Ghostery and uBlock Origin (the only two blockers I have installed) are disabled on the NYT's sites, but it had no effect. I tried bypassing the cache too. This is very frustrating.

One of our general suggestions is to test in Firefox's Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

გამოსადეგია?

Dropa said

Screenshot are good here but since you aren't providing URL without users login in - no one can test in FireFox or Chrome for the issues?

Here's the link to the article I used without being logged in:

https://www.nytimes.com/2022/09/25/upshot/starter-home-prices.html

Hope that helps...

გამოსადეგია?

jscher2000 - Support Volunteer said

Hi Dropa, I have an account and it's not normal for the top part of the page to show that you're logged in and the bottom part to refer to free articles like you don't have an account. It seems that some of the scripts aren't "on the same page" as the others. My only theory for that was cross-site cookie problems, but it seems there is some other issue.

mstorin said

Both Ghostery and uBlock Origin (the only two blockers I have installed) are disabled on the NYT's sites, but it had no effect. I tried bypassing the cache too. This is very frustrating.

One of our general suggestions is to test in Firefox's Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Hi there, I ran Firefox in troubleshoot mode and got the same behavior. I logged in and tried accessing the same article and it still thinks I am not logged in or do not have an subscription. Same thing happens when I log out of NYT. Very frustrating.

გამოსადეგია?

Any other ideas, suggestions? I really want to resolve this issue. Up till a couple of weeks ago, I was able to access articles fine using Firefox. Now I can't access any. It is really a pain to have to switch to Chrome whenever I want to read an article that I pay good money to be able to access.

გამოსადეგია?

Just to close the loop on cookie blocking, in case we missed a site, could you change your Enhanced Tracking Protection setting to "Custom" and globally roll back the cookie block to "Cross-site tracking cookies". This is how that looks:

გამოსადეგია?

jscher2000 - Support Volunteer said

Just to close the loop on cookie blocking, in case we missed a site, could you change your Enhanced Tracking Protection setting to "Custom" and globally roll back the cookie block to "Cross-site tracking cookies". This is how that looks:

Done, no effect, but I thank you for continuing to look at my problem. It is most frustrating.

გამოსადეგია?

Did you disable Enhanced Tracking Protection as well in Firefox ?

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.

გამოსადეგია?

cor-el said

Did you disable Enhanced Tracking Protection as well in Firefox ? Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.
  • click the shield icon for more detail and possibly disable the protection
You can check the Web Console for relevant-looking messages about blocked content.

Hi cor-el, Enhanced Tracking Protection has been disabled for all the NYtimes sites. I disabled it when jscher2000 recommended it a number of days ago. I had not effect on my problem.

გამოსადეგია?

Note that you need to disable ETP in Firefox in addition of disabling other content blocking extensions to make sure that nothing is blocked.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

გამოსადეგია?

cor-el, I used "forget this site" via the browser's history and that appears to have fixed the problem. I logged back in and now I can access articles again. Unless I am somehow just getting more "free articles", in which case I will again be blocked after so many articles. I am hopeful though. Thank you cor-el and everyone who helped me with this problem! Yes!!!

Once I am sure that the issue is indeed resolved, I will mark this issue resolved. Again Thanks

გამოსადეგია?

დასვით კითხვა

უნდა შეხვიდეთ ანგარიშზე პასუხის დასაწერად. გთხოვთ, დასვათ ახალი შეკითხვა, თუ ჯერ არ გაქვთ ანგარიში.