ძიება მხარდაჭერაში

თავი დაიცავით თაღლითობებისგან. ჩვენ არასდროს მოგთხოვთ სატელეფონო ნომერზე დარეკვას, შეტყობინების გამოგზავნას ან პირადი მონაცემების გაზიარებას. გთხოვთ, გვაცნობოთ რამე საეჭვოს შემჩნევისას, „დარღვევაზე მოხსენების“ მეშვეობით.

Learn More

Firefox stuck in dark mode with a custom theme

  • 7 პასუხი
  • 1 მომხმარებელი წააწყდა მსგავს სიძნელეს
  • 361 ნახვა
  • ბოლოს გამოეხმაურა jscher2000 - Support Volunteer

I have been using the same custom theme for the past 3 years or so on both my windows 10 pro and dual boot Ubuntu 20.04. Recently, my windows 10 pro firefox started going into dark mode all of a sudden without me changing ANYTHING. The system theme and everything else stays the same. Then about 5 days later, my Ubuntu 20.04 firefox started to inherit this stupid dark mode as well. I have tried _ setting ui.systemUsesDarkTheme to 0 (number value) in about:config _ Changing to other custom color themes, and they all went into dark mode. _ Refresh Firefox _ Reinstall Firefox

When I went into "Ads on & theme" tabs, changing to system theme, it picks up the white theme mode. But Youtube webpage system theme mode pick up the dark theme mode.

I have been using the same custom theme for the past 3 years or so on both my windows 10 pro and dual boot Ubuntu 20.04. Recently, my windows 10 pro firefox started going into dark mode all of a sudden without me changing ANYTHING. The system theme and everything else stays the same. Then about 5 days later, my Ubuntu 20.04 firefox started to inherit this stupid dark mode as well. I have tried _ setting ui.systemUsesDarkTheme to 0 (number value) in about:config _ Changing to other custom color themes, and they all went into dark mode. _ Refresh Firefox _ Reinstall Firefox When I went into "Ads on & theme" tabs, changing to system theme, it picks up the white theme mode. But Youtube webpage system theme mode pick up the dark theme mode.

გადაწყვეტა შერჩეულია

Hekate said

I'm sorry, but I'm unable to access any of the link you provided.

The link doesn't open a page on the Add-ons site? Or the Add-ons site won't let you install the theme?

Regarding whether my theme is really light mode, I have been using that same theme for the past 3 years now, the text and tab bar is dark mode ish. But everything else stays the same, the webpage, the setting page, all in light theme. Only recently did those things went into dark mode. There's no reason for the theme to suddenly change all of a sudden.

Right, the theme did not change. However, starting in Firefox 96, Firefox assigns your global color-scheme based on the toolbar text color of your theme.

It's not due to the theme updating itself, else both my Ubuntu and windows would have the same theme otherwise. And I made sure to disable auto update on my Ubuntu regarding that theme. Yet, it still inherit that same dark mode that my window has.

You could try changing this preference on both systems:

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

პასუხის ნახვა სრულად 👍 1

ყველა პასუხი (7)

Firefox 96 applies a dark color scheme to menus, the sidebar, the Library window, and various built-in pages if the color of text on your toolbars is light or white. It also signals sites that you have a dark theme preference.

Did you try a theme that has dark text on the toolbars? That doesn't need to be blinding, as shown in these examples:

Regarding YouTube, it might have stored your earlier preference in a cookie. You could go through their menu to switch your preference or flush your cookies for YouTube.

jscher2000 said

Firefox 96 applies a dark color scheme to menus, the sidebar, the Library window, and various built-in pages if the color of text on your toolbars is light or white. It also signals sites that you have a dark theme preference. Did you try a theme that has dark text on the toolbars? That doesn't need to be blinding, as shown in these examples:

I'm sorry, but I'm unable to access any of the link you provided. Regarding whether my theme is really light mode, I have been using that same theme for the past 3 years now, the text and tab bar is dark mode ish. But everything else stays the same, the webpage, the setting page, all in light theme. Only recently did those things went into dark mode. There's no reason for the theme to suddenly change all of a sudden. It's not due to the theme updating itself, else both my Ubuntu and windows would have the same theme otherwise. And I made sure to disable auto update on my Ubuntu regarding that theme. Yet, it still inherit that same dark mode that my window has.

შერჩეული გადაწყვეტა

Hekate said

I'm sorry, but I'm unable to access any of the link you provided.

The link doesn't open a page on the Add-ons site? Or the Add-ons site won't let you install the theme?

Regarding whether my theme is really light mode, I have been using that same theme for the past 3 years now, the text and tab bar is dark mode ish. But everything else stays the same, the webpage, the setting page, all in light theme. Only recently did those things went into dark mode. There's no reason for the theme to suddenly change all of a sudden.

Right, the theme did not change. However, starting in Firefox 96, Firefox assigns your global color-scheme based on the toolbar text color of your theme.

It's not due to the theme updating itself, else both my Ubuntu and windows would have the same theme otherwise. And I made sure to disable auto update on my Ubuntu regarding that theme. Yet, it still inherit that same dark mode that my window has.

You could try changing this preference on both systems:

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

jscher2000 said

Hekate said

I'm sorry, but I'm unable to access any of the link you provided.

The link doesn't open a page on the Add-ons site? Or the Add-ons site won't let you install the theme?

Regarding whether my theme is really light mode, I have been using that same theme for the past 3 years now, the text and tab bar is dark mode ish. But everything else stays the same, the webpage, the setting page, all in light theme. Only recently did those things went into dark mode. There's no reason for the theme to suddenly change all of a sudden.

Right, the theme did not change. However, starting in Firefox 96, Firefox assigns your global color-scheme based on the toolbar text color of your theme.

It's not due to the theme updating itself, else both my Ubuntu and windows would have the same theme otherwise. And I made sure to disable auto update on my Ubuntu regarding that theme. Yet, it still inherit that same dark mode that my window has.

You could try changing this preference on both systems:

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

I am unable to go to any of the page you linked. Secure failure or something. However, this solution works splendidly, thank you so much. You saved me a lot of frustration, man. It means a lot.

jscher2000 - Support Volunteer said

Hekate said

I'm sorry, but I'm unable to access any of the link you provided.

The link doesn't open a page on the Add-ons site? Or the Add-ons site won't let you install the theme?

Regarding whether my theme is really light mode, I have been using that same theme for the past 3 years now, the text and tab bar is dark mode ish. But everything else stays the same, the webpage, the setting page, all in light theme. Only recently did those things went into dark mode. There's no reason for the theme to suddenly change all of a sudden.

Right, the theme did not change. However, starting in Firefox 96, Firefox assigns your global color-scheme based on the toolbar text color of your theme.

It's not due to the theme updating itself, else both my Ubuntu and windows would have the same theme otherwise. And I made sure to disable auto update on my Ubuntu regarding that theme. Yet, it still inherit that same dark mode that my window has.

You could try changing this preference on both systems:

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

I did this EXACTLY, but my new tab background is still black

nicolino.will said

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered (3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.
  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)
The about:config page should immediately reflect your saved change.

I did this EXACTLY, but my new tab background is still black

Hmm, did the about:config page change when you saved the change? For example:

That definitely should flip the built-in Firefox Home / new tab page: