ძიება მხარდაჭერაში

თავი დაიცავით თაღლითობებისგან. ჩვენ არასდროს მოგთხოვთ სატელეფონო ნომერზე დარეკვას, შეტყობინების გამოგზავნას ან პირადი მონაცემების გაზიარებას. გთხოვთ, გვაცნობოთ რამე საეჭვოს შემჩნევისას, „დარღვევაზე მოხსენების“ მეშვეობით.

Learn More

Firefox Dev Edition Defaults to Italics

  • 4 პასუხი
  • 1 მომხმარებელი წააწყდა მსგავს სიძნელეს
  • 14 ნახვა
  • ბოლოს გამოეხმაურა FredMcD

Hi there,

I've just downloaded the dev version of Firefox, and for some reason some of the text defaults to italics; I can't see where to change this. On all other browsers, this text is not italic.

Does anyone have an explanation / solution?

The non-italic text in the picture attached is the 'good text' which accurately reflects itself accross browsers and devices. The italic text is the 'bad text' that I want to change for consistency.

Thanks!

Hi there, I've just downloaded the dev version of Firefox, and for some reason some of the text defaults to italics; I can't see where to change this. On all other browsers, this text is not italic. Does anyone have an explanation / solution? The non-italic text in the picture attached is the 'good text' which accurately reflects itself accross browsers and devices. The italic text is the 'bad text' that I want to change for consistency. Thanks!
მიმაგრებული ეკრანის სურათები

ყველა პასუხი (4)

Is this with all websites/pages, some, a few?

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Hi FredMcD, thanks so much for your reply!

It is only on some websites. One I am building for work; work provides templates and I use HTML / CSS / JS to make them unique. However, even changing the CSS does not change the site from this weird italic font; I have tried !important and I have tried refreshing Firefox. The issue only seems to exist on this browser and I have no idea why!

With that said, when running in troubleshooting mode, the italics dissapears.

Do you have any further advice?

Many thanks

J

ჩასწორების თარიღი: , ავტორი: Korinthos

Did you check the font rules that are applied in the Inspector ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

Korinthos said

. . . . when running in troubleshooting mode, the italics dissapears.

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.