Avatar for Username

ძიება მხარდაჭერაში

ნუ გაებმებით თაღლითების მახეში მხარდაჭერის საიტზე. აქ არასდროს მოგთხოვენ სატელეფონო ნომერზე დარეკვას, შეტყობინების გამოგზავნას ან პირადი მონაცემების გაზიარებას. გთხოვთ, გვაცნობოთ რამე საეჭვოს შემჩნევისას „დარღვევაზე მოხსენების“ მეშვეობით.

Learn More

how do i stop firefox from auto-refeshing a tab the first time i click on it after restoring a session?

  • 5 პასუხი
  • 2 მომხმარებელი წააწყდა მსგავს სიძნელეს
  • 13 ნახვა
  • ბოლოს გამოეხმაურა cor-el

when i close a Firefox session, i leave a few tabs open. i have already set "accessibility.blockautorefresh" to false, which stops tabs from updating when i restart Firefox. now when i click on an open tab, it automatically refreshes. how can i stop the automatic refreshing of tabs when i click them?

when i close a Firefox session, i leave a few tabs open. i have already set "accessibility.blockautorefresh" to false, which stops tabs from updating when i restart Firefox. now when i click on an open tab, it automatically refreshes. how can i stop the automatic refreshing of tabs when i click them?

ყველა პასუხი (5)

vanhove said

when i close a Firefox session, i leave a few tabs open. i have already set "accessibility.blockautorefresh" to false, which stops tabs from updating when i restart Firefox. now when i click on an open tab, it automatically refreshes. how can i stop the automatic refreshing of tabs when i click them?

The name is "accessibility.blockautorefresh" and it means block auto refresh. Setting it to false allows the refresh.

sorry, i should have said i set it to "true"

accessibility.blockautorefresh is not about restoring tabs from the previous session, but about preventing website from using the location response header to redirect to another website.

Firefox will always reload web pages.

Firefox always needs to reload tabs when you restore tabs from the previous session.

  • Tools > Options > General > Startup: [X] "Don’t load tabs until selected"

If restore_on_demand is set, pinned tabs are restored on startup by default. When restore_on_demand is set to true, the restore_pinned_tabs_on_demand pref overrides that behavior, and pinned tabs will only be restored when they are focused.

browser.sessionstore.restore_pinned_tabs_on_demand (pinned tabs)(false) browser.sessionstore.restore_on_demand (default as set in Options -> Tabs)(true) browser.sessionstore.restore_hidden_tabs (tabs in other tab groups)(false)

thanks for the help, i was mistaken is what "accessibility.blockautorefresh" was for. i do have "Don’t load tabs until selected" selected, and it is working in preventing tabs from auto-reloading when i restore my session.

what i am wondering is how to prevent Firefox from auto-reloading a tab when i click on it for the first time after i restore my session? this did not occur in the previous version of Firefox i was using.

ჩასწორების თარიღი: , ავტორი: vanhove

Firefox would normally reload the tabs from the disk cache. If you aren't using the disk cache or clear the disk cache when you close Firefox then Firefox won't be able to restore the tabs from the cache.

You can check the cache via the about:cache page.

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content