Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

After upgrading Firefox on Mac, my address bar no longer displays the http:// in front of web address

  • 2 件の返信
  • 23 人がこの問題に困っています
  • 38 回表示
  • 最後の返信者: amandascookin

more options

I upgraded Firefox by clicking "About Firefox". After the upgrade I restarted the browser. Now, no matter what web page I go to, the http:// is missing from the address field. The only time it shows is if it's a secure webpage, such as https://

How do I get this back?

For example, when I go to http://amandascookin.com the site loads but the address bar only displays amandascookin.com

選ばれた解決策

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

この回答をすべて読む 👍 22

すべての返信 (2)

more options

選ばれた解決策

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

more options

Thank you SO much! Such a quick reply too :)