Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

How do I disable the History | Restore Previous Sesssion option. It is a privacy issue.

  • 6 件の返信
  • 65 人がこの問題に困っています
  • 26 回表示
  • 最後の返信者: etherance

more options

Hi I have upgraded to firefox 4.

It seems that no matter how I shut down firefox or what security settings I use the options History | Restore Previous Session is always enabled when I restart firefox.

This is the same big button that appears on the default firefox browser home page.

Even if I shut down with only one tab open it still has the option available and that goes back to the single tab.

Clearing history before shutting down firefox does not help.

I found the web page where someone had actually requested this functionality but niether of the pricay settings he suggested to tweak this feature did anything when adjusted.

These were:

     browser.sessionstore.privacy_level
     browser.sessionstore.privacy_level_deferred

in about:config


How do I get rid of this menu item/'feature' ?

I tried turning on browser.showQuitWarning in about:config as suggested on another site and that givs me the 'do you want to save your session tabs' dialog when I shut firefox like it used to in firefox 3.x. So I was semi happy with this. However this did not stop the Restore previous Session being available even if I selected quit (no dont save tabs option) on the dialog.

I do not want to be able to restore the previous session unless: a) firefox crashed or b) I expressly told it to save my session on shutdown.

I also have the tools | options | general | when firefox starts set to 'show my home page'. So I dont think thats related.

Cheers. Anyhelp appreciated.

この投稿は gold32 により に変更されました

すべての返信 (6)

more options

I found that by simply changing your homepage, you can stop that feature from appearing. What I did was set my homepage to Google, then restarted Firefox. No more session restore button. Simple as that.

more options

I think its an problem with the way mozilla's programmed... Thats right now the only reason that stops me using mozilla 4. It's aide to invasion of privacy... I close something.. someone else comes opens the browser and boom my facebook account

more options

To Response: Apple_iJuice

You will find that even changing your home page is not enough.

This does get rid of the button but it is still possible to use menu | History | Restore Previous Session regardless of what home page you have set.

この投稿は gold32 により に変更されました

more options

A possibility is to use Delete browsing, search and download history on Firefox to clear the history if you exit Firefox or close all open tabs. Then there is nothing to restore. Otherwise disabling Restore Previous Session wouldn't really help anyway.

more options

To Response: cor_el

Thanks. Following that link I worked out how to clear the history automatically on shutdown.

Having firefox auto clear my history ensures the 'Restore Presvious Session' is not available next time firefox starts.

However, if I then want to force it to save my session on shut down I cant. I can get the 'Do you want to save your session' dialog, as in firefox 3.6x, by having about:config browser.showQuitWarning set to true. After restarting firfox however my tabs are not restored.

more options

I discovered that if you 'tick' the 'clear history when firefox closes' (found in options - privacy tab) the offending button goes away. Hope that is a help