Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

How to stop everything being marked as Junk?

  • 5 件の返信
  • 0 人がこの問題に困っています
  • 57 回表示
  • 最後の返信者: john914

more options

Can any kind person help?

All incoming mail on one of my accounts (gmail, IMAP) is marked as junk. This happens whether "adaptive junk mail controls" are enabled or not. If they are enabled training appears to have no effect, and the checked exclusions (Address book, Collected Addresses, Personal Address Book) also have no effect - every email from every sender is marked as junk, regardless of what I do.

I have tried deleting the profile and starting from scratch - the problem remains. I have the same problem on my PC and on my Mac, but only for this one account. Other IMAP accounts including other gmail are fine.

To be clear, the messages are not moved to my junk folder - they remain in my inbox, but marked as junk. I can unmark them individually. I have no problem viewing the account directly with gmail.

I don't want any junk controls in TB - I find gmail is already over-zealous!

Can any kind person help? All incoming mail on one of my accounts (gmail, IMAP) is marked as junk. This happens whether "adaptive junk mail controls" are enabled or not. If they are enabled training appears to have no effect, and the checked exclusions (Address book, Collected Addresses, Personal Address Book) also have no effect - every email from every sender is marked as junk, regardless of what I do. I have tried deleting the profile and starting from scratch - the problem remains. I have the same problem on my PC and on my Mac, but only for this one account. Other IMAP accounts including other gmail are fine. To be clear, the messages are not moved to my junk folder - they remain in my inbox, but marked as junk. I can unmark them individually. I have no problem viewing the account directly with gmail. I don't want any junk controls in TB - I find gmail is already over-zealous!

すべての返信 (5)

more options

re: I have the same problem on my PC and on my Mac, but only for this one account.

Q: Are you using Thunderbird on both PC and MAC ? Q: Can I assume both are set up as IMAP ?

re : messages are not moved to my junk folder - they remain in my inbox, but marked as junk.

Select 'Inbox' In Message List - 'Junk Status' column (please enable it if you cannot see it ) Q: Are all the flame icons greyed outlines or are they red/orange flame icons ?

As you mention gmail has it's own spam filters: Q: Have you got any setting in gmail webmail account which is forcing all mail including any potential spam into the Inbox ? So nothing goes into the server/webmail 'Spam' folder.

Q: In Thunderbird, do you have any Message Filters which can mark as junk ? If yes, please post image of that Message Filter.

more options

It is possible an Anti-Virus product is marking as spam, so you would need to do the following in order to check this - please do it because it has to be ruled out.

Make sure the MAC is not switched on - we do not want anything occuring in Thunderbird on that computer during the test.

On PC, have you installed an Anti-Virus product or are you just using the built in Defender product ?

On PC Exit all programs. Restart computer PC in 'SafeMode with Networking'. If you normally use a wireless connection then you may need to connect computer to router via an ethernet cable in order to test this.

Then Start Thunderbird as normal. Wait for a decent amount of time - a few hours - to allow incoming mail to naturally come into the problem gmail account. Does it still get auto marked as junk? If yes, what colour is the junk flame icon?

more options

Thanks for this. I appreciate your help. I'm about to go on a trip, and I can't do this right now. However I will revisit when I return at the end of the month.

In answer to the questions in your earlier email: Q: Can I assume both (PC and MAC) are set up as IMAP ? A: Yes - both IMAP, and both set up using TB's autoconfig

Q: Are all the flame icons greyed outlines or are they red/orange flame icons ? A: Yes red/orange. I've assumed the grey outline means "not marked as spam".

Q: Have you got any setting in gmail webmail account which is forcing all mail including any potential spam into the Inbox ? A: Not for all mail, but I do have some filters for important senders. These are of the form Matches: from:(xyz@gmail.com) Do this: Never send it to Spam, Categorise as Primary

Q: In Thunderbird, do you have any Message Filters which can mark as junk ? A: No - the TB installation is pretty much unchanged since I recreated the profile.

However, I should say I've noticed that training now seems to be kicking in, and some incoming mail is not marked as spam. Of course, I'd rather I didn't have to train it!

I'll keep monitoring, and report when I get back from my trip. JA

more options

I did the 'SafeMode with Networking' test overnight. A dozen emails arrived and all were marked as spam with the red flame icon. I normally use Microsoft Defender for virus protection.

I think I was mistaken in saying that training was kicking in. Currently every incoming email is marked as spam. It's possible that a week or so back some arrived that were not marked (or perhaps I had finger trouble).

Some other points:

  • I have separate TB installations on PC and Mac and both show the problem when using IMAP to view this gmail account.
  • Other apparently similar gmail accounts work fine using IMAP on PC and Mac installations of TB
  • I can view the problem account using IMAP on Outlook without any problems
  • I can also view the account directly in gmail
  • I have tried deleting and recreating the profile.
more options

And suddenly it changed.

From about midnight last night, no incoming mail is marked with the dreaded red flame - about 20 so far. I thought it might be the update to v102.12, but my Mac is still on 102.10, and that also has no red flame on today's emails.

Perhaps Google changed something.