Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

詳しく学ぶ

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

64-bit browser is scrubbing out ltpatoken from cookie

  • 2 件の返信
  • 1 人がこの問題に困っています
  • 1 回表示
  • 最後の返信者: astuer

more options

when trying to login to a server configured for single sign-on, all works well using a 32-bit browser, the server responds with the ltpatoken and the browser correctly re-uses the received ltpatoken in it's next requests to the server. BUT when using a 64-bit browser, on the same workstation, connecting to the same server, the browser suddenly scrubbs out the ltpatoken from the cookie which breaks the flow and the user cannot open the web application as blocked on the login prompt.

Has anyone an idea what can cause this strange behavior. My browser settings are standard, I didn't change anything. But could it be that 64-bit has some strickter security setting which makes the browser think the ltpatoken in the cookie isn't correct ? we don't have the security bit set on the token, the domain accompanying the token is correct, so not sure what else to check as all works fine switching to 32-bit browser !

when trying to login to a server configured for single sign-on, all works well using a 32-bit browser, the server responds with the ltpatoken and the browser correctly re-uses the received ltpatoken in it's next requests to the server. BUT when using a 64-bit browser, on the same workstation, connecting to the same server, the browser suddenly scrubbs out the ltpatoken from the cookie which breaks the flow and the user cannot open the web application as blocked on the login prompt. Has anyone an idea what can cause this strange behavior. My browser settings are standard, I didn't change anything. But could it be that 64-bit has some strickter security setting which makes the browser think the ltpatoken in the cookie isn't correct ? we don't have the security bit set on the token, the domain accompanying the token is correct, so not sure what else to check as all works fine switching to 32-bit browser !

選ばれた解決策

I finally found the cause of this issue. Security has been enforced on 64-bit browsers and additionally in Windows10. The following RFC 6265 was implemented (which isn't implemented in 32-bit browsers and not generally on windows7 workstations) which includes a check on the cookie attribute "Domain" against the public domain suffix list (https://publicsuffix.org/list/public_suffix_list.dat). I my case the token domain was included in this list which caused the browser to reject the cookie. After modifying the token dns domain to a value not included in the public domain list, the problem was solved !

この回答をすべて読む 👍 0

すべての返信 (2)

more options

astuer said

When using a 64-bit browser, on the same workstation, connecting to the same server, the browser suddenly scrubbs out the ltpatoken from the cookie which breaks the flow and the user cannot open the web application as blocked on the login prompt...

I'll guess at this. What about turning OFF Content Blocking or reducing the Blocking? (My settings, attached. Try other setups.)


~Pj

more options

選ばれた解決策

I finally found the cause of this issue. Security has been enforced on 64-bit browsers and additionally in Windows10. The following RFC 6265 was implemented (which isn't implemented in 32-bit browsers and not generally on windows7 workstations) which includes a check on the cookie attribute "Domain" against the public domain suffix list (https://publicsuffix.org/list/public_suffix_list.dat). I my case the token domain was included in this list which caused the browser to reject the cookie. After modifying the token dns domain to a value not included in the public domain list, the problem was solved !