Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

"Remember password" bookmarklet doesn't work.

  • 2 件の返信
  • 4 人がこの問題に困っています
  • 5 回表示
  • 最後の返信者: coffent

more options

I am trying to use the "remember password" bookmarklet to store a password. I followed the instructions - bookmarked the link, opened the website and clicked the remember password link. I got the message "Removed autocomplete=off from 3 forms and from 0 form elements, and removed onsubmit from 0 forms. After you type your password and submit the form, the browser will offer to remember your password." I clicked OK, entered my username and password, and clicked "Sign in". I was then signed in but the browser did *not* offer to store the password.

I'm not sure exactly how the bookmarklet works, but I tried viewing "Page source" both before and after running the bookmarklet. I manually found the 3 "autocomplete=off" instances in the page source, but they were still there after running the bookmarklet. Should they have been? What isn't working? Thanks.

すべての返信 (2)

more options

Current Firefox releases no longer respect autocomplete=off, so there is no need to use the bookmarklet.

The Firefox Password Manager should detect the login form on most web pages and offer to passwords.

In Firefox 55 you can still use the Saved Password Editor extension.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) where Firefox doesn't ask to store the username and password?

Note that you can't save new passwords when you are using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

more options

Thanks for the information. The website I'm having the problem with is https://newlook.dteenergy.com/wps/wcm/connect/dte-web/home/ I can manually enter my username and password and get into the site, but Firefox doesn't ask to save them. The website is not on my exceptions list, there's no password for the site already stored, and I'm not using Private browsing. FWIW, I also tried removing all DTE-related cookies.