Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

Attribute Error showing Django setting should be DEBUG=TRUE when it is currently DEBUG=FALSE. I don't know how to fix this. Need help changing setting please!

  • 1 件の返信
  • 12 人がこの問題に困っています
  • 2 回表示
  • 最後の返信者: cor-el

more options

I am trying to access an online simulation through Pearson's MyMIS Lab for an online class. I was using this simulation a couple of days ago but when I logged on this morning, the simulation would not open. I have copy and pasted the error message that pops up when I try to access it. At the bottom, it reads "You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 500 page." I have no idea what Django settings are and have researched how to change the setting but I am not familiar with this at all. Any help would be greatly appreciated so I can get my homework finished! Thank you!!!!


AttributeError at /simLaunch/launch/

'Settings' object has no attribute 'XLSIMS_LAUNCH_URL'

Request Method: 	POST
Request URL: 	http://econdip.pearsoncmg.com/xlsim/simLaunch/launch/
Django Version: 	1.5.2
Exception Type: 	AttributeError
Exception Value: 	

'Settings' object has no attribute 'XLSIMS_LAUNCH_URL'

Exception Location: 	/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/conf/__init__.py in __getattr__, line 54
Python Executable: 	/usr/bin/python
Python Version: 	2.6.6
Python Path: 	

['/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages',
 '/usr/lib64/python26.zip',
 '/usr/lib64/python2.6',
 '/usr/lib64/python2.6/plat-linux2',
 '/usr/lib64/python2.6/lib-tk',
 '/usr/lib64/python2.6/lib-old',
 '/usr/lib64/python2.6/lib-dynload',
 '/usr/lib64/python2.6/site-packages',
 '/usr/lib64/python2.6/site-packages/gtk-2.0',
 '/usr/lib/python2.6/site-packages',
 '/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg-info',
 '/vh/docroots/econdip.pearsoncmg.com/prod/server/glservice']

Server time: 	Sat, 30 Aug 2014 14:59:46 -0500

Environment:


Request Method: POST
Request URL: http://econdip.pearsoncmg.com/xlsim/simLaunch/launch/

Django Version: 1.5.2
Python Version: 2.6.6
Installed Applications:
('django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.sites',
 'django.contrib.messages',
 'django.contrib.staticfiles',
 'django.contrib.admin',
 'gldata',
 'econ.ca',
 'econ.ue',
 'gllaunch',
 'datacapture',
 'xlsims')
Installed Middleware:
('django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.middleware.csrf.CsrfViewMiddleware',
 'django.contrib.auth.middleware.AuthenticationMiddleware',
 'django.contrib.messages.middleware.MessageMiddleware')


Traceback:
File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/core/handlers/base.py" in get_response
  115.                         response = callback(request, *callback_args, **callback_kwargs)
File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/views/decorators/csrf.py" in wrapped_view
  77.         return view_func(*args, **kwargs)
File "/vh/docroots/econdip.pearsoncmg.com/prod/server/glservice/xlsims/views.py" in launchSim
  23.     if TPIUtils.has_valid_signature(launch_data, url=settings.XLSIMS_LAUNCH_URL, key='bphsc2014'):
File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/conf/__init__.py" in __getattr__
  54.         return getattr(self._wrapped, name)
I am trying to access an online simulation through Pearson's MyMIS Lab for an online class. I was using this simulation a couple of days ago but when I logged on this morning, the simulation would not open. I have copy and pasted the error message that pops up when I try to access it. At the bottom, it reads "You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 500 page." I have no idea what Django settings are and have researched how to change the setting but I am not familiar with this at all. Any help would be greatly appreciated so I can get my homework finished! Thank you!!!! <pre><nowiki>AttributeError at /simLaunch/launch/ 'Settings' object has no attribute 'XLSIMS_LAUNCH_URL' Request Method: POST Request URL: http://econdip.pearsoncmg.com/xlsim/simLaunch/launch/ Django Version: 1.5.2 Exception Type: AttributeError Exception Value: 'Settings' object has no attribute 'XLSIMS_LAUNCH_URL' Exception Location: /vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/conf/__init__.py in __getattr__, line 54 Python Executable: /usr/bin/python Python Version: 2.6.6 Python Path: ['/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages', '/usr/lib64/python26.zip', '/usr/lib64/python2.6', '/usr/lib64/python2.6/plat-linux2', '/usr/lib64/python2.6/lib-tk', '/usr/lib64/python2.6/lib-old', '/usr/lib64/python2.6/lib-dynload', '/usr/lib64/python2.6/site-packages', '/usr/lib64/python2.6/site-packages/gtk-2.0', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg-info', '/vh/docroots/econdip.pearsoncmg.com/prod/server/glservice'] Server time: Sat, 30 Aug 2014 14:59:46 -0500 Environment: Request Method: POST Request URL: http://econdip.pearsoncmg.com/xlsim/simLaunch/launch/ Django Version: 1.5.2 Python Version: 2.6.6 Installed Applications: ('django.contrib.auth', 'django.contrib.contenttypes', 'django.contrib.sessions', 'django.contrib.sites', 'django.contrib.messages', 'django.contrib.staticfiles', 'django.contrib.admin', 'gldata', 'econ.ca', 'econ.ue', 'gllaunch', 'datacapture', 'xlsims') Installed Middleware: ('django.middleware.common.CommonMiddleware', 'django.contrib.sessions.middleware.SessionMiddleware', 'django.middleware.csrf.CsrfViewMiddleware', 'django.contrib.auth.middleware.AuthenticationMiddleware', 'django.contrib.messages.middleware.MessageMiddleware') Traceback: File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/core/handlers/base.py" in get_response 115. response = callback(request, *callback_args, **callback_kwargs) File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/views/decorators/csrf.py" in wrapped_view 77. return view_func(*args, **kwargs) File "/vh/docroots/econdip.pearsoncmg.com/prod/server/glservice/xlsims/views.py" in launchSim 23. if TPIUtils.has_valid_signature(launch_data, url=settings.XLSIMS_LAUNCH_URL, key='bphsc2014'): File "/vh/docroots/econdip.pearsoncmg.com/prod/virtualenv/lib/python2.6/site-packages/django/conf/__init__.py" in __getattr__ 54. return getattr(self._wrapped, name)</nowiki></pre>

この投稿は cor-el により に変更されました

選ばれた解決策

That is a problem with a Python script that runs on the server. The website needs to fix this. If the problem persists then contact them via e-mail.

You can try to clear the cache and remove cookies from this website.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
この回答をすべて読む 👍 2

すべての返信 (1)

more options

選ばれた解決策

That is a problem with a Python script that runs on the server. The website needs to fix this. If the problem persists then contact them via e-mail.

You can try to clear the cache and remove cookies from this website.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"