Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Search Engines list icons mismatch on McAfee Secure Search - why?

  • 9 risposte
  • 2 hanno questo problema
  • 369 visualizzazioni
  • Ultima risposta di sknarf

more options

I had a virus that redirected my web address thru something called Conduit when I entered the url in the address bar. Geek Squad was able to remove the virus (took two attempts). After that I noticed the Secure Search icon in the Search Engine bar when Secure Search is selected is a small light gray rectangle, containing a grid, with the upper right corner of the rectangle turned down and the center of the grid contains a darker gray square. However, when the Manage Search Engines option is clicked the list of available search engines shows Secure Search with the conventional icon: Red McAfee Shield emblazoned with white M. I am concerned this apparent discrepancy indicates that Geek Squad did not completely remove the virus. I must admit this apparent discrepancy could have been there all along, is “normal”, but I only noticed it after the virus was removed. If it really is a problem, how do I get it fixed? I appreciate any enlightenment available.

Soluzione scelta

Hello cor-el,

  The searchplugins folder in the Firefox profile folder is empty just as it was on 24-Feb, the first time I looked at it. I think SecureSearch is part of McAfee SiteAdvisor; however SevcureSearch does not show in the list of Add-ons that Search Bar ->  Mange Search Engines  ->  Get more search engines produces.

I guess, technically, this is not solved, but since I can work around it, perhaps we ought to forget it. I appreciate all of your good effort in resolving this matter but, discretion being the better part of valor, I will mark it solved.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (9)

more options

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

cor-el, Thanks for the reply; unfortunately it made no difference, assuming I did it right. I followed your link for addons reset, clicked the button, and saw a response saying the add on had been added. Since it is supposed to delete itself, and it seem to have, I assume it worked as advertised. The only change I saw was my home page to Firefox. I reset that to my e-mail login. Again thanks for trying.

more options

Do you see this search engine in the searchplugins folder in the Firefox profile folder?

Are there any references found to that website if you do a search on the about:config page?

more options

Hello cor-el, I searched (Windows 7 Home search box) for %APPDATA%\Mozilla\Firefox\Profiles\ and found one entry: iejmds8x.default. I followed it to the searchplugins folder which is empty. Nevertheless the Search Bar drop down Manage Search Engines list shows a number of search engines, including Secure Search with the standard red shield icon to the left of it, installed. Yet in the Secure Search entry in the Search Bar drop down shows Secure Search with the gray rectangle icon. Thus my concern that if I use the Secure Search entry (wrong? Icon) from the Search Bar drop down I may, in fact, be using something else, such as conduit. As far as I know, Secure Search is part of McAfee SiteAdviser which does show up in Firefox --> Add-ons --> Extensions.

Secure Search does not show in the list about:config produces.

Since I ran SearchReset extension, per your first reply, I notice that when Firefox starts it now always opes a tab for SearchReset :: Add-On for Firefox. Am I supposed to do something with that? For example, is running the SearchReset extension a two-step process with the second step occurring on the next startup of Firefox?

more options

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Hello cor-el, I deleted search.json and search-metadata.json but there was no search.sqlite in the Firefox profile. That did not help. I then downloaded a fresh copy of Firefox, but that did not help either. In addition, as mentioned last time, since I ran the SearchReset extension, when Firefox starts it now always opens a tab for SearchReset :: Add-On for Firefox. It also opens two tabs for yahoo mail, my home page, no matter how I leave Firefox. For example, clearing all history before exiting still results in the next start-up opening the 3 tabs: two for the home page and one for SearchReset :: Add-On for Firefox. Is there any way to correct that and get back to starting with only one open tab – the one for yahoo mail? The start-up issue is the bigger problem now because I can avoid using SecureSearch by moving it down in the list. In addition, there seems to be a second copy of SecureSearch (with conventional icon) in the bottom right corner of the Firefox window.

more options

Hello cor-el,

PS – After sending the last reply, I found the start-up 3-tab problem. Previously my wife had me make a desktop shortcut to the Chavah Messianic Radio web site. I noticed that when that link was clicked Firefox opened with just one tab: Chavah Messianic Radio; but, when I opened a new tab and then clicked Home in the upper right corner of the Firefox window, three more tabs: two for the home page and one for SearchReset :: Add-On for Firefox opened. That lead me to Firefox -> Options -> General -> Home Page that had three urls: two for the home page and one for SearchReset :: Add-On for Firefox in it. I fixed that and Firefox now opens normally (only one tab for yahoo mail). The original SecureSearch icon mismatch problem is still there, but as I said I can get around it by being careful; so it is a minor nuisance I can live with. Thanks for all your efforts in my behalf.

more options

Did you try to reinstall this search engine assuming that it is installed in the searchplugins folder in the Firefox profile folder?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Soluzione scelta

Hello cor-el,

  The searchplugins folder in the Firefox profile folder is empty just as it was on 24-Feb, the first time I looked at it. I think SecureSearch is part of McAfee SiteAdvisor; however SevcureSearch does not show in the list of Add-ons that Search Bar ->  Mange Search Engines  ->  Get more search engines produces.

I guess, technically, this is not solved, but since I can work around it, perhaps we ought to forget it. I appreciate all of your good effort in resolving this matter but, discretion being the better part of valor, I will mark it solved.