Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I stop firefox from remenbering my last session every time I open up the browser?

  • 14 risposte
  • 2 hanno questo problema
  • 3215 visualizzazioni
  • Ultima risposta di cor-el

more options

Something happen to my computer yesterday because lots of my program shut down but I was able to open up again and now I discovered today that every time I open firefox it remember my last session even though I didn't ask it to - my homepage is set to my homepage under options and I do remember history and I know if I turn that off it won't do this but it shouldn't be doing this in the first place.

Soluzione scelta

You can delete the user.js file if that what your above reply is about to prevent Firefox from restoring the previous session on each start.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (14)

more options
more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

It say it set to true ... I have not updated yet but that because of my security software doesn't have patch for there toolbar yet so I hope it will fix itself then - will it?

more options

Soluzione scelta

You can delete the user.js file if that what your above reply is about to prevent Firefox from restoring the previous session on each start.

more options

Is safe to do so? I couldn't find under profile folder - I add to search for it but is okay to deleted? If so what the safest way of doing it - just deleting the file like that?

more options

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see the name without file extension.
You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.

Can you post the content of the user.js file?

more options

> Firefox > Profiles > ec6p37cr.default

So it's in the ec6p37cr.default which I search for in there and the tittle of it is User .... I haven't click on while I'm not using firefox yet so ... I'll see

more options

I still get an error if I click on it would a pic help? If so I do it tomorrow when I get back

Thank you for helping me so far.

more options

You shouldn't double-click a Firefox .js file as that will make Windows try to run this file as a JScript file and this will fail because it is a Firefox file that stores user set prefs.
To inspect the file, you need to access the right-click context menu and use "Open with" to open the file in a text editor like Notepad.

more options

I open it with notepad -

user_pref("browser.sessionstore.resume_session_once", true);

more options

Yes, that line will cause Firefox to restore the previous session at each new start, so you need to delete this file to prevent this.

more options

okay I test it out

more options

It seems to work so why is that the case?

more options

When the browser.sessionstore.resume_session_once pref is set to true then it does what it says and restore the previous session.
You may have had an extension or other software on your computer that had created this file (the file creation date might give a clue).