Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to enable webGL in firefox

  • 6 risposte
  • 46 hanno questo problema
  • 11486 visualizzazioni
  • Ultima risposta di philipp

more options

Today, I wanted to view a model on thingiverse using their thingyview. This javascript 30 viewer uses webGL. I remember using it in former firefox versions quite often.

Now, it won't work. It works in Google Chrome and Opera with no problem, so I assume this must be problem of browser configuration, not drivers.

Tutte le risposte (6)

more options

• Go to Options through Firefox > options or Tools > Options

• Go to Advanced, then General Tab

• Check the “Use hardware acceleration when available”

• Restart Firefox

Modificato da Sean Moroz il

more options

You can check on the "Help > Troubleshooting Information" page in the Graphics section to see if there are problems with WebGL reported.


There are other things that need your attention.

Note that your System Details List shows multiple outdated Flash plugins.

  1. Shockwave Flash 11.9 r900
  2. Shockwave Flash 10.0 r45

You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\

Update the Flash plugin to the latest version.

Latest Flash player version here:

more options

@cor-el WebGL does not need Adobe flash.

What should check on https://developer.mozilla.org/en-US/docs/Web/WebGL ?

@Sean Moroz: Good idea, but I have that already checked.

Modificato da Jakub Mareda il

more options

I didn't say that WebGL need Flash.
I wrote that you have installed multiple Flash plugins and that you need to look into that to avoid issues with Flash.

Can you paste the content of the Help > Troubleshooting Information page?

Did you check the webgl prefs on the about:config page?

more options

@cor-el: I'm so sorry, I didn't read your post carefully. I'll check the flash problem later, but I'll note it to myself. Thank you for checking my settings :)

It took a while to orientate myself in Troubleshooting information, but now, under the Graphics section I've found this error for webGL:

"Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer."

I can't upgrade my driver - it causes horrible system errors (http://superuser.com/questions/569942/nvidia-on-startup-breaks-all-drivers-and-the-system). Why firefox disables it while other browsers don't? Isn't there any workaround, like forcing browser to ignore drivers and just try it?

more options

hello Jakub Mareda, usually drivers get blocked in firefox when they are known to cause crashes of the browser. for details and also a workaround how to force the usage of a driver nevertheless, please see: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers