Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

unwanted popup "like.php"

  • 17 risposte
  • 9 hanno questo problema
  • 1460 visualizzazioni
  • Ultima risposta di thierryj

more options

After reading the possible solution "reset Firefox", I did that but this unwanted popup continues to appear asking for saving or opening. What can I do ? This only happens with Firefox , not with Chrome ! Thanks for your answer, I would like to keep Firefox.

Soluzione scelta

I just completely removed Zonealarm and the problem seems to have disappeared. Don't ask me why . . .

Marked as the solution ~J99

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (17)

more options

In fact, it is now much WORSE : one popup for every page !

more options

A screenshot may help as would the full troubleshooting information (Please paste that in to a separate reply from the troubleshooting page. Edit out the print related information if that takes up a lot of lines).

Lets say with the information so far maybe it is some form of hijack,so you will need to find the rogue software, remove that. Then reset only the search etc preferences by using a special add-on

more options

Thanks for your quick reply. Here is the trouble shooting information and the screenshot is attached as an image

--------------------------------------------------------
Application Basics
------------------
Name: Firefox
Version: 26.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Extensions
----------
Name: feedly
Version: 16.0.528
Enabled: true
ID: feedly@devhd
Name: FireFTP
Version: 2.0.17
Enabled: true
ID: {a7c6cf7f-112c-4500-a7ea-39801a327e5f}
Name: Flagfox
Version: 4.2.16
Enabled: true
ID: {1018e4d6-728f-4b20-ad56-37578a4de76b}
Name: Translate This!
Version: 3.0.1
Enabled: true
ID: jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack
Name: avast! Online Security
Version: 9.0.2011.70
Enabled: false
ID: wrc@avast.com
Name: Logitech SetPoint
Version: 6.5
Enabled: false
ID: {F003DA68-8256-4b37-A6C4-350FA04494DF}
Name: PDF Architect Converter For Firefox
Version: 1.0
Enabled: false
ID: FFPDFArchitectConverter@pdfarchitect.com
Name: Soda PDF 3D Reader Converter For Firefox
Version: 1.0
Enabled: false
ID: FFSodaReaderPDFConverter@sodapdf.com
Important Modified Preferences
------------------------------
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
browser.startup.homepage: http://www.google.fr/webhp?nord=1
browser.startup.homepage_override.buildID: 20131205075310
browser.startup.homepage_override.mstone: 26.0
dom.mozApps.used: true
extensions.lastAppVersion: 26.0
gfx.direct3d.last_used_feature_level_idx: 0
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1389010751
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1389010749
Graphics
--------
Adapter Description: Intel(R) HD Graphics 3000
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
Device ID: 0x0112
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16492)
Driver Date: 10-17-2012
Driver Version: 9.17.10.2875
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2
NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

Modificato da cor-el il

more options

Sorry I do not know the answer.

I am guessing it relates to facebook and possibly certain websites. Do you only get this after visiting certain websites ?

  • Which websites, if you can detect a pattern ?

I will leave this for someone else to answer.

more options

Normally the Like button code is pulled in seamlessly and processed by Firefox as a normal web page. But not every site in the world has a Like button, obviously. That points toward one of your extensions as a potential culprit.

To quickly test that theory, try visiting some sites in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

The reset should have cleared these potential issues, but I'll just note them for the sake of completeness since they have been mentioned in past threads about this issue of Firefox suggesting to download like.php:

(1) A problem with cached files or cookies for Facebook; or
(2) Corrupted download actions (mimeTypes.rdf) file.

Modificato da jscher2000 il

more options

@John99 : I do not detect any pattern, almost all sites seem to ask. (FYI : I have NO facebook account and never go to their site, I do not like facebook and now even less !)

@jscher2000 : Thanks

I also now face many slow responses, could this be an other effect of the same cause ? The fact is that I now use Chrome more and more often as it has fast responses and no silly questions for downloading "like.php"

Modificato da thierryj il

more options

Hi thierryj, the "like.php" problem seems very rare, it's not a normal Firefox behavior. Did Safe Mode make any difference?

more options

Hi jscher200, As I made a reset I was almost sure, but I made a test in Safe Mode as you suggested and I can now confirm that it makes no difference : the popup continues to appear also in Safe Mode.

more options

Could you open the Browser Console (Ctrl+Shift+j) and keep that in the background until the next time you get the dialog? Then look in the browser console for that request and click it to review the request and response headers. I have attached some screen shots for reference showing the areas of interest. (It's possible to select/copy from this dialog to paste into a reply, but it might turn into a mess.)

Of critical importance is the Content-Type header from the server. It should be text/html, or something related to JavaScript such as application/json or text/javascript. If it is something else, then Firefox will handle it according to the specified type. This may be different than other browsers, which may "sniff" the beginning of the content to determine whether the server is providing the correct information. Firefox is quite literal about it.

more options

Thank you very much for your help. I am far from being an expert like you but, if I understand you well, the solution is within Firefox and I cannot do anything. The only thing I can do is send you a screenshot showing what appears in the Browser console immediately after the popup. Do you want that ?

more options

Hi thierryj, I'm mostly curious about the "Content-Type" header coming back from Facebook. If it's a type that Firefox normally handles as a web page, then Firefox should not be putting up that dialog. If it's some other type, then you may have external software which is filtering your web traffic and modifying it in some way that is triggering Firefox's behavior. Assuming you find the like.php line in the Browser Console, click it, scroll down, and find the Content-Type header, that Content-Type header line is really all I need.

more options

I have found 2 lines with "like.php" - click on 1st gives : Content-Type: text/html; charset=utf-8

- No such info after click on 2nd line

Here is the screenshot with the console and the 2 windows. Hope it helps (this is Chinese for me !)

Modificato da thierryj il

more options

Hi thierryj, thanks for that. On the first one, it shows the correct response, so I would expect the first Like button on the page to appear as expected. The second one is strange. The site is requesting the exact same button (more specifically a tiny web page which fits into a frame and displays the button), so the response should be the same, but it isn't. It seems to be missing the information I'm looking for. Was the download dialog open at that point?

I noticed someone else reported an intermittent problem with a PHP page loading into an iframe in Firefox (iframe in FireFox sometimes pops up a "Save As..." dialog rather than loading the frame - Stack Overflow) but there wasn't really a clear explanation of the cause in that case.

more options

I don't know whether this is relevant, but since you have avast! and other users have discovered various websites not working correctly with avast!, I thought it was worth a search.

The following mention avast! hiding the Like button. Depending on how that is done, perhaps it is contributing to this problem?

more options

Was the download dialog open at that point? ----> YES

Additional info : the popup seems to appear only once per page per Firefox session (if I come back on a page which pushed this popup, it does not show again) but I have not made enough tests to completely sure of that.

Concerning avast, I have no problem with Chrome. If it is a "misunderstanding" between Firefox and avast, we just have to wait a future version, if they have recognized the bug and work on it. In the meantime I will switch to Chrome. Thanks a lot for your help. It's now time for me to go to sleep.

more options

Soluzione scelta

I just completely removed Zonealarm and the problem seems to have disappeared. Don't ask me why . . .

Marked as the solution ~J99

Modificato da John99 il