Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Mobile version of a website showing up on my laptop

  • 16 risposte
  • 15 hanno questo problema
  • 59328 visualizzazioni
  • Ultima risposta di eyalnow

more options

I was running malwarebytes last night and removed a bunch of "registry errors". Today, one of the websites I use frequently; fodors.com, shows up in Firefox as the mobile version. It's the only site that seems to show up as a mobile version and the mobile version is not showing up when I try it in Internet Explorer. Any suggestions?

Soluzione scelta

Hi eyalnow, what I see in Firefox, Chrome, and Firefox Mobile is a responsive layout that varies depending on width. If you search in your style sheet (http://eyalnow.com/eyalnow/wp-content.../style.css) for 1260 you can see the media query which flips the layout for a document width of 1260px or higher.

That sound straightforward, but the measurement of page width (window.innerWidth) in Firefox 22 and later is different than in earlier versions because it is adjusted based on the zoom level, as part of Firefox's becoming a "DPI-aware" application. 1260 physical monitor pixels will be reported as a lower number if your zoom level is higher than 100%. For example, if the zoom level is 125%, it is reported as 1050 CSS layout pixels.

If you zoom up and down on the following play page, you can see how this new math works: http://dev.jeffersonscher.com/resolution.html

So... if you are viewing your site at a high zoom level and you want the "desktop" layout, what is the solution? One possibility is to leave it to the user to reduce the zoom level if they find the more compact layout to be too large for reading comfort. Another possibility is to experiment with additional variables to fine-tune the responsive behavior. I don't have enough experience to suggest how you might do that.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (16)

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

It's possible to send alternate browser identities to a particular site, but unlikely to be happening if you never set it up yourself (either directly or through an add-on). You can check for a such a setting in Firefox's about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste fodor and pause while the list is filtered

Any preferences match? The one to look out for would have a name similar to "general.useragent.override.fodors.com".

more options

Thank you for the help, but it didn't work. No Fodor in the about:config page. I failed to mention I reinstalled firefox about the same time I ran malwarebytes. I picked up a toparcadegames.com extention/virus downloading a game demo.

Fodors.com still showing up in the mobile version. I hate to clear history and the cache, but will have to do so if it is the only way. Thanks again.

more options

Hi agedude, you don't need to clear history for all sites: the "Forget about this site" feature removes history, cookies, and bookmarks (possible some other site-specific data) just for the site you select.

Can you think of any other filters operating on your system, or Firefox add-ons, that might alter how a website perceives your browser? To bypass the effects of any extensions, you could try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Then remove your fodors.com cookies, and when you open fodors.com, reload using Ctrl+Shift+r to bypass cached files.

Any difference?

more options

Thanks again, but still no difference. I'm not sure how to use the "forget about this site" feature, but have deleted all cookies, bookmarks, and checked for registry entries.

Can't think of any other filters. I'd gotten this "toparcadehits" extension downloading a game demo and was doing whatever I could to delete it. I deleted the extension, ran malwarebytes, ran a Norton virus check. I did update my plugins sometime during this process and updated two Adobe files, including reader, and a Java plug-in if I'm not mistaken. My browser may have been on Fodors.com while some of this was going on. I'm taking a trip in 10 days and have been seeking information.

No other problems with any other sites, just fodors.com in the mobile version, which is unusable on my netbook. As I stated earlier, it works fine in Internet Explorer. I've never seen anything like it before.

I appreciate your trying to help. It's one of those annoying little issues that drives you crazy because you can't figure out how to resolve it.

more options

Can you test something? Open a new tab to Fodors, then open the web console using Ctrl+Shift+k. Click the Clear button to empty out the console, then reload the page using Ctrl+Shift+r to force a reload of everything.

If you scroll the web console back up to the top, it should have a link to the home page, click that, and look at the User-Agent under the Request Headers. This is what Firefox is sending to the site. Anything mobile-looking there?

I've post a comparison screenshot.

more options

I'm getting what looks like "parsing errors, declaration dropped" messages across the board. It appears it's trying to open the main website, getting a ton of errors, then saying screw it and opening the mobile sight. I've attached screen shots of hopefully the information you requested.

I hope this is what you need, if not, please let me know. I appreciate your help and am getting pretty curious on what the fix might be.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Hi agedude, you'll always see a lot of those CSS parsing errors because sites typically include a lot of specific style rules that only work in particular browsers. You can click the CSS button to hide those. What's curious to me is you got the www site. When did it flip to the mobile site -- did that happen automatically or when you clicked a link?

more options

did all of the above.

nothing works.

more options

Hi eyalnow, are you having the problem at Fodors as well, or a different site?

I assume you do not use any add-ons that change your user agent string, and/or have confirmed using the Web Console that Firefox is sending the correct string for your desktop OS.

Is there anything special about your connection that might hint at a mobile network, such as using a 3G/4G modem?

more options

hey, i get the normal desktop version at fodors.com

the problem is with my own site at http://eyalnow.com/

i've done everything you suggested in this post. console says i'm sending the regular non-mobile user agent. wifi over fiber. happens in safe mode as well. chrome shows my website just fine - desktop version.

other ideas ?

thanks

more options

It's a bit NSFW, so I'll have to look at it later.

more options

sorry, didn't realize my website is NSFW. These topics are a constant reality in my life.

Modificato da eyalnow il

more options

Soluzione scelta

Hi eyalnow, what I see in Firefox, Chrome, and Firefox Mobile is a responsive layout that varies depending on width. If you search in your style sheet (http://eyalnow.com/eyalnow/wp-content.../style.css) for 1260 you can see the media query which flips the layout for a document width of 1260px or higher.

That sound straightforward, but the measurement of page width (window.innerWidth) in Firefox 22 and later is different than in earlier versions because it is adjusted based on the zoom level, as part of Firefox's becoming a "DPI-aware" application. 1260 physical monitor pixels will be reported as a lower number if your zoom level is higher than 100%. For example, if the zoom level is 125%, it is reported as 1050 CSS layout pixels.

If you zoom up and down on the following play page, you can see how this new math works: http://dev.jeffersonscher.com/resolution.html

So... if you are viewing your site at a high zoom level and you want the "desktop" layout, what is the solution? One possibility is to leave it to the user to reduce the zoom level if they find the more compact layout to be too large for reading comfort. Another possibility is to experiment with additional variables to fine-tune the responsive behavior. I don't have enough experience to suggest how you might do that.

more options

funny enough, my webmaster just figured the same thing today, zoom level. indeed.

thank you, Jefferson, for putting all that time and effort into helping me.