X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è chiusa e archiviata. Inserire una nuova richiesta se occorre aiuto.

The bookmarks feature is not working. The right click bookmark this page won't save the bookmark.

Inserita
Locking duplicate thread.
Please continue here: [/questions/969841]

I'm not sure what happened but a few weeks ago all my bookmarks disappeared. I did the restore bookmarks but when I shut down and restart Firefox they were gone again. Now Firefox won't let me save any bookmarks.

<pre><i>Locking duplicate thread. Please continue here: [[/questions/969841]] </i></pre> I'm not sure what happened but a few weeks ago all my bookmarks disappeared. I did the restore bookmarks but when I shut down and restart Firefox they were gone again. Now Firefox won't let me save any bookmarks.

Modificato da cor-el il

Dettagli aggiuntivi sul sistema

Plugin installati

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • VLC media player Web Plugin 2.0.6
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Garmin Communicator Plug-In 4.0.4.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:23.0) Gecko/20100101 Firefox/23.0

Ulteriori informazioni

itsmemjithin 0 soluzioni 5 risposte

Try these options....

Fix the Bookmarks file

If your changes to your bookmarks do not appear when you restart Firefox, the issue may be that your bookmarks file is write-protected. A write-protected file can't be changed, which prevents Firefox from saving any changes you have made.

Allow Firefox to save bookmark changes:

  Open your profile folder:
  At the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.
  Under the Application Basics section, click on Show Folder. A window with your profile files will open.
  Note: If you are unable to open or use Fire​fox, follow the instructions in Finding your profile without opening Firefox.
  At the top of the Firefox window, click on the File menu and then select Exit
  Right-click the file places.sqlite, and select Properties to open the Properties window.
  In the Properties window, select the General tab. Near the bottom of the window, verify that Read-only is NOT selected.
  bookmarksnotsaved-readonly.png

Create a new Bookmarks file Bookmarks and browsing history are stored in the Firefox profile folder in the file places.sqlite. If there is a problem with this file, your bookmark changes may be lost whenever you restart Firefox. You can force Firefox to create another places.sqlite file by deleting the existing one.

You might want to print these directions out, or copy them down to reference because you will have to close Firefox to delete the files. Warning: Once you delete the places.sqlite file, you will lose all of your browsing history.

  Open your profile folder:
  At the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.
  Under the Application Basics section, click on Show Folder. A window with your profile files will open.
  Note: If you are unable to open or use Fire​fox, follow the instructions in Finding your profile without opening Firefox.
  At the top of the Firefox window, click on the File menu and then select Exit
  In your profile folder, delete the places.sqlite file and, if it exists, places.sqlite-journal.
  (Optional) Also delete the file localstore.rdf. This will reset any toolbar customizations you have made. 

Firefox will create a new places.sqlite file and automatically import the most recent bookmark backup file. Your bookmarks will be backed up, but you will lose your browsing history.



If nothing works,try this backup option:

At the top of the Firefox window, click the Bookmarks menu and select Show All Bookmarks to open the Library window.

From the toolbar on the Library window, click Import and Backup and choose Export Bookmarks to HTML....

In the Export Bookmarks File window that opens, choose a location to save the file, which is named bookmarks.html by default. The desktop is usually a good spot, but any place that is easy to remember will work.

Click the Save button. The Export Bookmarks File window will close.

Close the Library window.

Try these options.... Fix the Bookmarks file If your changes to your bookmarks do not appear when you restart Firefox, the issue may be that your bookmarks file is write-protected. A write-protected file can't be changed, which prevents Firefox from saving any changes you have made. Allow Firefox to save bookmark changes: Open your profile folder: At the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open. Under the Application Basics section, click on Show Folder. A window with your profile files will open. Note: If you are unable to open or use Fire​fox, follow the instructions in Finding your profile without opening Firefox. At the top of the Firefox window, click on the File menu and then select Exit Right-click the file places.sqlite, and select Properties to open the Properties window. In the Properties window, select the General tab. Near the bottom of the window, verify that Read-only is NOT selected. bookmarksnotsaved-readonly.png Create a new Bookmarks file Bookmarks and browsing history are stored in the Firefox profile folder in the file places.sqlite. If there is a problem with this file, your bookmark changes may be lost whenever you restart Firefox. You can force Firefox to create another places.sqlite file by deleting the existing one. You might want to print these directions out, or copy them down to reference because you will have to close Firefox to delete the files. Warning: Once you delete the places.sqlite file, you will lose all of your browsing history. Open your profile folder: At the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open. Under the Application Basics section, click on Show Folder. A window with your profile files will open. Note: If you are unable to open or use Fire​fox, follow the instructions in Finding your profile without opening Firefox. At the top of the Firefox window, click on the File menu and then select Exit In your profile folder, delete the places.sqlite file and, if it exists, places.sqlite-journal. (Optional) Also delete the file localstore.rdf. This will reset any toolbar customizations you have made. Firefox will create a new places.sqlite file and automatically import the most recent bookmark backup file. Your bookmarks will be backed up, but you will lose your browsing history. If nothing works,try this backup option: At the top of the Firefox window, click the Bookmarks menu and select Show All Bookmarks to open the Library window. From the toolbar on the Library window, click Import and Backup and choose Export Bookmarks to HTML.... In the Export Bookmarks File window that opens, choose a location to save the file, which is named bookmarks.html by default. The desktop is usually a good spot, but any place that is easy to remember will work. Click the Save button. The Export Bookmarks File window will close. Close the Library window.