X
Tocca qui per la versione per piattaforma mobile del sito.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Disable TLS on Firefox android

Inserita

hi I want to disable Tls on Firefox android but in setting not have tls please help

hi I want to disable Tls on Firefox android but in setting not have tls please help

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Android; Mobile; rv:20.0) Gecko/20.0 Firefox/20.0

Ulteriori informazioni

jscher2000
  • Top 10 Contributor
8956 soluzioni 73389 risposte

Risposta utile

You could try this:

In the Awesomebar, type or paste about:config and tap the Go arrow. I suggest bookmarking this page for future ease of access.

Type tls into the search box and tap the Enter key to find all preferences that contain tls.

Under security.enable_tls tap the Toggle button to switch its value from true to false.

Does that work?

There is a similar preference for ssl3.

I saw elsewhere that the ssl3 and tls preferences will be changing in Firefox 23. I'm not sure how the old preferences will migrate to the new ones...

You could try this: In the Awesomebar, type or paste '''about:config''' and tap the Go arrow. ''I suggest bookmarking this page for future ease of access.'' Type tls into the search box and tap the Enter key to find all preferences that contain tls. Under '''security.enable_tls''' tap the Toggle button to switch its value from true to false. Does that work? There is a similar preference for ssl3. I saw elsewhere that the ssl3 and tls preferences will be changing in Firefox 23. I'm not sure how the old preferences will migrate to the new ones...
hagi_mostafa 0 soluzioni 20 risposte

i have FF 23 x64 edition, due to severe filtering in iran the only solution which works is https proxies via proxifier app, i don't know exactly why but to enter facebook in this way we need to enter facebook just with secure address HTTPS://fb.com. chrome works fine but in firefox by default this error happens: An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) so when we disable TLS 1 in FF 20 then it works fine but as this option is no more availabe in FF 23 and as i guess in first question in FF mobile then it is a serious problem for us. i tried your solution but it didn't worked. any idea? thanks by the way

i have FF 23 x64 edition, due to severe filtering in iran the only solution which works is https proxies via proxifier app, i don't know exactly why but to enter facebook in this way we need to enter facebook just with secure address HTTPS://fb.com. chrome works fine but in firefox by default this error happens: An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) so when we disable TLS 1 in FF 20 then it works fine but as this option is no more availabe in FF 23 and as i guess in first question in FF mobile then it is a serious problem for us. i tried your solution but it didn't worked. any idea? thanks by the way
jscher2000
  • Top 10 Contributor
8956 soluzioni 73389 risposte

Risposta utile

Hi hagi_mostafa, in Firefox 23, please look for these preferences:

security.tls.version.min
security.tls.version.max

According to a comment in the code:

// 0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.

So try setting both min and max to 2, to force TLS 1.1, and see whether that works.

Hi hagi_mostafa, in Firefox 23, please look for these preferences: security.tls.version.min<br> security.tls.version.max According to a comment in the code: // 0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc. So try setting both min and max to 2, to force TLS 1.1, and see whether that works.
hagi_mostafa 0 soluzioni 20 risposte

excellent my friend! but 2 didn't worked, i set both to 3 and now it works nice and smooth! thanks

excellent my friend! but 2 didn't worked, i set both to 3 and now it works nice and smooth! thanks
nasim 0 soluzioni 4 risposte

hey thanks jscher2000 that worked for me, too you're wonderful, u know it?;-)

hey thanks jscher2000 that worked for me, too you're wonderful, u know it?;-)
nasim 0 soluzioni 4 risposte

salam chetori :-D damesh garmaaa cheghhadr bache bahushe

salam chetori :-D damesh garmaaa cheghhadr bache bahushe
hagi_mostafa 0 soluzioni 20 risposte

قربونت، اولا که باهوش نیس با 10هزار تا پست خورس ;) دوما که اشتباه گفت اصن اگه من راهنماییش نمیکردم و جوابش رو اصلاح نمیکردم به نتیجه نمیرسید :p

قربونت، اولا که باهوش نیس با 10هزار تا پست خورس ;) دوما که اشتباه گفت اصن اگه من راهنماییش نمیکردم و جوابش رو اصلاح نمیکردم به نتیجه نمیرسید :p
hagi_mostafa 0 soluzioni 20 risposte

میگم نره یوقت اینارو بزنه تو گوگل ترنسلیت بفهمه چی پش سرش گفتیم :|

میگم نره یوقت اینارو بزنه تو گوگل ترنسلیت بفهمه چی پش سرش گفتیم :|
hagi_mostafa 0 soluzioni 20 risposte

as i mentioned earlier i solved the problem in FF pc, but me and golnamak both have these issue in FF mobile

these commands aren't in mobile version. security.tls.version.min security.tls.version.max

does creating them help?

any other solutions? thanks golnamak fadat beshe ishala :)

as i mentioned earlier i solved the problem in FF pc, but me and golnamak both have these issue in FF mobile these commands aren't in mobile version. security.tls.version.min security.tls.version.max does creating them help? any other solutions? thanks golnamak fadat beshe ishala :)
jscher2000
  • Top 10 Contributor
8956 soluzioni 73389 risposte

Hi hagi_mostafa, what version do you have on Android? The min/max settings are coming in Firefox 23. They are not in the released version.

I don't think you will have to create them on Firefox 23, but it has been a while since I reviewed the documentation so I'm not 100% certain.

Hi hagi_mostafa, what version do you have on Android? The min/max settings are coming in Firefox 23. They are not in the released version. I don't think you will have to create them on Firefox 23, but it has been a while since I reviewed the documentation so I'm not 100% certain.