Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Questa discussione è chiusa e archiviata. Inserire una nuova richiesta se occorre aiuto.

firefox hanging with script error

  • 15 risposte
  • 15 hanno questo problema
  • 15087 visualizzazioni
  • Ultima risposta di the-edmeister

more options

firefox 20 has been hanging constantly with a different script error depending on the site visited. "Script: https://s.ytimg.com/yts/jsbin/www-watch-extra-vflEcdvg9.js:329" was encountered on youtube. I have tried safe mode with ad-ons disabled, reset firefox, rolled back versions of flash and java. nothing has worked. I am currently using google Chrome

Modificato da crlane il

All Replies (15)

more options

I noticed several different realplayer, shockwave etc plugins in your line-up. Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

plug-ins have been updated, no luck, still hangs

more options

Is the script, cited above ( "Script: https://s.ytimg.com/yts/jsbin/www-watch-extra-vflEcdvg9.js:329") just an example for several scripts hanging? Or is it the only one that causes you trouble?

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

The script error is an example, that particular one was encountered on youtube

more options

I have the same problem. Exactly the same! I've tried disabling the hw acceleration, entered in safe mode, updated, reinstalled, etc.

It doesn't matter the site, FF will crash after opening 2-3 tabs (approx), and just browsing any site.

This is my latest report ID: 45d02187-1ca8-41e8-8c2b-ff2222d21c4d

I've installed Chrome and I'm happier man. However, some idiot created a tool that I need to use at work, and it only works for FF. This is the best chance that Mozilla has to convince me to move back to my previous favorite browser :)

Thanks

more options

Hi toro445

Do you have crash reports that have a "bp-" prefix?

The one you posted doesn't seem to have been submitted.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

In the Location bar, type about:config and press Enter.

 - Click I'll be careful, I promise!, to continue to the about:config page. 

In the about:config page, search for the preference dom.max_script_run_time, and double-click on it. In the Enter integer value prompt, type 20. Press OK

-- Sadiq Fazal

more options

The script still loops endlessly

more options

Yeap, same here.

crlane, what configuration are you using? I'm running from a ThinkPad X1 (corei5) with win7 pro... I don't believe it's related to HW; all the other browsers are working perfectly. I'm using IE9, Opera, and Chrome (at this moment with 36 tabs opened)... just FF crashes

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Try to disable hardware acceleration in Firefox.

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
more options

Tried all of the above after resetting firefox. After resetting all my cookies were gone

more options

Turning Javascript off makes firefox work like normal. Other browsers have no issue. This started acting up on me about 4-5 days ago. Quite annoying to not be able to run firefox with javascript on. Is there a way to reinstall javascript?

I have tried safe mode, resetting firefox, reinstalling firefox, disabling addons, changing profiles, it really comes down to javascript being turned off fixes it for me. So despite being fairly computer savvy, I have no idea what is causing this. I ran Microsoft security essentials, a few malware/spyware utilities, checked hijackthis. I cannot find the issue. Firefox likely submitted 50+ crash reports.

more options

fbpat,

Please ask a new question - https://support.mozilla.org/en-US/questions/new - and provide the requested information.

Also open about:crashes in the URL bar and hit Enter. Please load the most recent crash reports and see what was reported. If you need help interpreting those crash reports, please submit those report ID's to this forum and one of us can look at them.

more options

locking this thread due to age - plus it's gone off-topic - hanging vs. crashing