Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to override System admin's forced home page?

  • 4 risposte
  • 2 hanno questo problema
  • 21836 visualizzazioni
  • Ultima risposta di piyush_soni

more options

So our System admin forces upon us a really slow internal website as our Home page. Fortunately it is not that big of a problem in Firefox (as it's in IE, but who uses that?) since I've set the browser to start all last opened tabs and windows on a Firefox restart, but as soon as we start a new window, that page opens up and I hate that. Any way I can override these system forced settings? Whenever I change that back to about:blank or Firefox Start page, probably on next system restart or whenever the group policies are enforced again it's changed back to that slow website.

Since Firefox is open and highly customizable, I was thinking there might be a way to do that (I won't mind an add-on to do that). Thanks!

Soluzione scelta

That is not good enough. I actually got the solution myself, and I don't mind telling that on the web (when injustice becomes law, rebellion becomes duty :) ).

This was the registry key which was doing that for my Firefox:

HKEY_USERS\<my-user-specific-key>\Software\Policies\Firefox.

Just change the value of FirefoxHomepage to fix the problem. Add a batch file to do that on each system startup, and you're all set.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (4)

more options

Well, I'm hesitant to work around company policy, so I'm only going to make a limited suggestion, and that is the following. If you don't mind clicking a button or menu item to launch a new window, you could create a bookmarklet on your Bookmarks Toolbar or Bookmarks Menu.

If you want to try it, here are the steps:

(1) Select and copy one of the following lines of script (each is one long line; of course you can edit the URL later):

(i) Blank window

javascript:void(window.open("about:blank", "_blank", "menubar,toolbar,personalbar,location,resizable,scrollbars,status"));

(ii) Firefox built-in home page

javascript:void(window.open("about:home", "_blank", "menubar,toolbar,personalbar,location,resizable,scrollbars,status"));

(iii) Mozilla Support Hot Topics

javascript:void(window.open("https://support.mozilla.org/topics/hot", "_blank", "menubar,toolbar,personalbar,location,resizable,scrollbars,status"));

(2) Right-click the Bookmarks Toolbar and choose New Bookmark. (If you do not ordinarily display the Bookmarks Toolbar, you can add it to the menu instead. Whatever will be convenient.)

(3) Click in Location and paste the script.

(4) Click in Name and name it whatever you like (e.g., NewWin) and then click Add.

Now click the bookmarklet button to launch a new window.

more options

Soluzione scelta

That is not good enough. I actually got the solution myself, and I don't mind telling that on the web (when injustice becomes law, rebellion becomes duty :) ).

This was the registry key which was doing that for my Firefox:

HKEY_USERS\<my-user-specific-key>\Software\Policies\Firefox.

Just change the value of FirefoxHomepage to fix the problem. Add a batch file to do that on each system startup, and you're all set.

Modificato da piyush_soni il

more options

How did the Firefox home page previously show on the about:config page?

  • browser.startup.homepage

Was that a bold (user set pref) or a modified default pref or a locked pref?

more options

@cor-el, I don't know that :( ... I can only see that right now it is bold (after I changed that to about:blank both from registry and the browser settings)