Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Issues "pinning" to the New Tabs Page

  • 11 risposte
  • 2 hanno questo problema
  • 1987 visualizzazioni
  • Ultima risposta di wolfwoman1st

more options

When I attempt to "pin" a top site from my bookmarks (drag then drop), per the instructions given by Firefox, it doesn't pin it. All it does is open the page in a tab. I was wondering if anyone knew how to fix this?

Additional info: I also cannot pin the website while open because the "pin" thing that Firefox talks about in the top left corner doesn't appear. I'm running the latest version of Firefox with a Windows 7 (SP2) OS Platform, in the "default" theme. My homepage loads fine. If there's anything else you need to know, ask me.

Soluzione scelta

Do you at least see the 9 (3x3) squares on the about:newtab page?

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Leggere questa risposta nel contesto 👍 3

Tutte le risposte (11)

more options

If you have the "New Tab" page open, you must drag a Bookmark from the Bookmark window to the 'New Tab' page and drop it on one of the Empty Squares. In the top left corner a blue square with a "Pin" should appear. Click this will Remove the shortcut if the Square is Blue not Grey. Click it when its Grey will "Pin" it (turn it blue)

more options

I tired that.

All it does when I drag the bookmark over to an empty square is open the bookmark into another tab. It doesn't pin it.

Also, the blue "Pin" square doesn't appear in the left-hand corner at all.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

more options

Okay. So, I ran Firefox in Safe Mode and the issue was still occurring there. I tried disabling all Extensions. I tried disabling Hardware Acceleration. Nothing. The problem is still occurring. All it does is open the website I'm trying to drag from my bookmarks and pin. It doesn't actually pin it.

more options

Soluzione scelta

Do you at least see the 9 (3x3) squares on the about:newtab page?

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
more options

I was able to see the nine boxes, yes.

I went into the privacy settings and unchecked the "Always use private browsing mode" box, which I'm not sure how it got checked since I didn't have it checked before. I also made sure that it said "Use custom settings for history" from the drop-down options there. This fixed the issue and I was able to pin to the page! Hopefully Firefox will allow us to pin more than just nine sites soon, as Chrome, Opera, and Safari do. I'm glad they've enabled this feature so far though :D

Thank you so much cor-el! I wouldn't have been able to figure this out without your help! If I could give you reps, I totally would :-)

more options

Firefox can pin more than nine sites, but you have to make the change on the about:config page.

  • browser.newtabpage.columns (3)
  • browser.newtabpage.rows (3)
more options

Amazing! Thanks again :D

more options

This just happened to me, and (unlike original question) I do NOT see the squares anymore, either! I did read through to the end of this thread and followed all the instructions given, but nothing got them back. Should I uninstall and reinstall Firefox?

more options

Hi wolfwoman1st

Is the new tab page still set to about:newtab?

Do you get the the new tab page if you open the about:newtab page via the location bar?

You can check the value of the browser.newtab.url pref on the about:config page.


more options

Thank you, cor-el - I am sure this would have worked and I've saved it for future reference! I'm afraid I was impatient and simply uninstalled, then reinstalled Firefox. My tabs are back and all is working well. Happy me!