Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to disable Plugin Check from opening every time browser opens

  • 12 risposte
  • 33 hanno questo problema
  • 20087 visualizzazioni
  • Ultima risposta di denovo

more options

Every time I open firefox, "plugin check" opens. Even after I installed and updated all plugins, the plugin-check appears whenever firefox opens. After updating all the plugins I restarted my pc, reset the browser and checked to make sure that my home page has not been changed the firefox plugin change, disabled all my plugins and even tried blocking the website via HOSTS.

I am fully capable of checking to see if my browser and plugins are up-to-date and I don't appreciate the unnecessary waste of time with this plugin-check running every single time the browser opens. Similar to updates, this should be an OPTIONAL check not FORCED and there should be a simple way to disable it without having the browser open an extra blank tab or requiring the user to edit the about:config to work around it.

Website: https://www.mozilla.com/en-US/plugincheck/

Soluzione scelta

hello, please update firefox to the latest version - this is a problem that normally only occurs on older builds...

Leggere questa risposta nel contesto 👍 5

Tutte le risposte (12)

more options

Soluzione scelta

hello, please update firefox to the latest version - this is a problem that normally only occurs on older builds...

more options

I also have this problem - started not too long ago, after i inadvertently updated firefox. I have now updated to the latest versionavailable to me, 12.0, and it still opens up a plugin check tab every time i open firefox. After the upgrrrrade to firefox12.0 my addons were updated by firefox, yet the tab persists. I have spent considerable time now trying to get rid of this annoying problem and am like many others on the verge of dumping firefox to avoid this annoyance. I have used firefox for many years nowa nd will be sorry to do so, but i have lost patience with this matter. I generally will not allow automatic updates because it seems to me they cause as many problems as they fix, and if i want to do something on my pc i do not want to be diverted by irrelevant activities. Is there a sure way to remove this annoyance? If not, i'm off to another browser - i see Chrome being recommended. Any other recommendations?

more options

Now that was weird!! I had updated firefox just a few minutes ago using the menu <Help/About/Check for Updates> and firefox updated itself without asking further - but only to 12.0 Thinking this must be the latest i posted my complaint re the "check updates" tab opening every time. On a whim, i went to <Help/About/Check for Updates> again and firefox downloaded another 25 MB (i nearly stopped it thinking it was going to get me 12.0 again) but it has now updated to 22.0 and that annoying tab has now stopped, so Phillipp was correct when he said update to the latest but he didn't say the latest would not be immediately forthcoming using the update feature in the Help menu. Oh well, at least i've learnt something, but here's another question - how do i REALLY get the latest update, and is 22.0 it??

more options

Hello mphillipsaustralia

probably you have Windows 2000 or Windows XP or XP (with sp1).

For Windows 2000 and Windows XP or XP (with sp1) the latest supported version from firefox is 12.0, see : Firefox 12 System Requirements

Firefox 13 System Requirements, check the difference in xp versions between 12.0 and 13.0.

see also: Firefox no longer works with some versions of Windows XP

to get the latest version you must upgrade at least to Windows XP with sp2, see : Firefox 22 System Requirements


thank you

more options

Thank you for your interest ideato. I have been using xp sp3, have done so for many years now, and all was fine with firefox - i was probably on version 3 or something - until very recently. Recent inadvertent upgrade to version 5 seems (maybe) to have caused my issues with firefox. Now that i've upgraded to the latest version 22 of firefox the issue has been fixed, just as Phillipp said it would. Version 22 fixed my problem. As to why my downloads of firefox took me in steps to version 12 then with another 'go' minutes later to version 22 is beyond my comprehension, but hey, i've come to appreciate that computers and software is magic, ineffable, and not for mortals like me to delve too deeply into! thanks again.

more options

This can happen if you have plugins installed that have been blocklisted and disabled.

more options

Hello cor-el,

This can happen if you have plugins installed that have been blocklisted and disabled.

thank you, always learning from you, thanks again

more options

I have firefox 3.6 and windows xp sp2, now just recently this stupid plugin check keeps popping up every time i open my firefox.

Yes i know most would tell me to update my firefox to correct it.

BUT I DO NOT WANT A NEW VERSION. if i wanted it i would download it. My version 3.6 was fine until today. I personally hate the new versions of firefox, and have no use for them. many needed plugins were not updated for the newer firefox. If i have to update to something I DON'T WANT i may as well use internet explorer. i want to keep my old firefox without having to update it every time mozilla feels like changing or adding some stupid feature i do not use, need or want. leave versions alone for petes sake mozilla

with that said how can i permanently stop that stupid checker ?

Modificato da defuz2013 il

more options

Hello defuz2013, go to about:config find plugins.update.url and change it the value to an empty string.

also change the plugins.hide_infobar_for_outdated_plugin to TRUE

then check firefox again


thank you

more options

I tried both suggestions but Firefox still tries to open the plugins check page, just that it's blank now since I changed the string value to an empty string.

How to stop the plugins check without upgrading Firefox...it's only been occurring for the past week, v12 worked fine for months without this problem.

more options

Do you know which outdated and probably blocklisted plugin is causing this?

more options

I appear to have this solved now -

I am running 3.6.27 and, like previous posters, would like to decide for myself when and if I want to upgrade, and hate this extra tab that started recently.

If you set the key <plugins.update.notifyUser> in about:config to false (which is the default value by the way), it stops the behaviour once, then reverts on the next opening. Bizarre !!

But you can override this behaviour thus: 1) in your Firefox Profiles folder -- in XP this is <C:\Documents and Settings\[your user name]\Application Data\Mozilla\Firefox\Profiles\[your folder number].default> -- find the file <user.js>. If the file doesn't exist then make a new text file in that folder using Notepad, and save it as <user.js> (ie: NO .txt extension).

2) Inside <user.js> (open it by opening a Notepad window and then dragging the filename into that window) write (copy in) the two lines:

// Don't show plugins update tab on startup user_pref("plugins.update.notifyUser", false);

Then save the file.

The first line is just a comment to say what the following line is for. The second line overwrites that particular preference line in about:config every time you open Firefox.

Works for me - hope you all find that helpful.