X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 18 not keeping persistent cookies.

Inserita

This also happens in FF 18 - cookies that are supposed to be retained are not.

I tried the SQLite Database Browser tool, but found no questionable entries like the ones outlined above.

I tried deleting site preferences - no change. Tried deleting permission.sqlite. Still no change.

What this is showing up in is my online banking. It asks you to register the computer, and supposedly puts a "secure cookie" in the browser. This no longer works - everytime I have to go through the process of asking for a new code via email. This works fine in IE, and used to in Firefox. What is odder is that if I ask it to show cookies, it shows it with an expiration of Jan. 2100. But it does not seem to be accessble to FF anymore, while it used to be. Any other ideas?

This also happens in FF 18 - cookies that are supposed to be retained are not. I tried the SQLite Database Browser tool, but found no questionable entries like the ones outlined above. I tried deleting site preferences - no change. Tried deleting permission.sqlite. Still no change. What this is showing up in is my online banking. It asks you to register the computer, and supposedly puts a "secure cookie" in the browser. This no longer works - everytime I have to go through the process of asking for a new code via email. This works fine in IE, and used to in Firefox. What is odder is that if I ask it to show cookies, it shows it with an expiration of Jan. 2100. But it does not seem to be accessble to FF anymore, while it used to be. Any other ideas?

Modificato da jaman57 il

Soluzione scelta

It is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
Leggere questa risposta nel contesto 1

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • GEPlugin
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1662

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

Ulteriori informazioni

cor-el
  • Top 10 Contributor
  • Moderator
17668 soluzioni 159825 risposte

Soluzione scelta

It is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
It is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookie files like <b>cookies.sqlite-journal</b> in the Firefox Profile Folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Utente che ha posto la domanda

Renaming the cookies.sqlite file, allowing FF to create a new one, solved the problem. Thank you very much!

Renaming the cookies.sqlite file, allowing FF to create a new one, solved the problem. Thank you very much!
cor-el
  • Top 10 Contributor
  • Moderator
17668 soluzioni 159825 risposte

You're welcome

You're welcome