Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I stop firefox from changing my language all the time?

  • 6 risposte
  • 1 ha questo problema
  • 2954 visualizzazioni
  • Ultima risposta di Eamon123

more options

It keeps resetting my spellcheck to US English. I have to manually change it in the right click context menu of multi-line text boxes, every time.

Soluzione scelta

Thanks for all your help guys. I uninstalled and installed the version preconfigured for my locale. Pretty fool-proof way to fix it and it worked. :)

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (6)

more options

hello Eamon123, maybe the database that stores this information got corrupted somehow.

please go to firefox > help > troubleshooting information > profile - show folder & close firefox. in the windows that opened up look for the file named content-prefs.sqlite and delete or rename it. the database will be regenerated the next time you launch firefox & hopefully the custom zoom levels will be stored again in the future.

more options

madperson: I did that and the language is still being reset.

more options

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can consider to reset Firefox.

If you reset Firefox then a new profile is created and some of your data (bookmarks, passwords, cookies, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data).

You can recover more data from the old profile (be cautious with doing that).

more options

co-rel: I reset Firefox and the language is still being reset.

more options

What is the value of the spellchecker.dictionary pref(s) on the about:config page?

Do you have a user.js file in the chrome folder in the Firefox Profile Folder that may be overriding the current setting on each start of fx ?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

Soluzione scelta

Thanks for all your help guys. I uninstalled and installed the version preconfigured for my locale. Pretty fool-proof way to fix it and it worked. :)