X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

New tab page FF13.0 doesn't show thumbnails of sites, only empty box but site is mentioned.

Inserita

Updated to this version but the new tab page didn't save my most visited sites as is the intention. Dragged my most used websites over there and worked but there is no thumbnail-picture or anything to show, just empty boxes with just below the site described as in my bookmarks.

Updated to this version but the new tab page didn't save my most visited sites as is the intention. Dragged my most used websites over there and worked but there is no thumbnail-picture or anything to show, just empty boxes with just below the site described as in my bookmarks.

Soluzione scelta

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

Leggere questa risposta nel contesto 31

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 11.2 r202
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • 4.1.10111.0
  • Garmin Communicator Plug-In 4.0.1.0
  • Logitech Device Detection
  • BlackBerry WebSL Browser Plug-In

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

Ulteriori informazioni

Matt_G 365 soluzioni 1860 risposte

Hey Ostrakizein,

I just tried this on FF 13 and I can reproduce what you are reporting. However, if I then click on each of those links to actually load the page then the thumbnails appear the next time I open the new tabs page. You might want to give that a try.

Hopefully this helps!

Hey Ostrakizein, I just tried this on FF 13 and I can reproduce what you are reporting. However, if I then click on each of those links to actually load the page then the thumbnails appear the next time I open the new tabs page. You might want to give that a try. Hopefully this helps!

Utente che ha posto la domanda

Just clicked every link, closed FF and even restarted my computer to see but still nothing appears... It's just a small annoyance but do you have any other ideas to solve this?

Just clicked every link, closed FF and even restarted my computer to see but still nothing appears... It's just a small annoyance but do you have any other ideas to solve this?
cor-el
  • Top 10 Contributor
  • Moderator
17773 soluzioni 160751 risposte

Soluzione scelta

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.<br /> Do not use Clear Recent History to clear data when you close Firefox.<br /> If there is no history then you get an about:newtab page with empty boxes.

Utente che ha posto la domanda

Thank you very much for your help!

Thank you very much for your help!
Fidodido1966 0 soluzioni 1 risposte

Here's the exact procedure to fix this problem (I'm translating from the french version so please be understanding):

1-Go in Tools - Options - Privacy tab 2-In the History drop down menu, you need to select "keep all history". If you don't like Firefox to be configured that way, then forget it this will not work. 3-Click on the + to open up a new tab 4-Click on one of the links under an invisible thumbnail and make sure you let the website load completely before doing anything else 5-Click on the + to open up a new tab again. This time you will see the thumbnail relating to the page you let load. 6-Repeat this process for each link that still show an invisible thumbnail

Here's the exact procedure to fix this problem (I'm translating from the french version so please be understanding): 1-Go in Tools - Options - Privacy tab 2-In the History drop down menu, you need to select "keep all history". If you don't like Firefox to be configured that way, then forget it this will not work. 3-Click on the + to open up a new tab 4-Click on one of the links under an invisible thumbnail and make sure you let the website load completely before doing anything else 5-Click on the + to open up a new tab again. This time you will see the thumbnail relating to the page you let load. 6-Repeat this process for each link that still show an invisible thumbnail
tony2murray 0 soluzioni 3 risposte

I have this problem. I tried the options above (keep history), let linked pages load completely, and also clearing cache (in case the cache was full - suggested here: https://support.mozilla.org/en-US/kb/thumbnails-on-new-tab-page-are-missing?s=new+tab&r=1&e=es&as=s). None worked so far. I'm using Firefox on Kubuntu.

I have this problem. I tried the options above (keep history), let linked pages load completely, and also clearing cache (in case the cache was full - suggested here: https://support.mozilla.org/en-US/kb/thumbnails-on-new-tab-page-are-missing?s=new+tab&r=1&e=es&as=s). None worked so far. I'm using Firefox on Kubuntu.
chad_work 0 soluzioni 3 risposte

Risposta utile

Here's the correct procedure to fix this problem:

1) Click the orange Firefox tab, then Options, or if you have the Menu bar showing, click Tools, Options

2) In the Options window, click Privacy

3) Under the History section, either choose Remember History, or:

4) With Use custom settings for history selected, and the Clear history when Firefox closes check box checked, click the Settings button to the right of this check box, and in the Settings for Clearing History window, under the History section, you'll have to uncheck Cache. Having Cache checked clears the cache when Firefox closes. The New Tab page preview uses this cache to fill-in the pages with graphics. With Cache unchecked, you can browse to a site and its page will have a graphic on the new tab page.

Here's the correct procedure to fix this problem: 1) Click the orange Firefox tab, then Options, or if you have the Menu bar showing, click Tools, Options 2) In the Options window, click Privacy 3) Under the History section, either choose Remember History, or: 4) With Use custom settings for history selected, and the Clear history when Firefox closes check box checked, click the Settings button to the right of this check box, and in the Settings for Clearing History window, under the History section, you'll have to uncheck Cache. Having Cache checked clears the cache when Firefox closes. The New Tab page preview uses this cache to fill-in the pages with graphics. With Cache unchecked, you can browse to a site and its page will have a graphic on the new tab page.
tony2murray 0 soluzioni 3 risposte

Risposta utile

Hi Chad, - thanks for quick reply. The solution did not immediately solve the problem for me. I found further info here: https://bugzilla.mozilla.org/show_bug.cgi?id=726267 . I was able to solve by going to: about:config and changing: browser.cache.disk.enable to "true".

The thumbnails now show up.

I also toggled the Cache setting you mentioned under custom settings for history. As you mentioned, the cache setting needs to be unchecked.

Hi Chad, - thanks for quick reply. The solution did not immediately solve the problem for me. I found further info here: https://bugzilla.mozilla.org/show_bug.cgi?id=726267 . I was able to solve by going to: about:config and changing: browser.cache.disk.enable to "true". The thumbnails now show up. I also toggled the Cache setting you mentioned under custom settings for history. As you mentioned, the cache setting needs to be unchecked.
Adeveau 0 soluzioni 3 risposte

I'm getting this message..

The address isn't valid The URL is not valid and cannot be loaded.

Web addresses are usually written like
   http://www.example.com/
Make sure that you're using forward slashes (i.e.   /).
I'm getting this message.. The address isn't valid The URL is not valid and cannot be loaded. Web addresses are usually written like http://www.example.com/ Make sure that you're using forward slashes (i.e. /).
geowits 0 soluzioni 2 risposte

How do I get to "browser.cache.disk.enable"? I cant find any access to a configure screen.

How do I get to "browser.cache.disk.enable"? I cant find any access to a configure screen.
geowits 0 soluzioni 2 risposte

I found it - both were "true".

I found it - both were "true".
cor-el
  • Top 10 Contributor
  • Moderator
17773 soluzioni 160751 risposte

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.
Do not use Clear Recent History to clear data when you close Firefox.
If there is no history then you get an about:newtab page with empty boxes.

Make sure that you do not run Firefox in permanent Private Browsing mode.

The thumbnails on the about:newtab page are generated from the cache, so if the page is not in the cache or otherwise can't be rendered as a PNG image then you will get an empty box.<br /> Do not use Clear Recent History to clear data when you close Firefox.<br /> If there is no history then you get an about:newtab page with empty boxes.<br /> <br /> Make sure that you do not run Firefox in permanent Private Browsing mode. *https://support.mozilla.org/kb/Private+Browsing
Nisa51 0 soluzioni 4 risposte

My New Tab Page does not work at all. I just have the empty squares with nothing in them at all? Why is this

My New Tab Page does not work at all. I just have the empty squares with nothing in them at all? Why is this
cashsimpson 0 soluzioni 1 risposte

what i dont get is this...i like having my cache cleared and all i want is a thumbnail....is there no way to have both? I mean when i bookmark a page the favicon stays on there even though i clear my cache and history and everything. No way to just take a snapshot or something?

what i dont get is this...i like having my cache cleared and all i want is a thumbnail....is there no way to have both? I mean when i bookmark a page the favicon stays on there even though i clear my cache and history and everything. No way to just take a snapshot or something?
cor-el
  • Top 10 Contributor
  • Moderator
17773 soluzioni 160751 risposte

Future Firefox versions will use its own thumbnails folder to store the thumbnails to avoid this choice, but that won't happen in Firefox 13.

  • bug 744388 - [Page Thumbnails] implement a custom storage, don't use the file cache

(please do not comment in bug reports)

Future Firefox versions will use its own thumbnails folder to store the thumbnails to avoid this choice, but that won't happen in Firefox 13. *[https://bugzilla.mozilla.org/show_bug.cgi?id=744388 bug 744388] - [Page Thumbnails] implement a custom storage, don't use the file cache <i>([https://bugzilla.mozilla.org/page.cgi?id=etiquette.html please do not comment in bug reports])</i>

Modificato da cor-el il

Nisa51 0 soluzioni 4 risposte

For some reason mine have started working now,!!!

For some reason mine have started working now,!!!
romaba 0 soluzioni 2 risposte

Thanks chad_work for your help resolving this issue.

Thanks chad_work for your help resolving this issue.

Modificato da romaba il

cb474 0 soluzioni 4 risposte

I have also found that this feature will not work with encrypted (SSL) pages.

I have also found that this feature will not work with encrypted (SSL) pages.
titaniumbones 0 soluzioni 3 risposte

I have also tried all the cache-related fixes suggested on this page, and am having the same problem. I'm running 14.0-b6 from the firefox-next PPA on Ubuntu (Precise), but have been having htis problem since the early 13.0 betas. Thanks!

I have also tried all the cache-related fixes suggested on this page, and am having the same problem. I'm running 14.0-b6 from the firefox-next PPA on Ubuntu (Precise), but have been having htis problem since the early 13.0 betas. Thanks!
gaby2300 0 soluzioni 7 risposte

Fidodido1966, I follow your procedure and it worked fine. Many thanks for such a clear strategy!!!!

Fidodido1966, I follow your procedure and it worked fine. Many thanks for such a clear strategy!!!!