Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 8 hangs seemingly randomly

  • 6 risposte
  • 85 hanno questo problema
  • 3 visualizzazioni
  • Ultima risposta di Jim Fell

more options

I recently upgraded from Firefox 3.whatever to 8, and while it's mostly working better, Firefox occasionally hangs for no reason that I can determine. The time between these hangs can be anywhere from a few minutes to an hour or so. When it hangs, it hangs for a few seconds, resumes normal operation for a few seconds, then hangs for anywhere from a few more seconds to two minutes or so. I've tried disabling my various add-ons with no change. I have a lot of tabs open, but closing the ones that seemed most likely to be causing problems solved nothing.

Tutte le risposte (6)

more options

Try updating your video card NVIDIA driver.

Is your AVG Safe Search plug in up to date? It can cause slowness.

Do you use ChatZilla? If not try disabling the plug-in.

Do you need the Java Quick Starter plug-in? Update your Java installation and disable the plug-in when you're not using it.

Do you need to have the Microsoft .NET Framework Assistant plug-in enabled? Disable it if not.

Type: "about:config" (without the quotes) into the Firefox urlbar/address bar (and press enter). You'll get a warning message to be careful. Accept that, then you'll be presented with a list of configuration items. Type in that window's search bar (not the Firefox search bar) the letters "prefetch" (without the quotes). You'll see an item listed as: network.prefetch-next and to the right of it the current setting. Right click on the value and select Modify, and change the value to True, then restart your browser.

If any of these things help, please let us know.

more options

I've already tried disabling all the add-ons, as I said initially. Clearing my history seems to have vastly reduced the length of these freezes to a second or less, but they still happen (though it's often difficult to tell WHEN they are happening now).

I do not understand how prefetch will make the browser stop having CPU usage spikes that cause it to freeze, but I'll enable it. Also, what would my video driver have to do with anything? It doesn't seem to be freezing because it's trying to render something.

more options

How old is your Firefox profile? Have you tried to create a new profile to see if that helps? If not, see Profile Manager - Create, remove or switch Firefox profiles and create a new profile for testing with no add-ons or printers selected.

Video drivers that are buggy can have odd and unexpected results. Best to methodically update everything so you know there are no loose ends.

Please check back to report your progress when you've had a chance to update your driver and try a new profile, (we'll call it profile B).

Also, I noticed in your config that your databases for Firefox look bloated. Download the SQLite Manager plug-in and install it in your new profile. Then use it to check your current profile's (profile A) data stores (bookmarks, etc.,) for integrity and compact them. This process vacuums out all the old slack space from the data files and can have the effect of speeding things up.

Modificato da sctl il

more options

I don't really understand how it would help, but I updated my video drivers.

I then created a new profile, switched to it, installed that plug-in... then I had no idea what you wanted me to do with it, so I tried reproducing the freeze on both profiles by running a virus scan (since Firefox seemed to be freezing more when it didn't get as much of a core as it wanted). It happened on neither profile. It may be a fluke, but something I did during that seems to have fixed it. I don't know if it will start happening again.

more options

Well, fingers crossed. Check back in if the problem begins again.

The SQLite Manager plugin is a tool you can use to repair and compact SQLite databases -- the .sqlite files now used in Firefox to house your bookmarks and other preferences are mini-databases, and as such become tired after long use. Records in them that are deleted leave slack space, eventually bloating the files and making them slow and sometimes unresponsive.

To use the tool, open it and then from the top menu bar in the tool, click Open Database, then navigate to where your Firefox (old) profile is stored, and select a .sqlite file. (The bookmarks file is one called "places.sqlite") For each .sqlite file, you can use the menus in the tool to check the integrity of each file, and compact and repair the file. This reduces the size of the file and re-indexes it, making it faster and more responsive. Go though the process for each .sqlite file.

You can't open a .sqlite file while you're using it, so this is why you must work on profile files from a different profile.

There is also a nice add-on called CheckPlaces that will automate the process, but only for your bookmarks folder.


edited to add file example

Modificato da sctl il

more options

I've noticed that this problem only occurs when I have pages loaded (in one or more tabs) that are running active content (e.g. AJAX, Flash, etc.). The problem never occurs when only static pages are loaded. This leads me to believe that their may be a problem with Firefox's handling of HTMLrequest or response messages in regards to processing dynamic content. For example, a thread may be spinning waiting for a response.