Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox does not save the websites from a previous seession even though the box is checked.

  • 5 risposte
  • 2 hanno questo problema
  • 1 visualizzazione
  • Ultima risposta di cor-el

more options

I have recently upgraded to Firefox 5.0. I am having two problems since the upgrade:

1. Firefox no longer saves the websites that I left 0pen from a previous session even though the box is checked to do so. Additionally, I am never given the option to "restore previous session" from the history menu. It is always "ghosted" out and cannot be selected from the menu.

2. When I open Firefox, regardless of whether I use a shortcut or access the browser any other way, multiple instances are opened automatically. I suspect that the number of instances are equivalent to the number of tabs I left open in the previous session but I'm not sure about this. They all open to a blank page, however, and do not open to the websites that were assigned to each tab in the previous session.

Thank you for your assistance.

Soluzione scelta

You can check if session restore is enabled [1].

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the files sessionstore.js [2] and sessionstore.bak in the Firefox Profile Folder.

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.
Deleting sessionstore.js will cause App Tabs and Tab Groups and all open tabs to get lost, so you will have to create them again (make a note or bookmark them).

See:

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (5)

more options

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"

See also:

more options

Thank you for the response. I checked my browser settings using your instructions and "Firefox will remember browsing history" was selected, and Permanent Private Browsing was not chosen under custom settings, so Private Browsing is not the problem, it seems. That was a good idea, though, because I hadn't thought to check that setting! Thanks again! Any other thoughts? Anyone? :-)

more options

Soluzione scelta

You can check if session restore is enabled [1].

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the files sessionstore.js [2] and sessionstore.bak in the Firefox Profile Folder.

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.
Deleting sessionstore.js will cause App Tabs and Tab Groups and all open tabs to get lost, so you will have to create them again (make a note or bookmark them).

See:

more options

Thank you. It worked!! I really appreciate your suggestions!