Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

.bin extension defaults to wrong action and is not listed in options applications tab. I can't change the action.

  • 9 risposte
  • 4 hanno questo problema
  • 7558 visualizzazioni
  • Ultima risposta di snowbropatrol

more options

I recently installed VLC player and it has overtaken my system.

When I click on .bin (ext) files in a Firefox browser window, the default action is now listed as "VLC.bin (default)" and nothing I do can change it. I want the default action to be to download the file and I would like to remove any option related to VLC, since no .bin file should ever be associated with that program.

There is no listing for a .bin extension for VLC (or any other program, for that matter*) in the Options/Applications tab, nor is VLC player the default action for anything listed except .wav files.

I have tried the following:

1. searched the options/applications tab but found nothing.

2. searched "about:config" for any entries with "bin", ".bin", or "vlc" (one at a time) and found nothing.

3. searched the registry for bin extension entries. I found one: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.bin\OpenWithProgids] "bin_auto_file"=hex(0): "VLC.bin"=hex(0): I deleted the key and rebooted. No change.

4. Double checked [HKEY_CURRENT_USER\Software\.. Gabest and Mozilla keys for anything that could be causing this behavior. Found nothing.


Any help would be appreciated.


  • As far as I can tell. However, the applications tab cuts off many of the extension names and the column cannot be extended, so I can't be certain. VLC added 34 extensions to the list (!), most of which default to using the Quicktime plugin 7.6.8.

Soluzione scelta

Anything here for .bin ?

  • Control Panel > Folder Options > File Types:

You may need the check the .bin file extension in the Windows registry to check the default action.
Do a search in this key for .bin via Ctrl + F

  • MIME Database : HKEY_CLASSES_ROOT\MIME\Database\Content Type\
Leggere questa risposta nel contesto 👍 0

Tutte le risposte (9)

more options

Firefox usually chooses a download action based on a content-type header sent by the server. This usually but does not always match up with the file extension.

To try to uncover the problem setting, return to

Tools > Options > Applications

and enter VLC into the search box.

Scan the list for any content types that don't seem to belong to VLC and change their action to "Always Ask".

Does that help?

By the way, if you hover your mouse very patiently over an item in the left column of the Applications tab, a tooltip eventually will appear showing the full entry. It would be better if you could expand the dialog...

Modificato da jscher2000 il

more options
more options

Thanks jscher2000, I tried your suggestion, but no joy (as expected). None of the extensions were .bin, and in fact, I can't find a single listing for handling the .bin extension in the entire (unfiltered) list.

That's why I'm so confused. Where is Firefox getting the name "VLC.bin (default)" from in the first place?


cor-el, I checked out the link that you posted.

I don't have an entry for "browser.download.pluginOverrideTypes" and the entry "plugin.disable_full_page_plugin_for_types" was empty (default setting).

My bad, but I forgot to mention in my first post that I had also tried renaming the mimetypes.rdf file in my "Application Data\Mozilla\Firefox\Profiles\xxx.default\" to .old to no avail.

Firefox created a new, almost empty file, but it didn't change the behavior for .bin files. I removed the new file and put the old file back in place after determining that clearing the file did not help, since I am otherwise happy with my current file-type options.

However, since the option to "Always perform this action" is grayed-out, I am looking into the possibility that the website is sending a misconfigured MIME type or is assigning "Content-Disposition: attachment" to the download. What's odd, though, is that I've never had problems getting binary files from the site in the past, and the problem started when the VLC player was installed.

I'll post back after I check into the server header data.

Modificato da snowbropatrol il

more options

I wasn't expecting a .bin extension. I was thinking that you might want to just change everything that isn't recognizable as a video format. However, cor-el's solution probably is quicker than experimenting.

---

One other thought: many media players have detailed configuration dialogs for which media they will handle. In QuickTime, there are two dialogs: one by file extension, and another by MIME type. Does VLC have anything similar?

Modificato da jscher2000 il

more options

As I mentioned, I did try it anyway. but with no results. Still, it was worth a shot. :)


I did check VLC. I wasn't able to find anything relating to .bin files. There are so many settings in there that it's possible I missed the crucial option. The closest thing I could find was under "Input / Codecs" / "Access Modules" / ... there are settings for FTP, File, HTTP(S), TCP, and UDP, but nothing that would seem to affect this action.

Modificato da snowbropatrol il

more options

Soluzione scelta

Anything here for .bin ?

  • Control Panel > Folder Options > File Types:

You may need the check the .bin file extension in the Windows registry to check the default action.
Do a search in this key for .bin via Ctrl + F

  • MIME Database : HKEY_CLASSES_ROOT\MIME\Database\Content Type\
more options

cor-el, You GOT IT. There were entries in both places. I hadn't thought to check the file extensions for Explorer -- I didn't think they would affect Firefox; and I didn't know about the MIME key in HKCR.

I removed the entry in Explorer and the entry relating to VLC in the "MIME\Database\Content Type" registry key, rebooted, and things are back to normal.

THANK YOU very much!!!


P.S. If I didn't need VLC to play my mp4's I would have removed it a long time ago. It's installation is very intrusive and I was never given any options to limit all the file extensions it appropriated. Unfortunately, my computer is old and slow, so I get lagging video (audio/video sync problems) in MPC. Oh, well.

Modificato da snowbropatrol il

more options
more options

I'll take a look at those.