X
Tocca qui per la versione per piattaforma mobile del sito.
La versione utilizzata di Firefox è obsoleta e costituisce un rischio per la sicurezza! Aggiornare Firefox

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

The multi-touch pinch/zoom gesture on the MacBook Pro is not working anymore.

Inviato

The multi-touch pinch/zoom gesture on the MacBook Pro is not working anymore.

Does the pinch/zoom multitouch touchpad gesture work with FireFox 4 on the MacBook Pro? It worked with the prior version of FireFox. Will it be added? Or is there something I am just doing wrong or need to change in settings?

Dettagli aggiuntivi sul sistema

Plugin installati

  • Office Live Update v1.0
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 4.0.50826.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • DivX Web Player version 2.1.0.900
  • DivX OVS Helper Plug-in
  • Version 1.9.2.1599
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.2 r152

Applicazione

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Ulteriori informazioni

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
FireFound
2.0.4
true
firefound@efinke.com
DivX Plus Web Player HTML5 <video>
2.1.0.900
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
DivX HiQ
2.1.0.900
false
{6904342A-8307-11DF-A508-4AE2DFD72085}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1301704544
places.history.expiration.transient_current_max_pages
120795
places.last_vacuum
1298258626
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
56
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
4
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x22600,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
3/3 OpenGL
I'm running the latest version of Mac OS X (10.6.7) on a Mid-2010 release 13" MacBook Pro and I just recently installed Firefox 4.0

cor-el
  • Top 10 Contributor
  • Moderator
10740 soluzioni 96657 risposte

Risposta utile

Some gestures have been removed in Firefox 4.

You can restore the zoom feature by changing the values of the related prefs on the about:config page.

browser.gesture.pinch.in -> cmd_fullZoomReduce
browser.gesture.pinch.in.shift -> cmd_fullZoomReset
browser.gesture.pinch.out -> cmd_fullZoomEnlarge
browser.gesture.pinch.out.shift -> cmd_fullZoomReset

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Cyril545 0 soluzioni 1 risposte

I don't want text zoom. I want the entire page zoom like Firefox 3. I want everything bigger. The screen resolution on my MacBook Pro makes everything so small that I need everything larger on some pages. It worked fine before Firefox 4. If you guys wanted to add a feature of text-only zoom then you should have made it an option not the default for Mac users. You can see how many questions that you are getting on this change to the UI. The process of changing the about:config is beyond most "normal" users, and it still doesn't restore the prior functionality.

If this doesn't get fixed even I will switch to another browser for more of my daily use. This is a real pain and I love Firefox, so you can see how important this feature is to MacBook Pro users.

screensavant 0 soluzioni 2 risposte

Is this something we can expect in the next update? I feel uncomfortable typing in a patch. I fear if I get something wrong it will have unintended, uncontrollable, irrevocable, mushrooming aftereffects.

screensavant 0 soluzioni 2 risposte

. . . especially since the warning threatens to void my warranty. . . .

cor-el
  • Top 10 Contributor
  • Moderator
10740 soluzioni 96657 risposte

See also the about:robots page :wink:

webserf 0 soluzioni 13 risposte

Risposta utile

I've provided an image for reference to making the corrections:

I had this problem with my browser as well. I'm using OS X 10.6.8 but, Try this: type the following into the address bar: about:config

Then use the filter (top left side) and type the word, Gesture.

Make the following changes to the following 2 fields:

For Zooming IN: browser.gesture.pinch.in ~ enter the field and type, cmd_fullZoomReduce browser.

And for zooming OUT: gesture.pinch.out ~ enter the field and type, cmd_fullZoomEnlarge

These changes should immediately restore the pinch gestures you are used to. Try it as soon as you make the changes and let us know. I've included a screenshot.

Note the changes in the 2 lines and make them. This worked for me. Good luck.

Modificato da webserf il

cor-el
  • Top 10 Contributor
  • Moderator
10740 soluzioni 96657 risposte

You can reset the pref with the name where you accidentally appended the value to the name instead of in the value. That is the third line in your screenshot (right-click > Reset; Close and Restart Firefox).

ashtango5 0 soluzioni 1 risposte

Error in above post for zooming in contained extra word "browser". Eliminate this to make it work as follows:

For Zooming IN: browser.gesture.pinch.in ~ enter the field and type:

    cmd_fullZoomReduce

And for zooming OUT: gesture.pinch.out ~ enter the field and type:

  cmd_fullZoomEnlarge 

The above worked perfectly, and restorted zoom IN and OUT fine.