X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 4 seems to have a memory leak.

Inserita

I have used Firefox 3.x for some time on a XP machine. Never any problems. It is a machine that I keep running for weeks on end without rebooting. It is a workstation but rather old.

After upgrading to Firefox 4 I get problems with memory. The machine has 2Gb of RAM. I have four tabs open in FF4, about the same as I usually have had in the past. Two of them are now pinned.

When I reboot Firefox it take about 90Mb. But after half a day that is up to 400Mb. I open and close tabs during the day. After another reboot cycle memory usage is again down.

Looks like a memory leak.

I have used Firefox 3.x for some time on a XP machine. Never any problems. It is a machine that I keep running for weeks on end without rebooting. It is a workstation but rather old. After upgrading to Firefox 4 I get problems with memory. The machine has 2Gb of RAM. I have four tabs open in FF4, about the same as I usually have had in the past. Two of them are now pinned. When I reboot Firefox it take about 90Mb. But after half a day that is up to 400Mb. I open and close tabs during the day. After another reboot cycle memory usage is again down. Looks like a memory leak.

Modificato da Noah_SUMO il

Dettagli aggiuntivi sul sistema

Che cosa è successo

Poche volte ogni settimana

È cominciato quando…

I upgraded to Firefox 4

Plugin installati

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Ulteriori informazioni

Rebooting FF fixes it for the moment, but that is only a workaround.

John99 971 soluzioni 13138 risposte

You may note Firefox 4 is no longer supported, you should be using Firefox 5.

You may note Firefox 4 is no longer supported, you should be using Firefox 5.
jajones 0 soluzioni 22 risposte

John... please try to keep up. Read the thread/postings.

John... please try to keep up. Read the thread/postings.
John99 971 soluzioni 13138 risposte

No need to keep up with this thread, just reminding users of firefox 4 that it is not supported as for instance shown on http://www.mozilla.com/en-US/firefox/4.0/whatsnew/

I know some of you are sticking with 3.6 for now. Although the developers are currently working on Firefox 8. And Firefox 7 is on the Aurora channel.

No need to keep up with this thread, just reminding users of firefox 4 that it is not supported as for instance shown on http://www.mozilla.com/en-US/firefox/4.0/whatsnew/ I know some of you are sticking with 3.6 for now. Although the developers are currently working on Firefox 8. And Firefox 7 is on the Aurora channel.
jajones 0 soluzioni 22 risposte

You're missing most of the conversation, and it shows. But then, you didn't think FF4 had a memory leak either. I have to say you're consistent.

You're missing most of the conversation, and it shows. But then, you didn't think FF4 had a memory leak either. I have to say you're consistent.