Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Cannot zoom with touchpad on MacBook Pro in Firefox 4

  • 4 risposte
  • 482 hanno questo problema
  • 8098 visualizzazioni
  • Ultima risposta di john1130

more options

It seems that after installing firefox 4 I cannot use my MacBook Pro touchpad (trackpad) for zooming in or out the page anymore, as I used to do in the previous versions of Firefox.

Many people are used to use their touchpads for zooming, instead of clicking the Cmnd +/-, and its one of the basic touchpad functions that we have on our MacBooks, and many apps are using it.

Soluzione scelta

Please see http://support.mozilla.com/en-US/questions/777886 for the solution to the same problem. Or like jesnft said in the above link, follow these steps-


For Firefox 4.0, several people have provided the solutions. The solution at: http://techmix.net/blog/2011/03/26/pr.../problem-with-pinchzoom-on-firefox-4-mac-osx/ restores Pinch-Zoom capability but with discrete steps. You also need to set browser.gesture.pinch.latched to false as was pointed out by iibpmii

So combining the steps, the complete solution that worked for me is:

   - Open a new Tab and type in “about:config” (without the quote) in the address bar
   - You will be asked to confirm to continue. Just do it.
   - Search for the term “browser.gesture” (without the quote).
   - Edit the browser.gesture.pinch settings as follows: 
   browser.gesture.pinch.in Value = cmd_fullZoomReduce
   browser.gesture.pinch.in.shift Value = cmd_fullZoomReset
   browser.gesture.pinch.latched Value = false
   browser.gesture.pinch.out Value = cmd_fullZoomEnlarge
   browser.gesture.pinch.out.shift Value = cmd_fullZoomReset
Leggere questa risposta nel contesto 👍 35

Tutte le risposte (4)

more options

Soluzione scelta

Please see http://support.mozilla.com/en-US/questions/777886 for the solution to the same problem. Or like jesnft said in the above link, follow these steps-


For Firefox 4.0, several people have provided the solutions. The solution at: http://techmix.net/blog/2011/03/26/pr.../problem-with-pinchzoom-on-firefox-4-mac-osx/ restores Pinch-Zoom capability but with discrete steps. You also need to set browser.gesture.pinch.latched to false as was pointed out by iibpmii

So combining the steps, the complete solution that worked for me is:

   - Open a new Tab and type in “about:config” (without the quote) in the address bar
   - You will be asked to confirm to continue. Just do it.
   - Search for the term “browser.gesture” (without the quote).
   - Edit the browser.gesture.pinch settings as follows: 
   browser.gesture.pinch.in Value = cmd_fullZoomReduce
   browser.gesture.pinch.in.shift Value = cmd_fullZoomReset
   browser.gesture.pinch.latched Value = false
   browser.gesture.pinch.out Value = cmd_fullZoomEnlarge
   browser.gesture.pinch.out.shift Value = cmd_fullZoomReset

Modificato da brinda il

more options

Wow, thanks, it worked!

more options

Awesome! If you could please mark this question as solved, it would be easier for other contributors :)

more options

This answer worked for me too. Thanks Brinda!