X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

when i type into the location bar, firefox no longer 'guesses' the web address and instead takes me straight to bing.

Inviato

Firefox used to 'guess' which website i was looking for when i typed a few keywords into the location bar. EG; when i typed 'bbc sport' firefox would take me straight to www.bbc.co.uk/sport Now however, it takes me straight to bing.com with the search results for my keywords. Ive been to about:config and checked that the 'guess' lookup feature is set as true. Help please!

Firefox used to 'guess' which website i was looking for when i typed a few keywords into the location bar. EG; when i typed 'bbc sport' firefox would take me straight to www.bbc.co.uk/sport Now however, it takes me straight to bing.com with the search results for my keywords. Ive been to about:config and checked that the 'guess' lookup feature is set as true. Help please!

Soluzione scelta

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL double-click on it and change its value to the link shown below

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

That will restore it to the "browse by name" Google search used by Firefox 3.6

Leggere questa risposta nel contesto 45

Dettagli aggiuntivi sul sistema

Che cosa è successo

Ogni volta che avvio Firefox

È cominciato quando...

I started using firefox 4 beta

Plugin installati

  • Google Update
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • DivX Web Player version 2.1.0.900
  • DivX OVS Helper Plug-in
  • OurBabymaker Installer Plugin Stub for 32-bit Windows
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.51204.0
  • NPWLPG
  • My Web Search Plugin Stub for 32-bit Windows
  • OurBabymaker Plugin Stub for 32-bit Windows
  • BlackBerry WebSL Browser Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

Ulteriori informazioni

TonyE
  • Moderator
1034 soluzioni 8840 risposte

Soluzione scelta

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL double-click on it and change its value to the link shown below

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

That will restore it to the "browse by name" Google search used by Firefox 3.6

# Type '''about:config''' into the location bar and press enter # Accept the warning message that appears, you will be taken to a list of preferences # Locate the preference '''keyword.URL''' double-click on it and change its value to the link shown below [http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=] That will restore it to the "browse by name" Google search used by Firefox 3.6

Modificato da TonyE il

Utente che ha posto la domanda

Brilliant thanks.

Brilliant thanks.
TonyE
  • Moderator
1034 soluzioni 8840 risposte

You're welcome

You're welcome
cluelessnut 0 soluzioni 1 risposte

I have the same problem any search's I do leads to a page with bing..com. I followed the instructions above about:config went to keyword.URL copy pasted the the one you posted and it still goes straight to bing.com

clueless

I have the same problem any search's I do leads to a page with bing..com. I followed the instructions above about:config went to keyword.URL copy pasted the the one you posted and it still goes straight to bing.com clueless
cor-el
  • Top 10 Contributor
  • Moderator
12748 soluzioni 117141 risposte

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

Start Firefox in [[Safe Mode]] to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). * Don't make any changes on the Safe mode start window. See: * [[Troubleshooting extensions and themes]] * [[Troubleshooting plugins]]
jackever 0 soluzioni 2 risposte

It got rid of Bing but does not google search. just opens google with blank search box??

It got rid of Bing but does not google search. just opens google with blank search box??
jackever 0 soluzioni 2 risposte

OK !! the issue was that in the posting the last = was not part of the link as a link so if you highlighted it and missed the = it would only go to a google page. With the = it works as before. I want to find a way to blast MS directly for hijacking this!!

OK !! the issue was that in the posting the last = was not part of the link as a link so if you highlighted it and missed the = it would only go to a google page. With the = it works as before. I want to find a way to blast MS directly for hijacking this!!
TonyE
  • Moderator
1034 soluzioni 8840 risposte

I've updated my earlier post to force the forum software to include the = sign at the end of the link.

I've updated my earlier post to force the forum software to include the = sign at the end of the link.
tommystack 0 soluzioni 1 risposte

Risposta utile

Thanks mate I'm so sick and tried of bing replacing google everywhere.

Thanks mate I'm so sick and tried of bing replacing google everywhere.