Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Seeing "?" symbols in a webpage.

  • 4 risposte
  • 60 hanno questo problema
  • 27 visualizzazioni
  • Ultima risposta di cor-el

more options

Seeing "�" symbols all over a webpage. It loads correctly with other browsers like Google Chrome.

"http://tnp.sg/news/" is an example of a website that Firefox tries to load with symbols all over the place (and no content loading).

Many other webpages also appear like this. Sometimes these symbols come up on certain webpages like Facebook but do not affect the page loading.

Seeing "�" symbols all over a webpage. It loads correctly with other browsers like Google Chrome. "http://tnp.sg/news/" is an example of a website that Firefox tries to load with symbols all over the place (and no content loading). Many other webpages also appear like this. Sometimes these symbols come up on certain webpages like Facebook but do not affect the page loading.

Soluzione scelta

If a server doesn't send an encoding then Firefox uses the default encoding as set in "Tools > Options > Content" (Western ISO-8859-1).

A possibility in such cases is to switch to "View > Character Encoding > Auto-Detect > Universal" to see if that makes Firefox switch to the correct encoding.

Leggere questa risposta nel contesto 👍 3

Tutte le risposte (4)

more options

Soluzione scelta

If a server doesn't send an encoding then Firefox uses the default encoding as set in "Tools > Options > Content" (Western ISO-8859-1).

A possibility in such cases is to switch to "View > Character Encoding > Auto-Detect > Universal" to see if that makes Firefox switch to the correct encoding.

more options

Thank you so much cor-el for your swift reply! It works fine now.

more options

I can use "View > Character Encoding > Western (ISO-8859-1)", but only the current open page is affected. Under the "Tools" menu, there doesn't seem to be an item for "Options". Is there some way to keep Western (ISO-8859-1) as the default character encoding? That seems to be the most useful.

more options

You set the default encoding via Tools > Options > Content : Fonts & Colors: Advanced > Default Character Encoding

See also Content Preferences: https://addons.mozilla.org/firefox/addon/4066