X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Where can I find the last complete Mozilla Suite (with e-mail client) for win98/ME?

Inserita

It's pretty frustrating searching for this, because I inevitably land on the relevant Mozilla page, or other sites linking to it, only to find the Download link leads to nowhere!

Can't the last version be made available, (naturally without support)?

I cannot be the only person that doesn't want to discard a perfectly functional PC.

Anyway: Rant over.

I want to emphasize I am looking for the complete suite. I already have the last Mozilla browser, but without a mail client. I have an old Thunderbird, but it has silly bugs.

Thanks!

It's pretty frustrating searching for this, because I inevitably land on the relevant Mozilla page, or other sites linking to it, only to find the Download link leads to nowhere! Can't the last version be made available, (naturally without support)? I cannot be the only person that doesn't want to discard a perfectly functional PC. Anyway: Rant over. I want to emphasize I am looking for the complete suite. I already have the last Mozilla browser, but without a mail client. I have an old Thunderbird, but it has silly bugs. Thanks!

Dettagli aggiuntivi sul sistema

Plugin installati

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Shockwave Flash 10.0 r45
  • 3.0.40818.0

Applicazione

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Ulteriori informazioni

Morbus 135 soluzioni 2340 risposte

Risposta utile

I will have you know that versions prior to Firefox 3.5 have been discontinued and are no longer supported by Mozilla. On top of that, they have known unpatched bugs and security problems. Use previous bellow 3.5 with caution and please make sure you are aware of these problems.

It is true, however, that new versions of Firefox (anything above Firefox 2.0, in fact) do not work with older versions of Windows (Windows Me included). However, I will remind you that Windows Me (in fact, any version of Windows prior to Windows XP) is no longer supported by Microsoft, and, like older versions of Firefox, has known unaddressed problems and security issues.

As such, I urge you to update your operating system. Windows XP is still widely used, will be supported until 2014, is relatively cheap and should run ok on your computer (please check its system requirements first). Older computers are normally not capable of running Windows Vista and above. If upgrading to a new version of Windows is not possible or you simply don't want to, there are many different distributions of Linux that will easily work in your computer, and easily surpass Windows Me in terms of ease of use and software compatibility (if you use Wine - a software compatiblity layer to use Windows applications). Getting and installing a Linux distribution is completely free (just like Firefox) and very easy too. I personally recommend Ubuntu, but you may want to try Xubuntu, a lightweight version of the former. See here for a complete list of all Linux distributions. If you need help getting started in the world of Linux, you can use the official support forums and take advantage of Linux's fantastic community.

Ok... Now that I've got the part where I tell you that your OS is not supported and you should update out of the way, I also have to tell you that Firefox 3.5 and above, despite being supported in newer versions of Windows and other operating systems (including, of course, Linux), are not supported in Windows Me, and is not supposed to work under it (since it was not developed with it in mind). If there is a way to make it work somehow, it will not be supported and we probably won't be able to help you in fixing any problems you might have. You can search the web for ways to installed Firefox 3.0/3.5/3.6 in Windows Me, but it probably won't be in Firefox's support forums.

You can, however, install, without any predictable issue, Firefox 2.0 and bellow, which is the last Firefox release for Windows Me. To get it, you will need to access Mozilla's FTP servers. Here's a link for the 2.0 (the latest version available) release directory:

ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.20/win32/

However, and again, I will remind you that version 2.0 of Firefox (and those before too) has been discontinued and is no longer supported. It has known unpatched bugs and security problems, and, again, I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at getfirefox.com.

So, no, it's not "a perfectly functional PC" if it has outdate software. It's a huge, huge security trap.

If you want the Mozilla suite, see this page.

For future reference, for whenever you are searching anything at all, I recommend you use Wikipedia. It's a fantastic website with many articles, and it's great for finding information about all sorts of software. I myself didn't know the link for the Mozilla suite, and what I did was quickly search Mozilla suite on the Wikipedia search on the search bar of Firefox, go to the bottom of the page, section External links and click the relevant link. It's really a fantastic website for these and many things, if you actually use it.

I hope this helps.

I will have you know that versions prior to Firefox 3.5 have been discontinued and are no longer supported by Mozilla. On top of that, they have known unpatched bugs and security problems. Use previous bellow 3.5 with caution and please make sure you are aware of these problems. It is true, however, that new versions of Firefox (anything above Firefox 2.0, in fact) do not work with older versions of Windows (Windows Me included). However, I will remind you that Windows Me (in fact, any version of Windows prior to Windows XP) is no longer supported by Microsoft, and, like older versions of Firefox, has known unaddressed problems and security issues. As such, I urge you to update your operating system. Windows XP is still widely used, will be supported until 2014, is relatively cheap and should run ok on your computer (please check its [http://support.microsoft.com/kb/314865 system requirements] first). Older computers are normally not capable of running Windows Vista and above. If upgrading to a new version of Windows is not possible or you simply don't want to, there are many different distributions of Linux that will easily work in your computer, and easily surpass Windows Me in terms of ease of use and software compatibility (if you use [http://www.winehq.org/ Wine] - a software compatiblity layer to use Windows applications). Getting and installing a Linux distribution is completely free (just like Firefox) and very easy too. I personally recommend [http://www.ubuntu.com/ Ubuntu], but you may want to try [http://www.xubuntu.org/ Xubuntu], a lightweight version of the former. See [http://en.wikipedia.org/wiki/List_of_Linux_distributions here] for a complete list of all Linux distributions. If you need help getting started in the world of Linux, you can use the official support forums and take advantage of Linux's fantastic community. Ok... Now that I've got the part where I tell you that your OS is not supported and you should update out of the way, I also have to tell you that Firefox 3.5 and above, despite being supported in newer versions of Windows and other operating systems (including, of course, Linux), are not supported in Windows Me, and is not supposed to work under it (since it was not developed with it in mind). If there is a way to make it work somehow, it will not be supported and we probably won't be able to help you in fixing any problems you might have. You can search the web for ways to installed Firefox 3.0/3.5/3.6 in Windows Me, but it probably won't be in Firefox's support forums. You can, however, install, without any predictable issue, Firefox 2.0 and bellow, which is the last Firefox release for Windows Me. To get it, you will need to access Mozilla's FTP servers. Here's a link for the 2.0 (the latest version available) release directory: ftp://ftp.mozilla.org/pub/firefox/releases/2.0.0.20/win32/ However, and again, I will remind you that version 2.0 of Firefox (and those before too) has been discontinued and is no longer supported. It has known unpatched bugs and security problems, and, again, I urge you to update to the latest version of Firefox, for maximum security, stability, performance and usability. You can get it for free, as always, at [http://www.getfirefox.com getfirefox.com]. So, no, it's not "a perfectly functional PC" if it has outdate software. It's a huge, ''huge'' security trap. If you want the Mozilla suite, see [http://www.mozilla.org/projects/browsers.html this page]. For future reference, for whenever you are searching anything ''at all'', I recommend you use [http://en.wikipedia.org/ Wikipedia]. It's a fantastic website with many articles, and it's great for finding information about all sorts of software. I myself didn't know the link for the Mozilla suite, and what I did was quickly search ''Mozilla suite'' on the Wikipedia search on the search bar of Firefox, go to the bottom of the page, section ''External links'' and click the relevant link. It's really a fantastic website for these and many things, if you actually use it. I hope this helps.
cor-el
  • Top 10 Contributor
  • Moderator
17521 soluzioni 158427 risposte
You can also look at SeaMonkey. http://www.seamonkey-project.org/releases/seamonkey1.1.19

Utente che ha posto la domanda

"I hope this helps. "

Not really.

I use the internet for e-mail and to look up the train time tables. That's about it.

I have a dial-up and it works reliably. Hi-speed expensive and in my country they force you to also pay for television license, even if you don't have a television.

Unfortunately your ftp-link only contains the firefox browser. I already have that. I need the full Mozilla Suite with e-mail.

Your link to Mozilla (this page) goes to the latest version (3.6), not the last WinME version. Links in Wikipedia all go to Mozilla.org and there are no old versions there.

I am not looking for support, I know there is no support.

I just want the last Mozilla Suite for WinME/98SE

"I hope this helps. " Not really. I use the internet for e-mail and to look up the train time tables. That's about it. I have a dial-up and it works reliably. Hi-speed expensive and in my country they force you to also pay for television license, even if you don't have a television. Unfortunately your ftp-link only contains the firefox browser. I already have that. I need the full Mozilla Suite with e-mail. Your link to Mozilla (this page) goes to the latest version (3.6), not the last WinME version. Links in Wikipedia all go to Mozilla.org and there are no old versions there. I am not looking for support, I know there is no support. I just want the last Mozilla Suite for WinME/98SE
AliceWyman
  • Moderator
240 soluzioni 2597 risposte

Risposta utile

You want SeaMonkey 1.1.19, which is an updated version of the old Mozilla Suite. Ref: http://kb.mozillazine.org/Mozilla_Suite

Download link is here for SeaMonkey 1.1.19: http://www.seamonkey-project.org/releases/1.1.19

You want SeaMonkey 1.1.19, which is an updated version of the old Mozilla Suite. Ref: http://kb.mozillazine.org/Mozilla_Suite Download link is here for SeaMonkey 1.1.19: http://www.seamonkey-project.org/releases/1.1.19

Modificato da AliceWyman il

Utente che ha posto la domanda

Ah, I see. Thought seamonkey is a different product. Thank you very much for your help! Downloaded now. Will install tonight.

Ah, I see. Thought seamonkey is a different product. Thank you very much for your help! Downloaded now. Will install tonight.