Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Google displays in foreign language while traveling but home page set in English.

  • 2 risposte
  • 36 hanno questo problema
  • 32 visualizzazioni
  • Ultima risposta di DaveRo

more options

I am traveling in Germany and using someone's wireless router. My home page is set as Google.com but is coming up as .de and is in German. Even if I put the correct address in the navigation bar it still comes up as the German version of google. How can I make it stay as the home page I set it for which is google.com in English?

Tutte le risposte (2)

more options

This might work http://www.google.com/ncr

more options