Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Firefox won't load pages while other browsers do

  • 17 risposte
  • 1 ha questo problema
  • 44 visualizzazioni
  • Ultima risposta di FredMcD

more options

I keep having problems with Firefox not loading certain pages despite that Microsoft Edge works fine. I've cleared my cache and cookies, tried disabling my firewall, and also tried Safe/troubleshooting mode and the problem was still there. Facebook Messenger and Google Hangouts are two of the ones that regularly don't work (and sometimes Submittable, Outlook, and Google Docs), but sometimes I can just refresh the page half a dozen times and then it works. I moved and switched internets two weeks ago and it may have started then (or a few days after). I also tried turning off the proxy and disabling Ipv6.

My comp: Windows 10, 64-bit, HP laptop, new in December 2019. Processor: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx.

Tutte le risposte (17)

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

È stato utile?

more options

I don't get actual error messages. Most of the time the issue is that Firefox will only load part of the page, like the header for Facebook but not the rest, or the writing on a page but not a link or button. I've attached how it does this for hangouts: the rest of the page loads but not the actual message bubble (I just get a blank square instead of all the messages there). Sometimes I also get a fully blank page (and just it stops loading as if it's done). When I load the same pages using Microsoft Edge there's no issue.

È stato utile?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

È stato utile?

more options

As I mentioned, I already tried Troubleshooting mode (so it's not one of my extensions), I already cleared my cache and cookies, and this is happening on pages where Firefox's shield icon isn't on. When I refresh the individual page by bypassing the cache, the problem is still there.

This leaves your suggestions about the Web Console and Network Monitor, which I don't know how to read, but they look fine...? I've attached a pic of the Console on a page that didn't load and the Monitor on another one.

È stato utile?

more options

You are using two different ad blockers. This can cause issues.

Turn off both. What happens?

Then turn on one. Test.

Then turn that off and turn on the other. Test.

È stato utile?

more options

That doesn't work either. Any other ideas?

È stato utile?

more options

È stato utile?

more options

I tried doing this both by clicking Safe Mode with networking in the msconfig boot menu and by doing shift-restart and choosing safe mode with network, and both times it wouldn't allow me to access the internet. Not sure why that is?

Is it possible that Firefox just takes up more speed/space than Microsoft Edge, and my internet is too slow for Firefox? My last internet was slightly faster, when I wasn't having issues with Firefox.

È stato utile?

more options

È stato utile?

more options

This did improve the situation -- I opened a browser with the new default profile and one with my old one and opened the same page in each and the new profile one could open it but the other couldn't. I'll have to test this a few more times to see if this actually solved the issue. If it did solve the problem though, does that mean I just need to build a new profile from scratch? (Paying attention to whether any new change causes the problem again?)

È stato utile?

more options

Once you decide that the new profile is working, we can tell you how to copy your data from the old one.

È stato utile?

more options

There are a couple sites that regularly don't work and a handful that sometimes don't work (can sometimes be fixed by refreshing a few times). One of the two that wouldn't work has for sure been fixed by having a new profile -- every time it hasn't worked, opening the page in a different browser on the other profile has worked. However, the other one for sure hasn't been fixed by having a new profile, so it seems to be a multifaceted problem...

È stato utile?

more options

È stato utile?

more options

When I open the same pages in Microsoft Edge they work -- doesn't that mean it's not my security software?

(I have Malwarebytes, Panda Dome, and ZoneAlarm Firewall.)

I'll keep reading through these pages to see if there's another solution I missed...

È stato utile?

more options

Firefox is a more secure browser.

È stato utile?

more options

You mean, so it's too secure to properly open some (not suspicious) websites? Or how does that relate to my antivirus etc software?

È stato utile?

more options

Anti-virus, and ad blockers, will stop anything they don't like.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.