Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

How do I stop the "Please complete the security check...hCaptcha...proves you are a human" check boxes from appearing each time I try to open a link in my browser?

  • 7 risposte
  • 1 ha questo problema
  • 19 visualizzazioni
  • Ultima risposta di jscher2000

more options

How do I stop the "Please complete the security check...hCaptcha...proves you are a human" check boxes from appearing each time I try to open a link in my browser? Thank you

Immagini allegate

Soluzione scelta

Does this happen if you test in a clean profile? If so, your IP address could be on a list of suspicious addresses or an intermediary (proxy server, security software filter, other "man in the middle") might be modifying some connection parameters. If not, then you might have changed a setting which makes the site suspicious of whether you are a human or a bot. Here is how to set up the test:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like May2021, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to May2021 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (May2021 will remain available for future testing.)

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (7)

more options

Soluzione scelta

Does this happen if you test in a clean profile? If so, your IP address could be on a list of suspicious addresses or an intermediary (proxy server, security software filter, other "man in the middle") might be modifying some connection parameters. If not, then you might have changed a setting which makes the site suspicious of whether you are a human or a bot. Here is how to set up the test:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like May2021, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to May2021 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (May2021 will remain available for future testing.)

È stato utile?

more options

In retrospect, I believe I just used the newly created profile as a "work-around" to a different underlying issue. Since implementing the solution provided above initially, I have created two more profiles. The first lasted roughly ten days before the attached "Attention Required! | Cloudflare" Captcha verification began again. The second lasted one day.

When jscher2000 stated,

"If so, your IP address could be on a list of suspicious addresses or an intermediary (proxy server, security software filter, other "man in the middle") might be modifying some connection parameters."

what does that mean?

I tried abandoning Firefox to resume work in Chrome and the attached "Attention Required! | Cloudflare" Captcha verification began appearing there also.

Can Support Moz://a help?

È stato utile?

more options

I notice the first line says to enable cookies, so it's worth checking that cookies are not too restricted by settings or add-ons. This article is the usual first stop for that: Websites say cookies are blocked - Unblock them. Google probably has a similar article for Chrome.

But perhaps that is not changing on its own over time. What is changing? Hmm... Could you test in Firefox's Safe/Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

È stato utile?

more options

no sir. No improvement.

Just to be clear, what we're trying to do is to prevent the attached

"One more step Please complete the security check to access...(CAPTCHA)"

from ever appearing again.

it seems like it should be an easy fix. Is that not the case?

È stato utile?

more options

If we knew what causes your requests to get diverted to Cloudflare CAPTCHA, maybe there would be an obvious solution. ;-)

According to the following article, the three scenarios for the CAPTCHA are:

  1. The visitor’s IP address demonstrated previous suspicious activity online. Review your client IP address for malicious activity at Project Honeypot. If no suspicious activity is observed from the visitor’s IP address after a two-week period, Cloudflare stops challenging the IP address.
  2. The website owner blocked the country associated with the visitor’s client IP.
  3. The visitor’s actions activated a Web Application Firewall rule enabled by the website owner.
Source: https://support.cloudflare.com/hc/en-us/articles/200170136-Understanding-Cloudflare-Challenge-Passage-Captcha-

I don't think it's #1 or #2 because a new profile would use the same network connection as the old one. Unless there is a setting in your Firefox that changes your network connection? You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Modificato da jscher2000 il

È stato utile?

more options

That is not a solution.

See, above, where I said,

"Just to be clear, what we're trying to do is to prevent the attached

"One more step Please complete the security check to access...(CAPTCHA)"

from ever appearing again.

it seems like it should be an easy fix. Is that not the case?"

Look at the settings in the attached, "Firefox settings showing cloudflare.JPG" where it says, Enable DNS over HTTPS...Cloudflare (default)

We want Cloudflare to have no association with the users web browsing. Changing the settings makes no difference. "No proxy" or otherwise.

Why is Cloudflare being given access to the users web browsing? No good can come from it and it appears to be something Firefox has as an "out of the box" add on.

I even uninstalled and reinstalled Firefox. Since when is web browsing such an ordeal?

Again, what we're trying to achieve is web browsing without having to go through a wholly unnecessary process of clicking on pictures. Why is this process even a part of the web browsing experience with Firefox?

È stato utile?

more options

DNS lookups are done before Firefox requests the page, so as far as I know, those should have nothing to do with this problem. But definitely turn off DNS over HTTPS to test whether it makes any difference. If it does, great, you're done. But I suspect not.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.