Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Google "before you continue" won't go away when I click 'I agree'.

  • 6 risposte
  • 1 ha questo problema
  • Ultima risposta di BC

more options

Like many users, I find Google's 'before you continue' pop-up annoying. Because I automatically delete cookies on browser exit, it keeps popping up as it doesn't remember my settings. I have installed Google Consent Dialog Remover, and it has been working well... until now.

I just did a search for a place, and tried to click on the map to go to Google Maps. The dialog intruded, despite the add-on. But worse than that, when I clicked 'I agree', nothing happened! I cannot get to the maps page at all. I've tried disabling enhanced protection -- no change. I've tried disabling various add-ons -- no change. I've tried restarting FF in safe mode, but the same problem persists.

I can't figure out how this is happening or what to do about it. Any suggestions?

Thank you!

Soluzione scelta

Thank you for the suggestion. It prompted me to do some investigation which seems to have solved the problem.

I had already tried turning off Enhanced Tracking Protection for google.com and it didn't work. However, on further investigation I found that google.com had been entirely blocked from setting cookies, while the add-on Cookie AutoDelete was set up to whitelist cookies from myaccount.google.com (i.e. to remember cookies rather than autodelete them on browser close). So I think the browser had saved some old cookies and was unable to set any new ones. I don't remember setting it up like this deliberately but can imagine that I may have done (see below).

I have now removed the block on google.com setting cookies and have removed google.com from the AutoDelete whitelist, so cookies are now set and then cleared when I close the tab. This seems to work. It still works with Enhanced Tracking Protection on and set to Custom.

The only thing I'm not completely happy about is that Cookie AutoDelete doesn't delete Google cookies if there are any Google tabs open. So I can do a search in one tab without signing in, then sign into Gmail in a second tab, close the second tab and find that I'm still signed in until the original search tab is closed. I guess this may be why I disabled Google from setting cookies in the first place.

Thanks to TerryN21 and jscher2000 for your help.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (6)

more options

I am not familiar with that 'pop-up'. I can load Google Maps with Enhanced Tracking Protection on. When you say "the same problem persists", do you mean the pop-up or the failure to load Google Maps? On the Privacy & Security page of Options there is a setting "Block pop-up windows".

È stato utile?

more options

Sorry, it's not strictly a pop-up. It's a page to which Google redirects in order to get cookie consent (see screenshot). If you click 'Customise' or 'I agree' when you're signed in, then it remembers your choice. But I want to be able to browse without signing in. In the past, the add-on 'Google Consent Dialog Remover' stopped this from appearing. And without the add-on, the dialog would appear but I could simply click 'I agree' and it would go away.

Now, the dialog appears even with the add-on enabled, and whatever I do, the dialog remains. If I click 'I agree', nothing happens. If I click 'Customise' it takes me to a page to customise my choices, and when I try to exit that page I'm right back at the dialog. There's no way of getting out of the loop and into Google Maps (with the possible exception of signing in to Google -- which is what I'm trying to avoid).

È stato utile?

more options

I don't get that using a private window in California, so perhaps it is targeted toward users based in Europe. If I can remember how my old VPN software works, perhaps I can test that theory...

Either way, if clicking I agree does not set a new cookie, then perhaps you are blocking new cookies from being set and not just removing them at shutdown. Do you use Strict or Custom tracking protection settings?

È stato utile?

more options

Soluzione scelta

Thank you for the suggestion. It prompted me to do some investigation which seems to have solved the problem.

I had already tried turning off Enhanced Tracking Protection for google.com and it didn't work. However, on further investigation I found that google.com had been entirely blocked from setting cookies, while the add-on Cookie AutoDelete was set up to whitelist cookies from myaccount.google.com (i.e. to remember cookies rather than autodelete them on browser close). So I think the browser had saved some old cookies and was unable to set any new ones. I don't remember setting it up like this deliberately but can imagine that I may have done (see below).

I have now removed the block on google.com setting cookies and have removed google.com from the AutoDelete whitelist, so cookies are now set and then cleared when I close the tab. This seems to work. It still works with Enhanced Tracking Protection on and set to Custom.

The only thing I'm not completely happy about is that Cookie AutoDelete doesn't delete Google cookies if there are any Google tabs open. So I can do a search in one tab without signing in, then sign into Gmail in a second tab, close the second tab and find that I'm still signed in until the original search tab is closed. I guess this may be why I disabled Google from setting cookies in the first place.

Thanks to TerryN21 and jscher2000 for your help.

È stato utile?

more options

There are some options for isolating your Gmail tab from your other tabs.

(1) Regular vs. Private windows

Cookies do not cross over between these two separate contexts.

(2) Container tabs

You can create a permanent or temporary "container" (separate context) and open Gmail in there (this only works in regular windows). I don't use this technology myself, so I'm not sure of the best way to approach it.

È stato utile?

more options

Thank you. Yes, I was planning on using container tabs -- I do have this set up and it works well for me. I haven't thought about using private windows but that's another good option.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.