Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Firefox doesn't remove history when it is closed, and unable to manually clear history.

more options

Hello,

Using Firefox 87.02 on arch linux 64 bit. As mentioned in the subject. Firefox is set to clear history when it closes but it doesn't. Neither am a able to clear the history manually from the preferences menu or otherwise. Do you know any sollution?

Kind regards.

Tutte le risposte (4)

more options

This can happen if you run Firefox in Private Browsing mode. You will have to run Firefox in regular mode if you want to use "Clear Recent History" or "Clear history when Firefox closes".

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Modificato da cor-el il

È stato utile?

more options

1991a265489b said

Hello, Using Firefox 87.02 on arch linux 64 bit. As mentioned in the subject. Firefox is set to clear history when it closes but it doesn't. Neither am a able to clear the history manually from the preferences menu or otherwise. Do you know any sollution? Kind regards.

cor-el said

This can happen if you run Firefox in Private Browsing mode. You will have to run Firefox in regular mode if you want to use "Clear Recent History" or "Clear history when Firefox closes". Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).
  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Hello,

Thank you for your answer, but firefox doesn't run in permanent private browsing mode. All that is checked under "Preferences" "Privacy & Security" "History" "Use custom settings for history" is "Clear history when Firefox closes".

Kind regards.

È stato utile?

more options

Are there messages reported if you start Firefox via a terminal window?

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

È stato utile?

more options

cor-el said

Are there messages reported if you start Firefox via a terminal window? You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Hello cor-el,

There were no messages reported starting Firefox from my terminal. So I removed the .mozilla folder from my home directory in order to see if a new profile would work. It did correctly, history was being removed. Then I put back the original places.sqlite to get my bookmarks back and that database appeared to be bad because my old history was back as wel. Exported bookmarks to html and imported them to the new profile. Now all seems well. Thank you for the assist!

Kind regards.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.