Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Screwed keyup events with alt modifiers

  • 11 risposte
  • 1 ha questo problema
  • 11 visualizzazioni
  • Ultima risposta di cor-el

more options

Hi,

I think I broke the ALT keyup events in some way, probably with my configuration but not sure how.

If I put this code in the console : `document.addEventListener("keyup", e=>console.log('alt: '+e.altKey+' | '+String.fromCharCode(e.which).toLowerCase()));` and the press the keys, I have the following results:

- pressing "I", I get the expected "alt: false | i" - pressing "ALT+I", I get "alt: true | �"

I do not have the problem with other modifier keys like CTRL

Immagini allegate

Soluzione scelta

Does it make a difference which Alt key you use (left or right)?

This may also be a problem with your keyboard layout that uses the Alt key as a modifier at the OS level, so Firefox gets a different character.

I notice that with "Resist Fingerprinting" enabled I get always e.altKey = false

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (11)

more options

OS X 10.15.7, FF 86.0.1

È stato utile?

more options

It's not a Firefox issue.

È stato utile?

more options

How to be sure it's not a Firefox issue? I agree it's probably due to my instance (extensions or configuration messing something up), but if it's not a Firefox issue, how come can't I reproduce it on the other navigators installed on my system? How do I tackle it?

È stato utile?

more options

For the record, I already tried disabling all extensions, and it didn't solve anything.

È stato utile?

more options

Simon said

How to be sure it's not a Firefox issue?

I can reproduce it on Edge/Chromium on Windows.

È stato utile?

more options

Well according to the docs `which` `code` and `keyCode` value should not depend on the modifier key, hence my confusion. I'm surprised the you can reproduce, this should not be the normal behavior.

I filed a bug although I'm pretty sure it comes from my config as my colleague is not having the problemn with the same FF version and OS.

È stato utile?

more options

OK, thanks for filing a bug. Let's see what devs say.

È stato utile?

more options

Soluzione scelta

Does it make a difference which Alt key you use (left or right)?

This may also be a problem with your keyboard layout that uses the Alt key as a modifier at the OS level, so Firefox gets a different character.

I notice that with "Resist Fingerprinting" enabled I get always e.altKey = false

È stato utile?

more options

Oh my god thank you it's been a challenging two weeks ^^

I know I had changed some privacy params but couldn't find the right one....

So I do get altKey=true, but the wrong code / keyCode etc. Gonna notify the devs thank you again

È stato utile?

more options

(Just to clarify, it was indeed the "Resist Fingerprinting" param)

È stato utile?

more options

You're welcome

I tested that because of your Firefox 78 user agent, that could be an indication of using "Resist Fingerprinting".

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.