Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

New Tab Behavior after latest update

  • 6 risposte
  • 1 ha questo problema
  • 29 visualizzazioni
  • Ultima risposta di monline

more options

In Options, the following selection item is included under General>>>Tabs:

"When you open a link in a new tab, switch to it immediately"

Although it has worked well in the past, selection of that option no longer seems to have an effect on new tab behavior. New tabs are thrust into the foreground regardless of whether or not the option is selected in Options.

Is this a flaw in the latest update to Firefox? Will it be corrected soon?

Soluzione scelta

(I previewed your reply, but a moderator needs to approve it because it has a link to a non-Mozilla site.)

So a thing that broke in Firefox 85 was previewing WordPress post edits. When you first click Preview, a script launches a tab and Firefox makes it active. Then you switch back to the editor, make changes, Preview again, but this time although the tab updates, when the script in the editor page tries to switch focus, the Preview tab stays in the background. That bug was fixed in Firefox 85.

Now it seems maybe that fix caused a bug for you? (Although that problem was exclusive to Firefox 85, so if this changes a longstanding behavior of the site, there may be something else going on...)

Either way, have you tried setting the browser.tabs.loadDivertedInBackground preference to true? That seems to work on my test page for the other issue to keep the second tab in the background:

https://www.jeffersonscher.com/res/focusnamedtab.html

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (6)

more options

I hate to sound like a cliché, but have you tried turning it off and on again? ;-)

Let's have a look through the back door:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered. Firefox should list a bunch of preferences targeting different specific scenarios. In backwards order:

  • Ignore the services.sync.prefs.sync.browser.tabs.loadInBackground preference, this just tells Firefox whether to include the next preference when it Syncs preference.
  • browser.tabs.loadInBackground is set to true by default and is the one that has the checkbox on the Options page. This covers the case where you specifically direct a link to a new tab, for example, from the right-click context menu, or by Ctrl+clicking or middle-clicking a link. I suggest double-clicking it to false, and then double-clicking it back to true, just to make sure you and Firefox are on the same page.
  • browser.tabs.loadDivertedInBackground is set to false by default. This covers the case where the link is coded to open in a new window and Firefox diverts it to a new tab instead -- Firefox switches to those immediately. If you are having problems with this kind of link, double-click the preference to switch the value from false to true.
  • browser.tabs.loadBookmarksInBackground is set to false by default. Not your issue, but something to consider experimenting with for the future.
  • browser.search.context.loadInBackground is set to false by default. This is for those searches you run by selecting text in a page, right-clicking, and using the item "Search Google for [text]" (or if your default search engine is not Google, your default search engine will be mentioned there instead). Not your issue, but something to consider experimenting with for the future.

Does that help at all?

È stato utile?

more options

jscher2000 thanks for the instructive message, including the valuable points for future reference. Unfortunately, the problem persists.

browser.tabs.loadInBackground was actually reading "false" in my case, not the default "true" setting described in your message. But even after I changed it to "true" the tabs continue to open in the foreground. This after switching the value several times, and noting that every change I made inback immediately took effect in the Options page tab setting. The fix just isn't changing the browser's actual behavior.

I did also close and reopen the browser, and I powered down and restarted the computer.

È stato utile?

more options

Is the problem when you use one of these methods:

  • right-click the link > Open Link in New Tab
  • Ctrl+click the link
  • middle-click the link using the mouse scroll wheel

Or is the problem in some other situation?

Do you use any tab-related add-ons?

È stato utile?

more options

None of the above. And I think that must explain it. I'm working with a web resource that doesn't use normal URL linkage. Left-clicking the terms in the visual linked below will open a new tab. The tab ought to refresh in the background on subsequent clicks, and it did a few days ago with Firefox. But it now moves into the foreground regardless of the settings in Options, and this resource is not currently responsive to the methods you've listed:

https://voyant.melvillesmarginalia.org/?corpus=047e991aa06ad7a4ad80834b0d980bed&visible=85&input=http://melvillesmarginaliadev.com//vt.aspx?type=doc&id=105&stage=false&inputFormat=json&view=Cirrus

È stato utile?

more options

Soluzione scelta

(I previewed your reply, but a moderator needs to approve it because it has a link to a non-Mozilla site.)

So a thing that broke in Firefox 85 was previewing WordPress post edits. When you first click Preview, a script launches a tab and Firefox makes it active. Then you switch back to the editor, make changes, Preview again, but this time although the tab updates, when the script in the editor page tries to switch focus, the Preview tab stays in the background. That bug was fixed in Firefox 85.

Now it seems maybe that fix caused a bug for you? (Although that problem was exclusive to Firefox 85, so if this changes a longstanding behavior of the site, there may be something else going on...)

Either way, have you tried setting the browser.tabs.loadDivertedInBackground preference to true? That seems to work on my test page for the other issue to keep the second tab in the background:

https://www.jeffersonscher.com/res/focusnamedtab.html

È stato utile?

more options

OK confirmed! Setting browser.tabs.loadDivertedInBackground to "true" does keep the new tab in the background when it reloads. Thanks very much for the explanation and the solution!

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.