Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

automacticlly switches to a new link opened in a new tab even with that option turned off in the settings

  • 5 risposte
  • 1 ha questo problema
  • 3 visualizzazioni
  • Ultima risposta di maddthom

more options

I updated Firefox, now it switches to a new link opened in a tab automatically, I have that setting turned off, I like to open multiple tabs from my bookmarks at once, so I do not want to switch to that tab until I am ready. So how do I uninstall this update or force firefox to stop switching tabs

Soluzione scelta

I overlooked your mention of bookmarks. You probably already spotted that browser.tabs.loadBookmarksInBackground preference.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (5)

more options

Hi, you want all tabs to open in the background? From what you say I assume you've already deselected 'When you open a link in a new tab, switch to it immediately' in Options - (General) > Tabs.

So try this: Type about:config into the address bar, press Enter and accept any warning, then copy and paste the following into the search box browser.tabs.loadInBackground Now on the search result - and assuming it isn't already set to True, click the Toggle button at the right-hand end to change from False to True. You may need to restart Firefox to implement the change.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

È stato utile?

more options

both setting are set to true, but thanks for trying

È stato utile?

more options

Is the problem when you use one of these methods:

  • right-click the link > Open Link in New Tab
  • Ctrl+click the link
  • middle-click the link using the mouse scroll wheel

That is what the above browser.tabs.loadInBackground preference covers.

If the problem is with simply left-clicking links:

Do you use any tab-related add-ons that might have updated recently?

Here is another possibly relevant preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste inback and pause while the list is filtered. Firefox should list a bunch of preferences targeting different specific scenarios.

(3) browser.tabs.loadDivertedInBackground is set to false by default. This covers the case where the link is coded to open in a new window and Firefox diverts it to a new tab instead -- Firefox switches to those immediately. If you are having problems with this kind of link, double-click the preference to switch the value from false to true.

Are we getting closer?

È stato utile?

more options

Soluzione scelta

I overlooked your mention of bookmarks. You probably already spotted that browser.tabs.loadBookmarksInBackground preference.

È stato utile?

more options

That was the answer I was hoping for, thank you, browser.tabs.loadBookmarksInBackground solved it, can't thank you enough.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.