Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Facebook videos "Sorry, we're having trouble with playing this video."

  • 7 risposte
  • 1 ha questo problema
  • 1641 visualizzazioni
  • Ultima risposta di jscher2000

more options

Hi

For two days I've been searching on the web and in here with no luck.

Initially as Facebook is loading ... I can see the video for a brief second, then its turns grey with the message "Sorry, we're having trouble with playing this video."

Appears to only be a problem on Facebook and only in FF (chrome facebook videos work fine)

Using

FF 81.0 (64-Bit) Windows 10 Version 2004

Tried with all addon's disabled. Tried with anti virus disabled

Tried adding "Flash Video Player for Facebook" addon

Videos all work and play in chrome.

Soluzione scelta

Could you check this group of settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste mediasource and pause while the list is filtered

(3) If the media.mediasource.enabled preference is bolded and has a value of false, double-click it to restore the default value of true

(4) Also check:

  • media.mediasource.mp4.enabled (used widely)
  • media.mediasource.vp9.enabled (probably only YouTube)
  • media.mediasource.webm.enabled (used on YouTube, probably some other sites)

Was anything there turned off and does turning it back on help?

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (7)

more options

Could you check the following test page, it is my re-post of the old YouTube HTML5 video support test page:

https://www.jeffersonscher.com/sumo/html5-video.html

If there are items that do not say "supported" or "probably", which ones are they?

more options

Hi Jeff

This is what I saw.

Legacy YouTube HTML5 Video Tests

HTMLVideoElement supported MP4/H.264(avc1.42001E, mp4a.40.2) probably WebM VP8 (vp8.0, vorbis) probably

Media Source Extensions Support:

Media Source Extensions not supported MSE & H.264 (video/mp4; codecs="avc1.4d401e") -- MSE & WebM VP9 ((video/webm; codecs="vp9") --

more options

Soluzione scelta

Could you check this group of settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste mediasource and pause while the list is filtered

(3) If the media.mediasource.enabled preference is bolded and has a value of false, double-click it to restore the default value of true

(4) Also check:

  • media.mediasource.mp4.enabled (used widely)
  • media.mediasource.vp9.enabled (probably only YouTube)
  • media.mediasource.webm.enabled (used on YouTube, probably some other sites)

Was anything there turned off and does turning it back on help?

more options

Thanks Jeff

media.mediasource.enabled was False ... and turned to True.

more options

Hi Greg, I don't know how that happened, but I'm glad we figured it out quickly.

more options

I've had this problem for months, if using Firefox standard release. It doesn't occur when using Beta or Nightly. I figured it would eventually propagate through to the final release build, but so far, it hasn't. Video support test yields same results for all three. Config settings(for media.mediasource....) are the same for all three. Just in case, I enabled "experimental" as well.

Modificato da vic.martin il

more options

Hi vic.martin, did you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?