Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

"Plugins will be installed shortly" but never actually install (Widevine + H264)

  • 22 risposte
  • 1 ha questo problema
  • 94 visualizzazioni
  • Ultima risposta di bvandyk

more options

Hi,

Problem as described in the title. I've read some similar questions and answers, but nothing ever helped.

I already tried the following steps (none of them helped): - Checking for updates - Toggling DRM on/off - Uninstall Firefox completely (delete profiles, too and so on) - Changing some DRM or Plugin related config in about:config like media.peerconnection.video.h264 (and of course reverting it after that) - Looking for XHR requests when toggling DRM on/off or visting a site with DRM content. I couldn't figure out what I'm actually looking for, though... - Switching off Firewall/Antivirus or the TLS filtering (Eset) for a moment - Looking for suspicious requests in some router protocols or dashboards or whatever

Thanks in advance!

Immagini allegate

Modificato da Volatilize il

Soluzione scelta

Edit: I've tested the below myself, so you don't have to unless you want to double check. It seems the # in the path to the temporary directory breaks Firefox. I'll report this as a bug and see what can be done.

Is the profile still being created under the User# dir (you can check by navigating to `about:support`)? If so, could you try using the Firefox Profile Manager (https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles#w_start-the-profile-manager-when-firefox-is-closed) to create a profile that's in a different directory? During profile creation you should be given the option to choose a folder, and if you pick one in another location that will help narrow the issue.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (20)

more options

Anyone?

È stato utile?

more options

hi, what's happening when you attempt to load this link?: https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1582.2-win-x64.zip

È stato utile?

more options

Hi, I'm asked if I want to download this .zip. And then there are some dll files in there but I'm not sure what to do with them. Should I open or run them? Or what did you want to check?

È stato utile?

more options

i just wanted to check if you can access the url without any error messages - common causes for this error would be a custom hosts file that blocks network access to the gvt1.com domain where the plugin is hosted (doesn't seem to be the case for you) or antivirus software that's intercepting secure connections. with eset, the latter thing may be somewhat likely too - can you try to leave tls filtering off for a day or two and see if this helps?

È stato utile?

more options

Yes, of course. It's turned off now. I'll check Firefox again soon and post the result here.

Modificato da Volatilize il

È stato utile?

more options

Until now, there's no change. The plugins won't install. Maybe the problem lies somewhere else?

È stato utile?

more options

thanks, then another url to try (it should get a result like in the screenshot attached): https://aus5.mozilla.org/update/3/GMP/80.0.1/20200831163820/WINNT_x86-msvc-x64/de/release/Windows_NT%2010.0.0.0.19041.508%20(x64)/default/default/update.xml

more troubleshooting steps would be to enter about:config into the address bar, search for preferences containing "gmp" and resetting/deleting all those custom preferences displayed in bold and restart the browser once.

in about:addons > plugins you can also try to click on the openh264/widevine entries and set automatic updates to "on".

È stato utile?

more options

You can check DRM content via this website.

If you toggle DRM off/on the you should see a XHR request in the Browser Console.

The OpenH264 plugin is used for WebRTC and that can be more difficult to test.

È stato utile?

more options

philipp said

thanks, then another url to try (it should get a result like in the screenshot attached): https://aus5.mozilla.org/update/3/GMP/80.0.1/20200831163820/WINNT_x86-msvc-x64/de/release/Windows_NT%2010.0.0.0.19041.508%20(x64)/default/default/update.xml more troubleshooting steps would be to enter about:config into the address bar, search for preferences containing "gmp" and resetting/deleting all those custom preferences displayed in bold and restart the browser once. in about:addons > plugins you can also try to click on the openh264/widevine entries and set automatic updates to "on".

The url works as seen in my screenshot.

But deleting the bold gmp settings doesn't get any results, addons still claim to be installed.

Do you think there's a faulty url so Firefox can't install them in some background process?

È stato utile?

more options

cor-el said

You can check DRM content via this website. If you toggle DRM off/on the you should see a XHR request in the Browser Console. The OpenH264 plugin is used for WebRTC and that can be more difficult to test.

I tried it with the Shakaplayer. It only says that there needs to be something installed (because of DRM).

I think I always looked into the webconsole... That's why I never saw anything. The browserconsole looks different: There's seems to be a problem with extracting a .zip file as shown in the screenshot.

È stato utile?

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

È stato utile?

more options

cor-el said

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Restartet the PC in Safe mode with network. Unfortunately, the result is exactly the same as in my last Screenshot: GMPExtractor Failed to extract zip file: C:\Users\User#\AppData\Local\Temp\tmpaddon-7d11e5 when toggling DRM on and off.

Modificato da Volatilize il

È stato utile?

more options

Hmm, seems to be a specific problem with my PC and not with firefox?

È stato utile?

more options

Is there maybe another solution?

È stato utile?

more options

It looks like Firefox is failing to extract the plugins. I wonder if the directory it's using is causing issues. Does your username contain any special characters? If so, could you try creating a user with a name like 'temp' and seeing if the problem persists?

È stato utile?

more options

bvandyk said

It looks like Firefox is failing to extract the plugins. I wonder if the directory it's using is causing issues. Does your username contain any special characters? If so, could you try creating a user with a name like 'temp' and seeing if the problem persists?

I'm sorry but stupid question: What username do you mean? The Windows? It doesn't have any special characters. But on C: the user path is C:\Users\User#

È stato utile?

more options

Volatilize said

bvandyk said

It looks like Firefox is failing to extract the plugins. I wonder if the directory it's using is causing issues. Does your username contain any special characters? If so, could you try creating a user with a name like 'temp' and seeing if the problem persists?

I'm sorry but stupid question: What username do you mean? The Windows? It doesn't have any special characters. But on C: the user path is C:\Users\User#

That's the one (the Windows one). Your Firefox profile is created under the users directory, and its possible that the path or permissions involved could upset the extraction of the plugins. I'm not sure if the hash in the path there could cause issues. If it were causing issues, it would make sense those issues would persist through profiles -- as all profiles would be created under that dir. If you create another Windows user with a different name (not as a permanent solution, but to test) and see if the issue persists, that would be interesting to know.

È stato utile?

more options

bvandyk said

Volatilize said

bvandyk said

It looks like Firefox is failing to extract the plugins. I wonder if the directory it's using is causing issues. Does your username contain any special characters? If so, could you try creating a user with a name like 'temp' and seeing if the problem persists?

I'm sorry but stupid question: What username do you mean? The Windows? It doesn't have any special characters. But on C: the user path is C:\Users\User#

That's the one (the Windows one). Your Firefox profile is created under the users directory, and its possible that the path or permissions involved could upset the extraction of the plugins. I'm not sure if the hash in the path there could cause issues. If it were causing issues, it would make sense those issues would persist through profiles -- as all profiles would be created under that dir. If you create another Windows user with a different name (not as a permanent solution, but to test) and see if the issue persists, that would be interesting to know.

It seems that you were right. Creating a second "Test" account on Windows solves the problem. That's why I renamed my default account and created a new profile in Firefox. Unfortunalely, the issue still won't fix. I think the problem lies in the userpath name: C:\Users\User#\AppData. The "#" doesn't fit, or shouldn't that be a problem? I'll try to rename the userpath.

Modificato da Volatilize il

È stato utile?

more options

Soluzione scelta

Edit: I've tested the below myself, so you don't have to unless you want to double check. It seems the # in the path to the temporary directory breaks Firefox. I'll report this as a bug and see what can be done.

Is the profile still being created under the User# dir (you can check by navigating to `about:support`)? If so, could you try using the Firefox Profile Manager (https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles#w_start-the-profile-manager-when-firefox-is-closed) to create a profile that's in a different directory? During profile creation you should be given the option to choose a folder, and if you pick one in another location that will help narrow the issue.

Modificato da bvandyk il

È stato utile?

more options

The bug tracking this can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=1668372

I'm hoping to have a fix ready for Firefox Nightly in the next week or two, after which it will take 2 release cycles (8 weeks total) to make it to release.

È stato utile?

  1. 1
  2. 2
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.