Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Turn off the control media playback via harware media keys

  • 9 risposte
  • 7 hanno questo problema
  • 5713 visualizzazioni
  • Ultima risposta di PedroSilva_

more options

Can I turn off the "control media playback via hardware media keys on a keyboard or headset or virtual media control interface" function? (Firefox 81.0, Windows 10)

Immagini allegate

Soluzione scelta

To disable it, enter about:config in the URL bar and set media.hardwaremediakeys.enabled = false.

Leggere questa risposta nel contesto 👍 8

Tutte le risposte (9)

more options

Soluzione scelta

To disable it, enter about:config in the URL bar and set media.hardwaremediakeys.enabled = false.

È stato utile?

more options

I have this same problem and seems to coincide with version 81 being installed. If you look at the screenshot you can see I've set media.hardwaremediakeys.enabled to false and hit volume button on keyboard and the box still pops up. This just started today and I've wasted about an hour at this point trying to resolve this issue. I use my keyboard volume key all the time because nobody's video is set to a standard volume. What did you do to make this obnoxious box start popping up on my screen?

È stato utile?

more options

Hi traysco2t

Did you close and restart Firefox after modifying media.hardwaremediakeys.enabled on the about:config page ?

I notice another media.hardware pref with a false value (second one in the list) that you apparently created yourself as this pref has a trashcan next to it meaning that this pref isn't present by default.

È stato utile?

more options

I've used FF for the past 14 years and donated. I absolutely love it, and always have.

But I'm sure anyone who comes from google into this thread will agree with me: This change This change is annoying as excreta.

Please include "media.hardwaremediakeys.enabled" in the UI in a future update. Thanks.

Edit: Or not, well I really hope the guy that downvoted me enjoys having random aspects of his Firefox starting / stopping when pressing media control keys while listening to Spotify. Enjoy.

Modificato da andrw80 il

È stato utile?

more options

this feature is incredibly annoying and it is way too convoluted to turn off. it is also really annoying that it shows up on the lock screen of all places and permits users to interact with your media while the computer is locked

È stato utile?

more options

Agreed. This change was incredibly idiotic to leave enabled by default, as YouTube, Soundcloud and many other sites do not play well with this change. Spotify should take priority as it can properly interpret hardware media key controls. YouTube and Soundcloud cannot. The media keys do not work properly, at all, and I find it hard to see why anyone would expect them to without custom fixes made.

Just to list what kind of buggy interaction occurs, for just about every website, when resuming playback by pressing a Play/Pause media key, the site will not respond for several seconds. After several seconds, the media will suddenly start playing. I also cannot seem to pause it once it starts playing, but I can pause before it resumes a few seconds later. Once it starts playing, any and all media key interactions completely fail.

È stato utile?

more options

Ok, I can disable media keys in Firefox, but it only stopped them from playing sound in random tab. Keys still do not work properly. Instead of managing my Spotify music playback, wthey do nothing at all. What else can I do? (yes, I have restarted Firefox after applying changes)

È stato utile?

more options

tomek3001 said

Ok, I can disable media keys in Firefox, but it only stopped them from playing sound in random tab. Keys still do not work properly. Instead of managing my Spotify music playback, wthey do nothing at all. What else can I do? (yes, I have restarted Firefox after applying changes)

Having the same problem. Did as suggested and now my hotkeys simply do nothing at all while Firefox is in focus. Wondering if it's a Windows issue after all, although I haven't had any system updates recently enough to explain it.

È stato utile?

more options

I would like to deactivate only the NOTIFICATION BAR but not the functions. Is it possible? This is very boring and is extremely inconvenient for privacy.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.