Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Watching youtube result in high resource usage

  • 2 risposte
  • 1 ha questo problema
  • 3 visualizzazioni
  • Ultima risposta di ron

more options

I m using the latest version of firefox. I notice my laptop gets very hot when viewing any youtube video. So I ran a test to compare against chrome and I believe it is a firefox problem. Here is the test:

Close all programs, open firefox, play a youtube video for a min, observe (total) cpu utilization~40%, gpu~35% Close firefox, open chrome, play the same video at the exact same resolution, cpu util~25%, gpu7% Close chrome, open firefox, play the same video, cpu util~40%, gpu~35%

Not sure why chrome uses much less resource then firefox. Is there a magic setting somewhere? Prefer to stay with firefox but if overheating continues, have no choice but to move to chrome. Thanks.

I m using the latest version of firefox. I notice my laptop gets very hot when viewing any youtube video. So I ran a test to compare against chrome and I believe it is a firefox problem. Here is the test: Close all programs, open firefox, play a youtube video for a min, observe (total) cpu utilization~40%, gpu~35% Close firefox, open chrome, play the same video at the exact same resolution, cpu util~25%, gpu7% Close chrome, open firefox, play the same video, cpu util~40%, gpu~35% Not sure why chrome uses much less resource then firefox. Is there a magic setting somewhere? Prefer to stay with firefox but if overheating continues, have no choice but to move to chrome. Thanks.

Tutte le risposte (2)

more options

hello, I think the only other settings which are changed in Safe Mode are for Themes and turning off your bookmarks toolbar.

When you started Firefox normally, then disabled your extensions, it could still be an extension causing the problem.

Try disabling all of your extensions, then Close Firefox. Start Firefox again normally and see if the problem persists.

If it works OK then, it's probably a faulty extension. Enable your extensions one-at-a-time to see which one is causing the problem.

more options

I notice that if I turn off 'use recommended performance setting' and set 'use hardware acceleration' to OFF, the cpu utilization is actually lower (gpu=0% obviously). It appears using hardware acceleration actually make things worse for firefox.