Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Almost every site is broken in Firefox 77

  • 10 risposte
  • 3 hanno questo problema
  • 582 visualizzazioni
  • Ultima risposta di Eojie

more options

I just upgraded to Firefox 77, x64, Windows 10 2004.

Firefox 76 already broke LockWise - https://support.mozilla.org/en-US/questions/1287008

Now Firefox 77 breaks 99% of all websites. (See attached screenshot.) www.example.com www.google.com www.wikipedia.org etc

Somehow, support.mozilla.org works, UNTIL I try to log in.

I've tried incognito mode, safe mode, etc. When I change charset of the page, the text displays differently, but it's still a useless mishmash.

--- BUT --- when I open developer tools, click the HTML request and click the Response tab, the HTML renders correctly there.

Immagini allegate

Soluzione scelta

Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

  • Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (10)

more options

The message from webhelp2 above is NOT Mozilla support.

È stato utile?

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop


Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer.


If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

È stato utile?

more options

Thanks for your input. In the end I have downgraded to Firefox 75, and kept my profiles intact with the `-allow-downgrade` flag.

(LockWise still shows an empty screen though, see linked issue.)

Modificato da milan2 il

È stato utile?

more options

Hi milan2, another user reported a similar display problem:

https://support.mozilla.org/questions/1289441

It looks similar to an old issue with Brotli encoding, but that is only used for HTTPS addresses, and your screenshot shows an HTTP connection. Very strange.

I wonder whether it might be related to WebRender, a new graphics back end? Hopefully someone more conversant with troubleshooting graphics issues can work on that with you.

È stato utile?

more options

Soluzione scelta

Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

  • Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

È stato utile?

more options

Thanks @cor-el. You're _almost_ right.

I had a system env variable MOZ_FORCE_DISABLE_E10S=0

I've had it set to 1 because I was investigating other crashes, and when I fixed those, I changed it to 0, but apparently Firefox still had e10s turned off (I can confirm it was running in 1 process only).

Anyway, both 77.0.1 and 78 nightly now work correctly (after removing the system variable and restarting). Thanks for helping!

Modificato da milan2 il

È stato utile?

more options

In a lot of cases the value of an environment variable doesn't matter, merely the presence is sufficient to make it active.

È stato utile?

more options

I mean... yeah, it kinda makes sense for people who set it to "true" or "yes", but IMHO it would be a good general rule to parse values "no", "false", "0" and empty string, and ignore the flag. But I get this is a very niche problem. Lesson learned, thanks again to both of you for helping :)

È stato utile?

more options

On Reddit, someone said this worked for them:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste ppdc and pause while the list is filtered

(3) Double-click the browser.tabs.documentchannel.ppdc preference to switch the value from true to false

I don't know what that does.

More info on about:config: Configuration Editor for Firefox.

È stato utile?

more options

jscher2000 said

On Reddit, someone said this worked for them: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste ppdc and pause while the list is filtered (3) Double-click the browser.tabs.documentchannel.ppdc preference to switch the value from true to false I don't know what that does. More info on about:config: Configuration Editor for Firefox.

Just writing to share that changing browser.tabs.documentchannel.ppdc value to false did it for me. I've reverted all of the other config changes mentioned above to their original values so I can confirm only this piece worked.

Firefox 77.0.1 x64 Windows 10

PS: Thanks, jscher2000

Modificato da Eojie il

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.