Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

default programs changed

  • 4 risposte
  • 1 ha questo problema
  • Ultima risposta di jscher2000

more options

how is my default pdf program changing; others can get in to change it from Foxit to WPS . It comes up in a mini widow below to open with WPS for a pdf file. Who allows this to be changed when I select my default pdf viewer ?

All Replies (4)

more options

Hello ThaiED, The reason it changed may be because you selected "Always open pdf with this". Just simply change your default pdf reader again and the next time you open a pdf, change the app you are using. Tell me if that helped and Stay Safe!

Helpful?

more options

Change it many times it can stay as default in the setup but others can open it  ; they override. In my task menu I have wps viewer as it opens itself and when ever there is a download; it asks to open it in its own windows on bottom right. ITs a "wps office program trying to open my pdf. How can those programs even be allowed to popup to offer to open a file ?

Helpful?

more options

ThaiED said

How can those programs even be allowed to popup to offer to open a file ?

Good question, I'm not completely sure about that but I'll keep researching about it. It probably has something to do with Windows.

Helpful?

more options

Hi ThaiED, could you explain this part or illustrate what it looks like with a screenshot:

ThaiED said

In my task menu I have wps viewer as it opens itself and when ever there is a download; it asks to open it in its own windows on bottom right.

That sounds like something different than the normal Firefox download dialog.

I think you have already checked, but just in case, what do you have on the Options page for "Portable Document Format" files: Preview in Firefox, Use Foxit, or something else? This article has the steps to get to that setting: View PDF files in Firefox or choose another viewer.

- - - -

One possible culprit for odd handling of downloads would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

- - - -

Finally, your Firefox identified itself as version 59, which is no longer supported. Can you update to a current version?

Helpful?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.